Problemas ao conectar fone de ouvido bluetooth

A principio, eu estava com problemas ao usar o microfone do meu fone de ouvido, o fone conectava porém não aparecia o microfone.

Primeiramente eu achei o seguinte link:
https://www.vivaolinux.com.br/topico/Ubuntu-e-Kubuntu/Ubuntu-1704-nao-reconhece-o-microfone-do-Headset

onde pedia para eu abrir o arquivo:
/etc/modprobe.d/alsa-base.conf
e adicionar a seginte linha:
options snd-hda-intel model=dell-headset-multi
porém não funcionou(mesmo eu reiniciando o computador)

Achei mais outra matéria: sound - Headphones microphone is not working - Ask Ubuntu
E eu segui as seguintes orientações:
Eu editei o arquivo
/etc/pulse/default.pa
e alterei a linha
de: load-module module-bluetooth-policy
para: load-module module-bluetooth-policy auto_switch=2

e rodei o seguinte comando:
pulseaudio -k e pulseaudio -D
O primeiro não retornou nada e o segundo retronou:
E: [pulseaudio] main.c: Falha na partida do daemon.

pesquisei sobre o erro e encontrei a seguinte matéria:
https://www.vivaolinux.com.br/topico/Linux-Basico/Como-ativar-o-PulseAudio

Seguindo a recomendação, reinstalei o pulseaudio, seguindo o passo a passo da matéria

em resumo fiz um sudo apt-get purge pulseaudio, depois um install e alterei o arquivo
/etc/avahi/avahi-daemon.conf setando o use-ipv6=no

depois de não resolver(tomei o cuidado de reiniciar a cada alteração) tentei uma recomendação anterior:
instalar o blueman.

Agora além do microfone não funcionar, o fone não aguenta 2 segundos conectado que logo se desconecta.
O fone é um fone Bluetooth da xiaomi
Eu uso o elementary os*

Talvez te ajude.