Problema pra instalar pacote R (software de estatística)

Boa noite, pessoal

Pretendo instalar o Iramuteq, que é um software de análise lexical, só a instalção do R deve acontecer antes.
O problema é que a versão mais atual é a 4.0, eu desejo instalar a 3.5 e a que estão nos repositórios oficiais do meu linux mint 19.1 é a 3.4.
Mesmo que eu coloque um ppa, a versão instalada será a 3.4.

Me recomendaram compilar, mas eu não sei bem como fazer isso. Se tiver outro método ou alguém me ajudar nessa compilação, eu agradeço bastante.

1 curtida

testei aqui em uma maquina virtual
tive vários problemas de dependências e cheguei a conclusão de:
habilite o repositório universe:
sudo add-apt-repository universe

e tente novamente

Opa, boa tarde, @Talls
Dpois de habilitar o repositório universe, eu só procedo a instalação do R normalmente?

1 curtida

sim.
explicação: o pacote R tem uma dependência que estar no universe,com o universe debilitado o apt instala a versão anterior já que este tem todas as dependências satisfeitas.

1 curtida

Massa. Muito obrigado pela ajuda.

1 curtida

Ei, @Talls
Adicionei o repositório, mas quando vou instalar o R, ele expõe isso:
caio:/etc/apt/sources.list.d$ sudo apt-get install r-base r-recommended r-cran-foreign r-base-core
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da “Incoming”.
A informação a seguir pode ajudar a resolver a situação:

> Os pacotes a seguir têm dependências desencontradas:
> r-cran-foreign : Depende: r-base-core (>= 3.6.3-1bionic) mas 3.4.4-1ubuntu1 está para ser instalado
> Depende: r-api-3.5 mas não é instalável
> E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
> caio:/etc/apt/sources.list.d$ sudo apt-get install r-base r-recommended r-cran-foreign r-base-core r-apiLendo listas de pacotes… Pronto
*> Construindo árvore de dependências *
> Lendo informação de estado… Pronto
> E: Impossível encontrar o pacote r-api
> caio:/etc/apt/sources.list.d$

poderia me mandar a saída do comando:

sudo apt update

quando estava testando, tive problemas para adicionar o ppa pode ser isso.
há e também o conteúdo do seu sourcelist

cat /etc/apt/sources.list