Problema na atualização ubuntu

logo abaixo segue o erro que estou tendo ao atualizar:

A preparar para desempacotar …/grub-efi-amd64_2.04-1ubuntu44.1_amd64.deb …
A descompactar grub-efi-amd64 (2.04-1ubuntu44.1) sobre (2.04-1ubuntu44) …
A preparar para desempacotar …/grub-efi-amd64-signed_1.167~18.04.3+2.04-1ubuntu44.1_amd64.deb …
A descompactar grub-efi-amd64-signed (1.167~18.04.3+2.04-1ubuntu44.1) sobre (1.167~18.04.1+2.04-1ubuntu44) …
A preparar para desempacotar …/grub-efi-amd64-bin_2.04-1ubuntu44.1_amd64.deb …
A descompactar grub-efi-amd64-bin (2.04-1ubuntu44.1) sobre (2.04-1ubuntu44) …
A preparar para desempacotar …/ubuntu-drivers-common_1%3a0.8.6.3~0.18.04.1_amd64.deb …
A descompactar ubuntu-drivers-common (1:0.8.6.3~0.18.04.1) sobre (1:0.5.3~ppa3) …
Configurando grub-efi-amd64-bin (2.04-1ubuntu44.1) …
Configurando grub-efi-amd64 (2.04-1ubuntu44.1) …
od: /sys/firmware/efi/efivars/SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c: Operação não permitida
/usr/share/grub/grub-check-signatures: 22: [: Illegal number:
dpkg: erro ao processar o pacote grub-efi-amd64 (–configure):
installed grub-efi-amd64 package post-installation script subprocess returned error exit status 255
dpkg: problemas com dependências impedem a configuração de grub-efi-amd64-signed:
grub-efi-amd64-signed depende de grub-efi-amd64 | grub-pc; porém:
Pacote grub-efi-amd64 não está configurado ainda.
Pacote grub-pc não está instalado.

dpkg: erro ao processar o pacote grub-efi-amd64-signed (–configure):
problemas de dependência - deixando desconfigurado
Configurando ubuntu-drivers-common (1:0.8.6.3~0.18.04.1) …
Nenhum relatório apport escrito pois a mensagem de erro indica que é um erro de seguimento de um erro anterior.
Erros foram encontrados durante o processamento de:
grub-efi-amd64
grub-efi-amd64-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)

Tenta o procedimento padrão: sudo apt autoremove
E depois:
sudo apt update && sudo apt full-upgrade && sudo apt autoclean

1 - sudo dpk --configure -a
2 - sudo apt-get install -f
3 - sudo apt-get remove ––purge + nome do pacote com problema
4 - sudo apt autoremove

OBS: sempre que pedir ajuda informe tambem quais os comandos usados para que ouvesse o respectivo erro , qual o programa que está tentando instalar ou versão da distribuição usada , etc.
isso ajuda a resolver o problema em um menor tempo possivél.

2 Curtidas

obrigado, me ajudou muito! agradeço igualmente a todos que responderam ao tópico :grinning:

1 Curtida