Problema com permissões em arquivos e pastas de HD montado

Bom, eu configurei um dual boot (Zorin OS 16 e Windows 10) no meu pc, e nele tenho dois HD’s instalados:

  • O principal que uso pra armazenar os sistemas operacionais (reconhecido aqui como SDA)
  • E um secundário que uso para manter meus arquivos (reconhecido aqui como SDB)

Ambos de 500gb da marca Seagate (Mais informações sobre eles abaixo)

Meu problema é que não consigo fazer certas coisas no HD secundário, como recortar ou renomear arquivos e pastas. Segui tutoriais para montar esse HD e consigo acessar os arquivos direitinho, mas num modo de somente leitura. Se eu tento alterar essas permissões vejo a mensagem de que não sou o proprietário (root) e acabo não conseguindo alterar nada.

Eu já usava esse setup desse jeito e funcionava muito bem, não tinha esses problemas, só que depois que precisei formatar pra reinstalar o Zorin OS depois de “quebrar” o sistema, comecei a passar por isso.

Segui vários tutoriais me instruindo a inserir comandos no terminal pra resolver isso, mas até agora nada deu certo e sinceramente eu não entendi muita coisa deles não, pois ainda não estou familiarizado com linux.

Se alguém souber me dizer como consigo acesso completo com as permissões necessárias pra mexer nesse HD, agradeço! Vou deixar aqui embaixo as informações necessárias, caso ajude!

[email protected]:~$ inxi -F --filter
System:
  Kernel: 5.13.0-30-generic x86_64 bits: 64 Desktop: Gnome 3.38.4 
  Distro: Zorin OS 16.1 
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A78L-M LX/BR v: Rev X.0x 
  serial: <filter> BIOS: American Megatrends v: 1101 date: 04/19/2013 
CPU:
  Topology: Quad Core model: AMD FX-4300 bits: 64 type: MCP 
  L2 cache: 2048 KiB 
  Speed: 1404 MHz min/max: 1400/3800 MHz Core speeds (MHz): 1: 1404 2: 1405 
  3: 1403 4: 1406 
Graphics:
  Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 470.103.01 
  Display: x11 server: X.Org 1.20.13 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa 
  resolution: 1280x960~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: NVIDIA GeForce GT 1030/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.103.01 
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel 
  Device-2: NVIDIA GP108 High Definition Audio driver: snd_hda_intel 
  Device-3: Texas Instruments PCM2902 Audio Codec type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k5.13.0-30-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 931.52 GiB used: 380.36 GiB (40.8%) 
  ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB 
Partition:
  ID-1: / size: 94.72 GiB used: 48.05 GiB (50.7%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: 52.0 C gpu: nvidia temp: 37 C 
  Fan Speeds (RPM): cpu: 2626 case-1: 0 
Info:
  Processes: 280 Uptime: 8h 33m Memory: 7.69 GiB used: 3.29 GiB (42.8%) 
  Shell: bash inxi: 3.0.38 

(Informações do "Discos" abaixo)

- HD Principal

500 GB Hard Disk
/dev/sda

Modelo: ST500DM002-1BD142 (HP73)
Tamanho: 500 GB (500.107.862.016 bytes)
Particionamento: Master Boot Record
Número de Série: Z3T31696
Avaliação: O disco está OK, 8 setores defeituosos (40 °C / 104 °F)

(No caso quando formatei, eu deixei tudo como estava, e só formatei a partição onde o Zorin OS estava instalado antes, e seria reinstalado depois. Mantive o resto das partições pra não apagar o Windows ou as configurações de dual boot, além das partições que francamente, não sei pra que servem, só sei que estão lá, então deixas elas quietas)



- HD Secundário

500 GB Hard Disk
/dev/sdb

Modelo: ST500DM002-1BD142 (KC48)
Tamanho: 500 GB (500.107.862.016 bytes)
Particionamento: Master Boot Record
Número de Série: Z6EP75R4
Avaliação: O disco está OK (36 °C / 97 °F)

Tamanho: 500 GB — 143 GB livres (71,4% ocupados)
Dispositivo: /dev/sdb1
UUID: 6CA0AE29A0ADF9AA
Tipo de Partição: NTFS/exFAT/HPFS (Bootable)
Conteúdo: NTFS — Montado em /mnt/sdb1

Se tiver algo errado no post, é só me dar um toque que eu arrumo! Não sou muito familiarizado com fóruns, então tudo isso é meio novo pra mim.

Opa! Manda um print tbm do particionamento dos discos (usa o Gnome Discos pra isso) e diga qual partição está com problemas para gravação e se é ext4 ou ntfs

1 curtida

Gnome Discos seria o “Discos” que já vem no Zorin? Se sim, foi nele que vi essas infos, segue os prints de cada HD

HD Primário

HD Secundário (Que é onde estou tendo problemas)

Sim, é o discos mesmo

Parece que sua home está junto da raiz do Zorin, então o problema é a partição NTFS (que imagino que no Windows seja o D:). Provavelmente a hibernação e o fast boot devem estar ativos no Windows - pesquise como desativá-los, é bem fácil.

Para montar essa partição automaticamente no sistema (vc não poderá usá-la como home, pra isso ela precisaria estar em ext4 ou outro formato de arquivos nativo das distros Linux), pode seguir este tutorial, ele usa esse mesmo discos

Apenas mantenha a opção “auto” no sistema de arquivos, podendo deixar mais ou menos como eu uso

Por fim, no gerenciador de arquivos (assim como na janela que abre quando se coloca “salvar como” ou “abrir”), entre na raiz do sistema, procure a pasta /mnt, lá estará seu disco, basta arrastar para o painel lateral da esquerda e criar um atalho para sua partição (pode renomear se quiser)

3 curtidas

Deu certo!
Segui o tutorial que você linkou e alterei as configurações da hibernação e fast boot no W10, e agora tá funcionando direitinho!

Valeu irmão!

1 curtida

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.