Pop!_OS: Vídeos travando

Opa. Com muita dificuldade consegui instalar o Pop!_OS mas to tendo problemas em assistir vídeos pelo youtube, netflix, prime video e afins. Os vídeos travam de vez em quando e só o áudio continua. Alguém sabe me informar do que se trata? To usando o Google Chrome pra ver os vídeos. Já instalei codecs de vídeo e não adiantou nada.

por favor, mais informação.

quanto de memória vc tem?
qual sua placa de vídeo?
já tentou desativar a aceleração de hardware de vídeo no Firefox ou Chrome?

Firefox
Para desativar a aceleração de hardware no Firefox :

  • Clique no menu e selecione Opções. Preferências.
  • Selecione o painel Avançado e a aba Geral.
  • Desmarque a opção Usar aceleração de hardware quando disponível.
  • Clique no menu do Firefox e selecione Sair. …
  • Inicie o Firefox como costuma fazer normalmente.

já tentou criar o arquivo
/etc/sysctl.d/99-sysctl.conf

com o seguinte conteúdo

#
# Reduz o uso de SWAP
vm.swappiness=1

Só usa a swap quando não houver mais jeito.

Tenho 10gb de RAM e uso o Linux em um HD de 80gb. Minha placa de vídeo é uma GT 710 de 1gb. Vou tentar desativar aceleração de hardware.

Qual é a versão do driver da NVIDIA que você está usando?

Entao provavelmente é a aceleração de hardware.
Não conheço pop. Nunca instalei, nem via virtuealização, mas vejo muita reclamação deste sistema…
Talvez seja interessante usar outra distro

DE repente configurando a aceleração funcione…
Mas não sei como faz isso neste sistema, ou se ele já configura sozinho.

já tentou usar outro browser? já tive problemas do tipo utilizando o firefox e quando testei no Brave e no Chrome funcionou normal.

no chrome vem desativado por padrão…

tente ativar

Ativei a aceleração de hardware e aparentemente funcionou. Se não mudar eu vou trocar de distro

O problema não é a distro, mas sim os navegadores que não tem suporte nenhum a aceleração de vídeo por hardware (no Firefox é pior ainda porque não tem suporte a aceleração de hardware de modo geral).

Eu estava com esse problema e instalei o pacote ubuntu-restricted-extras (sudo apt-get install ubuntu-restricted-extras) e resolveu.

O problema persistiu, instalei o Ubuntu e o problema continuou, daí instalei o Linux Mint e não teve mais o problema. Aparentemente meu computador não gosta de Gnome. Vai entender… (desculpem a demora pessoal)

Boa noite

Pessoal, estou enfrentando o mesmo problema no POP OS 20.04… videos no youtube no Chrome nao tem fluidez que tem no Firefox.
Testei todas as dicas acima, e não adiantou… Uso uma Radeon como GPU … e nao tibe problema semelhante em outras distros com Gnome.

Alguma dica adicional?

Obrigado

Uso o notebook em modo híbrido e no Xorg. (Intel + Nvidia)

Chrome

Eu ativo a aceleração em Configurações - Sistema:

Ativo também as seguintes opções em chrome://flags para a aceleração de hardware:

Override sofware rendering list

GPU rasterization

Hardware-accelerated video decode

chrome://gpu

image

Firefox
Eu habilito a aceleração de hardware em Preferências.

image

Em about:config eu mudo o valor para true nas seguintes opções.

gfx.webrender.all, gfx.webrender.enabled, layers.acceleration.force-enabled, media.ffmpeg.vaapi.enabled, media.ffmpeg.vaapi-drm-display.enabled, gfx.prefer-x11-egl, gfx.x11-egl.force-enabled, media.ffmpeg.enabled, media.ffmpeg.vaapi-drm-display.enabled, media.ffmpeg.vaapi.enabled.

Em layout.frame_rate eu coloco o valor de 60.

This pref determines how frequently the refresh driver ticks. The refresh driver is the mechanism that fires requestAnimationFrame and does painting.

Para verificar se a aceleração está habilitada no Firefox digite na barra de endereços about:support .

image

image

image

No meu notebook ficou excelente. Uso o notebook em modo híbrido.
Lenovo IdeaPad S145-15IWL, Intel Core i7-8565U, 12GB de RAM, SSD 240GB, SSD 512GB M.2 NVMe, NVIDIA GeForce MX110, Pop!_OS 20.04 LTS.

Eu imagino que sejam essas as configurações corretas. Caso eu tenha feito algo errado ou desnecessário, por favor, me informem. Cheguei nessas configurações após pesquisar sobre o tema na internet.

Eu tive esse problema em todas as distros gnome debian based. E outro bug chato que tive era do Discord travando quando eu estava em call. Depois que eu mudei para o fedora gnome, nunca mais tive nenhum problema relacionado. Recomendo testar se você quiser usar gnome.

Boa noite Henrique

Muito obrigado pelas dicas, creio que vai ajudar muita gente como me ajudou.
Mais foi algo simples, fiz o processo inverso… desativei a aceleração e… BINGO… resolveu.

Espero que as dicas ajudem mais pessoas.

1 curtida

Qual configuração do seu computador? Pq eu já instalei o pop os até num notebook com Intel i3 de 3 geração e nunca ocorreu erros na reprodução de vídeos seja no Chrome, no Firefox, Vivaldi ou Opera, em todos eles rodaram bem, agora quanto ao Netflix e Prime Vídeo existe um recurso chamado DRM que se não tiver habilitado os serviços de streaming de vídeos não funcionam…

Olá, swatquest, notei que no dentro do diretório /etc/sysctl.d existe um arquivo 10-pop-default-settings.conf no qual tem uma linha referente ao uso de swap, posso alterar o valor para 1, como vc sugeriu, neste arquivo ou devo usar o 99-sysctl.conf.
Desculpa qq coisa e agradeço desde já qq resposta.

Rapaz, gostei do Pop_os, mas agora não consigo mais instalar. A live USB não carrega. Fiquei com meu MX Linux. Tá funcionando belezinha.

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.