Pop_OS: Troca de placa wifi

Olá,
troquei a placa wifi do meu notebook, por uma similar porém com suporte a 5GHz, o problema é que ao iniciar o Pop_os 20.04, ele reconhece como a placa antiga e não encontra as redes 5Ghz. Não encontrei como desinstalar o drive da placa antiga (novo em linux). Alguma solução?

Tenta fazer o seguinte:
sudo apt update
sudo apt full-upgrade
sudo apt autoremove
sudo apt autoclean

Obrigado @JG22 já tinha realizado esse procedimento, todos os pacotes estão atualizados, o problema é justamente ele achar que o drive wifi é o mesmo do antigo. Queria ver se tem como resetar isso e reiniciar para ele achar o modem novo.

Pelo oq eu saiba, o linux verifica todo o sistema antes de iniciar e carrega os drivers certos, ou seja, se vc colocar um novo hardware, e o drive estiver no kernel, ao reiniciar ele irá carregar o drive correto, diferente do windows, que tem um sistema para melhorar o tempo de boot, que salva quais os drivers q são utilizados no HD e carrega assim mais rápido.

Vc pode dizer qual a placa de wifi que vc tem ? e qual a antiga ?

@M.Mazur tinha uma DW1707 que venho no meu Dell, e a nova é uma Atheros QCNFA435.

Realmente o que pensei que o linux fosse atualizar, porém como minha experiência é pouca, não tinha certeza.

Já tentou verificar no gerenciador de drivers se tem outro driver para selecionar?

Eu só tentei fazer o apt update. No Pop_OS eu não sei onde tem um janela só para gerenciar os drivers, é diferente do mint que usei.

Roda

sudo lshw -C network

E posta a saida aqui

Digite Drivers na busca para ver se acha o gerenciador de drivers.

Normalmente o gerenciador de drive so verifica sobre drivers proprietarios, drivers de rede e nem de video q são inclusos no kernel aparece lá

1 curtida
  *-network                 
   descrição: Interface sem fio
   produto: QCA9377 802.11ac Wireless Network Adapter
   fabricante: Qualcomm Atheros
   ID físico: 0
   informações do barramento: [email protected]:01:00.0
   nome lógico: wlp1s0
   versão: 30
   serial: 34:68:95:7f:e2:19
   largura: 64 bits
   clock: 33MHz
   capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuração: broadcast=yes driver=ath10k_pci driverversion=5.11.0-7614-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 latency=0 link=no multicast=yes wireless=IEEE 802.11
   recursos: irq:129 memória:d1000000-d11fffff

*-network
descrição: Ethernet interface
produto: RTL810xE PCI Express Fast Ethernet controller
fabricante: Realtek Semiconductor Co., Ltd.
ID físico: 0
informações do barramento: [email protected]:02:00.0
nome lógico: enp2s0
versão: 07
serial: 84:7b:eb:fc:72:14
tamanho: 100Mbit/s
capacidade: 100Mbit/s
largura: 64 bits
clock: 33MHz
capacidades: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuração: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-7614-generic duplex=full firmware=rtl8106e-1_0.0.1 06/29/12 ip=192.168.0.214 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
recursos: irq:17 porta de E/S:e000(tamanho=256) memória:d1204000-d1204fff memória:d1200000-d1203fff

@anon34547030 sim já fucei em tudo antes de postar :wink:
Obrigado pela ajuda

@M.Mazur viu que ele reconhece como QCA9377 802.11ac Wireless Network Adapter? por isso procurava um modo de deletar e reinstalar.

Esse é o modelo do chip q sua placa de rede tem, e não o modelo da placa em si, por exemplo essa placa pode existir pra PC usando o mesmo chip, mas o modelo entre a placa para pc e notebook é difirente, mas o driver o mesmo

Vamos tentar reinstalar o drive mesmo, do jeito seguro ainda, depois qualquer coisa a gente tenta apagar a pasta com ele e reinstalar

sudo apt-get install --reinstall linux-firmware

E reinicia

1 curtida

Ok, reinstalando. Trago já o resultado. Obrigado desde já.

1 curtida

No pop os não vem instalado e nem era para ter nos repositórios, mais como ela e baseada no Ubuntu tem como instalar o gerenciador de driver/drivers adicionais instalando a gnome software

sudo apt install gnome-software

Infelizmente no mesmo.

Entendi. Vou ver se consigo com as opções de @M.Mazur se for o último caso, vou ver isso, mas é muito estranho não atualizar.

1 curtida

Se consegue conectar o pc no cabo ? Acho q o wifi vai continuar funcionando, mas, pode ser q não,

Abre o terminal e digita

sudo nautilus

Se vai abrir o gerenciador de arquivos como Root, tome cuidado q vc agora pode apagar pastas que podem quebrar o sistema, vai em outros locais, computador>lib>fimware encontre a pasta ath10k, apague ela. e feche.
Abra o terminal e rode novamente

sudo apt-get install --reinstall linux-firmware

e reinicie

2 curtidas

Sim, só estou conectando pelo cabo.
Fiz todos os procedimentos, tenho familiaridade com o root, apaguei a pasta indicada e fiz a reinstalação, porém nada mudou.
Não tem como apagarmos as configurações gerais de rede e usar a opção de reinstalação do firmware para refazer tudo? não sei se estou falando besteira.
A placa continua achando minha rede 2.4Ghz apenas.

Não é driver então, e nem o linux, tem outras redes 5ghz por ai ?

Vc tem acesso ao roteador ? muda o canal da rede 5ghz pra algum menor q 32

1 curtida