Pje Office e instalar de driver safenet bug no ubuntu 20.04

bom dia pessoal, sou advogado e estava usando normalmente meu certificado digital no linux mint 19.3, está acontecendo um bug chato em todas as flavours 20.04 do ubuntu, eu consigo instalar o pjeoffice normalmente, procedimento através deste site:

porém quando instalo o SafenetAuthenticationClient-BR-10.0.37-0_amd64.deb ele termina a instalação, coloca os icones e tudo porém percebi pela janela do terminal que alguns erros acontecem durante o processo, coisa que não acontece em outras distros baseadas no 18.04 lts.

olhem o erro:

"(Lendo banco de dados … 257849 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/SafenetAuthenticationClient-BR-10.0.37-0_amd64.deb …
Terminating eToken Service… done
Stopping pcscd (via systemctl): pcscd.serviceWarning: Stopping pcscd.service, but it can still be activated by:
** pcscd.socket**
.
A descompactar safenetauthenticationclient (10.0.37-0) sobre (10.0.37-0) …
Configurando safenetauthenticationclient (10.0.37-0) …
cat: /etc/xdg/menus/applications.menu: Arquivo ou diretório inexistente
warning: can’t add eToken submenu
Stopping pcscd (via systemctl): pcscd.serviceWarning: Stopping pcscd.service, but it can still be activated by:
** pcscd.socket**
.
pcscd: nenhum processo localizado
Starting pcscd (via systemctl): pcscd.service.
Warning: Stopping pcscd.service, but it can still be activated by:
** pcscd.socket**
A processar ‘triggers’ para systemd (245.4-4ubuntu1) …
A processar ‘triggers’ para libc-bin (2.31-0ubuntu9) …"

Aciono o Pjeoffice que fica no painel normalmente, porém executo o app safenet que dá crash logo depois.

para eu entrar com o certificado digital preciso dos dois funcionando. percebo tambẽm que o crash acontece apenas com o safenet.

se alguém puder ajudar, seria de grande valia.

1 Curtida

Pode se algum problema com dependências. É preciso verificar se essa versão do Safenet tem todas as dependências disponíveis nos repositórios do Ubuntu 20.04. Caso contrário vai ser necessário instalá-las manualmente.

1 Curtida

foi exatamente isso amigo. sanei as dependencias manualmente pois no repositorio 20.04 não tinham. abs e obrigado!

2 Curtidas

O fornecedor do software provavelmente no futuro irá atualizar as depedências do programa pra que sejam compatíveis com o Ubuntu 20.04, eliminando esse problema de ter que procurá-las e instalá-las manualmente. Fique de olho nas próximas versões do software.

1 Curtida

qual eram as dependências ? como vc encontrou?

1 Curtida

Tentar executar o programa do Token pelo terminal:
$/usr/bin/SACTools
verificar se há o erro "Assertion ‘lib’ failed, se sim…
digitar:
sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 /usr/lib/libcrypto.so.6

Depois reiniciar, e certificar que o token está conectado.

2 Curtidas

Amigo, na distro BigLinux, o Pje-office está funcionando de boa. Se quiser evitar dor de cabeça utilize a distro está com suporte no Fórum e no telegram. https://forum.biglinux.com.br/

Rapaz, essa tua solução foi perfeita. Depois de anos, aproveitei uma brecha no tempo do trabalho e resolvi formatar a máquina. Escolhi o popOS 20.04 para ter uma experiência nova (e estou gostando até agora; o GNOME é meio diferente daquilo que estou acostumado, mas está sendo uma boa experiência). Depois que instalei o driver do certificado, tive essa dificuldade. Então, após essa tua dica, tudo passou a funcionar sem problemas.

Abraço.

1 Curtida

Pra mim isso aqui funcionou perfeitamente! Obrigado @Fernando_Raposo

1 Curtida