Pacotes quebrados que não podem ser corrigidos - Debian Buster

Bom, instalei aqui o Debian 10 Buster com Gnome, instalei o i3WM e removi completamente o Gnome (sudo apt purge gnome* sudo apt purge nautilus sudo apt autoremove). Rodei um script para configurar a Polybar do Terminal Root e instalei o Nemo sem puxar o Cinnamon (sudo apt install nemo --no-install-recommends). Fiquei sem gerenciador de login mesmo, não acho necessário.
Fui então tentar instalar o WineHQ, seguindo o procedimento deles para o Debian.

╭─aghbi@airis-laptop ~ ╰─$ sudo apt install --install-recommends winehq-stable [sudo] senha para aghbi: Lendo listas de pacotes... Pronto Construindo árvore de dependências Lendo informação de estado... Pronto Alguns pacotes não puderam ser instalados. Isto pode significar que você solicitou uma situação impossível ou, se você está usando a distribuição instável, que alguns pacotes requeridos não foram criados ainda ou foram retirados da "Incoming". A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas: winehq-stable : Depende: wine-stable (= 5.0.0~buster) E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Tentei então instalar pelo synaptic:

(Caixa de diálogo)
Não foi possível aplicar as alterações! Corrija os pacotes quebrados primeiro.

Mas no próprio Synaptic aparece 0 pacotes quebrados, e o sudo apt --fix-broken install também não acha pacotes quebrados.

Pelo que to vendo o problema é no Wine, faça o seguinte:

Desinstale o Wine:

sudo apt remove wine*

Remova a PPA dele e a key. Só siga daqui pra frente se fizer os outros dois procedimentos se não vai ter o mesmo problema:

Entre nesse site e baixe essa key:
Aperte Ctrl + S e salve o arquivo:
https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/Release.key

Abra o terminal e vá até a pasta que fez o Download do arquivo e digite esse comando:

sudo apt-key add Release.key

Após isso adicione essa PPA:

deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10 ./

Após isso de esse comando:

sudo apt update

Feito tudo isso só instale o Wine novamente:

sudo apt install --install-recommends winehq-stable

Não cheguei a instalar o wine

Então siga os outros passo, mas remova a PPA que você adiciono e adicione a nova que passei em baixo.

Esqueci de menciona uma coisa, antes de tudo de esse comando:

sudo dpkg --add-architecture i386

Remova a PPA antiga e adicione essa, ou somente tente adiciona a libs 32 e tente instala:

sudo dpkg --add-architecture i386

Opa, quis dizer o

sudo dpkg --add-architecture i386

Se já fez isso não tem necessidade, é só segui com o resto removendo a antiga PPA

Engraçado, o site opensuse.org tem repositórios com programas para Debian

Enfim, ele achou 1.5GB de dependências (agr entendi pq n tava indo) e tá baixando, sem aquele erro de antes.

Também não sei porque kkkk eu tive o mesmo problema no ubuntu e adicionei a PPA do opensuse e resolveu kkk só que tive que desinstala o Wine e remove a antiga PPA claro xD
A PPA que usei no ubuntu 18.04 foi essa:

deb Index of /repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./

O nome do repositório é Emulators, mas WINE significa WINE Is Not an Emulator

Nem tinha reparado nisso kkk, pelo menos a PPA funciono xd