Networkmanager no Arch em loop

Olá,

Recentemente comprei um dell inspirion 15 3000 e instalei o Arch juntamente com o Deepin e o Lxde. eu tinha essa configuração o meu antigo note mas com esse estou com um problema meio chato com o Networkmanager. Após rodar o ‘systemctl enable NetworkManager.service’ e reiniciar o sistema, a rede fica tentando conectar, em loop eterno. Já tentei reinstalar mas sem sucesso. O que posso fazer?

Obrigado!

Você habilitou o serviço do dhcpcd? Ele conflita com o Network Manager, causando esse loop.

nao tenho certeza, mas estou usando o wifi-menu para conectar à rede. Vou rodar o stop dhcpcd.service quando chegar em casa

Edit: Aparentemente não resolveu :frowning: Continua em loop

Acredito que seja conflito do ipv4 com o ipv6, para resolver, abra um terminal como root e digite o seguinte comando: echo "blacklist ipv6" >> /etc/modprobe.d/blacklist.conf esse comando vai colocar os módulos relacionados a o ipv6 numa “lista negra” ou seja, não iniciar junto com o sistema. Feito isso, reinicie o pc.

Poste o output deste comando:

systemctl status NetworkManager

�� NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; ven>
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
������NetworkManager-ovs.conf
Active: active (running) since Wed 2019-08-28 18:53:39 -04; 14min ago
Docs: man:NetworkManager(8)
Main PID: 439 (NetworkManager)
Tasks: 3 (limit: 4915)
Memory: 19.7M
CGroup: /system.slice/NetworkManager.service
������439 /usr/bin/NetworkManager --no-daemon

Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7337] device>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7339] device>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7344] manage>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7359] manage>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7360] policy>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.9037] device>
Aug 28 18:58:16 archlinux NetworkManager[439]: [1567033096.6351] manage>
Aug 28 18:58:16 archlinux NetworkManager[439]: [1567033096.9112] dhcp6 >
Aug 28 18:58:16 archlinux NetworkManager[439]: [1567033096.9142] policy>
Aug 28 18:58:17 archlinux NetworkManager[439]: [1567033097.1026] dhcp6 >
lines 1-22/22 (END)…skipping…
��� NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
������NetworkManager-ovs.conf
Active: active (running) since Wed 2019-08-28 18:53:39 -04; 14min ago
Docs: man:NetworkManager(8)
Main PID: 439 (NetworkManager)
Tasks: 3 (limit: 4915)
Memory: 19.7M
CGroup: /system.slice/NetworkManager.service
������439 /usr/bin/NetworkManager --no-daemon

Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7337] device (wlp1s0): state change: ip-check -> secondaries (reaso>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7339] device (wlp1s0): state change: secondaries -> activated (reas>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7344] manager: NetworkManager state is now CONNECTED_LOCAL
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7359] manager: NetworkManager state is now CONNECTED_SITE
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.7360] policy: set ‘NET_LCSO’ (wlp1s0) as default for IPv4 routing a>
Aug 28 18:58:15 archlinux NetworkManager[439]: [1567033095.9037] device (wlp1s0): Activation: successful, device activated.
Aug 28 18:58:16 archlinux NetworkManager[439]: [1567033096.6351] manager: NetworkManager state is now CONNECTED_GLOBAL
Aug 28 18:58:16 archlinux NetworkManager[439]: [1567033096.9112] dhcp6 (wlp1s0): activation: beginning transaction (timeout in>
Aug 28 18:58:16 archlinux NetworkManager[439]: [1567033096.9142] policy: set ‘NET_LCSO’ (wlp1s0) as default for IPv6 routing a>
Aug 28 18:58:17 archlinux NetworkManager[439]: [1567033097.1026] dhcp6 (wlp1s0): state changed unknown -> bound

Aparentemente não tem nada errado com o serviço, quando inicialização falha ou há algum problema costumam aparecer entradas “failed” no registro, elas normalmente indicam onde está o problema.

saídas dos comandos com terminal maximizado

systemctl --a
systemctl list-unit-files --state enabled
aperte o enter até acabar

veja também

cat /etc/hostname.conf

Não sei se influencia, mas postei após me conectar com o wifi-menu.

@swatquest, posto assim que possível

@vinicius_oliveira já tive esse problema (um tempão atrás no Arch também) e resolvi usando a mesma dica citada pelo @anon94729332. Era conflito entre o ipv4 e ipv6. Eu conectava e toda hora o networkmanager ficava notificando que a internet tinha caído e reconectado, porém, como no seu caso, a internet não segurava a conexão. O único jeito foi desabilitando o ipvv6.

@anon94729332 @Tuxraldo

Nota: O Arch kernel tem suporte a IPv6 compilado diretamente e, portanto, um módulo não pode ser inserido na lista negra.

https://wiki.archlinux.org/index.php/IPv6_(Português)

No wiki diz que se desabilita por parametro do kernel ou por systemctl.

Aqui eu faço assim:

# #crie um arquivo em /etc/sysctl.d/40-ipv6.conf
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1

# #comente ipv6 em /etc/hosts
#::1 localhost.localdomain localhost

# #verificar a configuração
ip addr show | grep net6

Ih, então estou bem desatualizado. Quando tive esse problema, se não estou enganado, o método que usei para desabilitar, usando uma dica do fórum do Arch, foi esse mesmo da blacklist. No Debian ainda dá para usar esse método.

Existem sites que não funcionam sem IPV6, então não é boa ideia desativar. Os IPV4 estão esgotados.

Caso a dica do @Pio não dê certo, tente esse tutorial:

Acho que o autor do tópico já deve ter desistido. Mas, se ele postar a saida esse comando ai de cima, ajudava bem. Já vi em algumas distros (e tive isso uma vez no Ubuntu) um conflito entre o netplan e o networkmanager que deixa a internet em loop comot o autor citou. Era só mandar apenas o networkmanager gerenciar a rede.

Eu estava tendo esse mesmo problema, o NetworkManager não estava apresentando problema e eu não conseguia conectar em uma rede pelo wifi-menu ai eu tentei diferentes redes ai consegui conectar pelo wifi do celular, ai eu instalei o gnome e consegui conectar normalmente em tudo (até a rede cabeada que não estava conectando) começou a funcionar

desculpa, não desisti não, só fiquei sem tempo de responder mesmo, foi mal.

Acho que consigo testar as dicas no almoço e dou um retorno

Edit: uma coisa que reparei agora é que esse problema acontece quando ligo a primeira vez. quando reinicio já entro na área de trabalho conectado na rede que estava tentando conectar. Mas basta desligar que o problema volta. Bom, estou rodando os comandos e já posto os resultados

1 Curtida

resultado do ip addr show | grep net 6:
Inet ::1/128 scop host

Executei os passos anteriores mas continua na mesma.

@gmmacedo, seria problema do Deepin então?

Já tentou conectar pelo network manager em vez do wifi-menu?

Consegui resolver o problema com esse tutorial, obrigado @Tuxraldo

PS:

sim, era ele que causava o loop na rede

1 Curtida