Nao consigo instalar o virtualbox no deepin 15.11

ja tentei de varias maneiras instalar o virtualbox no deepin e nao consigo sempre da esse erro

“Os pacotes a seguir têm dependências desencontradas:
virtualbox-6.0 : Depende: libc6 (>= 2.27) mas 2.24-11+deb9u3 está para ser instalado
Depende: libcurl4 (>= 7.16.2) mas não é instalável
Depende: libqt5core5a (>= 5.9.0~beta) mas 5.7.1+dfsg-10deepin está para ser instalado
Depende: libvpx5 (>= 1.6.0) mas não é instalável
Recomenda: libsdl-ttf2.0-0 mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.”

tanto por terminal como por arquivo .deb alguem sabe como resolver ?

O Deepin 15 tem base no Debian 9, que não é mais suportado pelo VirtualBox. É necessário atualizar para o Deepin 20 (base Debian 10). (é suportado sim)

O Deepin 15 tem base no Debian 9, e pelo que parece você pegou o pacote de uma distribuição mais moderna (Ubuntu?). Pelo que tem na lista aí, o Deepin 20 (base Debian 10) vai funcionar com esse DEB específico.

Outra opção é instalar o Gnome Boxes ou o VirtManager, que são alternativas ao VirtualBox que ainda rodam no Deepin 15 e no Debian 9 (inclusive, podem ser instalados direto por APT).

2 Curtidas

mais ainda sim versões anteriores sao suportados como o virtualbox 5.0 e mesmo assim da o mesmo erro

A compatibilidade do DEB não depende apenas da versão do VirtualBox, depende também do alvo do programador. Pegando o pacote do Debian 9 daqui:

O libc6 e o libqt5core5a devem ser compatíveis com o que tem aí (ao menos olhando por cima o conteúdo do DEB), e em vez de libcurl4 e libvpx5 tem libcurl3 e libvpx4 que estão disponíveis no Debian 9.