Não consigo instalar LIBPNG12-0 no Ubuntu 19.04

Galera, a LIBPNG12-0 é dependência de uma aplicação, e não estou conseguindo instalar ela.
Ela vinha com o sistema até a versão 16.04. Só que era possível instalar ela até a versão 18.10. Baixando o .deb e executando ela pela central de aplicativos ou com o DPKG.
Apenas na versão 19.04 não consegui fazer a instalação, alguém já teve esse problema ?

@sangrittijunior

Como tu já sabes, a biblioteca libpng foi discontinuada. Ubuntu 19.04 removeu todas as dependências dessa biblioteca. Então tens de fazer manualmente:

  1. Transfere libpng12-0_1.2.54-1ubuntu1.1_amd64.deb;
  2. Extrai esse pacote;
  3. Localiza libpng12.so.0 e libpng12.so.0.54.0 do arquivo comprimido data.tar.gz;
  4. Copia esses dois módulos para o directório /usr/lib/x86_64-linux-gnu/.

Voici!

Você quis dizer libpng12 correto? pois a libpng foi atualizada recentemente para a versão 1.6.37
https://sourceforge.net/projects/libpng/files/libpng16/

Essa versão da libpng12 já deveria estar extinta, ela já tem quase 20 anos, se algum programa ainda a requer é por preguiça do desenvolvedor.

1 Curtida

Sim, tinha tentado essa maneira, mas dessa forma a aplicação tenta iniciar, da um erro e se fecha.

libpng e libpng12 são a mesma biblioteca.

Eexecuta a aplicação no terminal, copia os erros e cola aqui para nós analisarmos.

Está é o problema, eu executei ela pelo terminal, e não retorna erro.
A mensagem de erro vem no modo gráfico, e é aquelas mensagem de erro padrão onde não lhe retorna informação nenhuma do motivo do erro.
Mas em todo o caso nem vou mais instalar, se tratava de um jogo, e não é o mais importante que eu tenho que ter na maquina.
Caso queira investigar mais trata-se do Dofus.

Vou testá-lo no meu computador.

Testei e quase funcionou, mas fechou-se várias vezes. Acho que é melhor reportarmos esses erros para os desenvolvedores do jogo.