Não conseguindo acessar o HD externo

Estou com problemas em um HD externo que tenho aqui. Tenho alguns arquivos nesse disco que eu queria recuperar. Mas não consigo nem acessá-lo para fazer qualquer tipo de backup. Quando conecto ele (uso o Mint 19.1) o sistema não monta as partições. Quando eu vou no gerenciador de arquivos e clico no nome da partição para montá-la aparece o erro da imagem abaixo:

Quando tento acessar usando o Gparted, ele fica carregando eternamente. No momento que eu desconecto o usb ele lista as partições do HD interno. Já tentei conectar o HD com o Gparted já aberto e atualizar a lista, mas continua carregando eternamente.

Segue abaixo a saída do fdisk -l:

Disk /dev/sdb: 931,5 GiB, 1000204885504 bytes, 1953525167 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
Disklabel type: dos
Disk identifier: 0x362d366d

Device     Boot      Start        End    Sectors   Size Id Type
/dev/sdb1  *          2048   11718654   11716607   5,6G  7 HPFS/NTFS/exFAT
/dev/sdb2         11720702 1953523711 1941803010 925,9G  5 Extended
/dev/sdb5         11720704  207030271  195309568  93,1G 83 Linux
/dev/sdb6        207032320 1747437567 1540405248 734,5G 83 Linux
/dev/sdb7       1747439616 1845094399   97654784  46,6G 83 Linux
/dev/sdb8       1845096448 1953523711  108427264  51,7G 83 Linux

Partition 2 does not start on physical sector boundary.

Tentei usar o Disks, mas sem sucesso. Não dá pra fazer nada com o disco.
O Windows também não abre. Usei o gerenciador de discos dele, e também não realiza nenhuma operação.

Ja tentou mudar de USB ou o cabo que faz a conexão se nao for fixo?

Tive um problema parecido com um pendrive e um HD internet.

O pendrive mudei de porta e resolveu.
O HD internet tive que usar o gnome disks, ir nas opções e colocar para restaurar disco.

OBS: corre o risco de perder algum arquivo no processo, mas felizmente finalizou o processo sem perda alguma.

Caso não consiga de forma alguma, acho que vale a pena o risco para recuperar os arquivos que tem nele

Já tentei trocar de usb e cabos. Nada. O Disks que comentei acima é o gnome disks. Não consigo fazer nada no disco com ele.

Pode parecer besteira, mas já experimentou verificar esse HD com o Testdisk? talvez exista um backup do superbloco e caso exista talvez o testdisk consiga recuperar pois ele lida com o HD no modo RAW.
https://www.cgsecurity.org/wiki/TestDisk_PT
Digo pois já recuperei discos (tabela de partições), arquivos, partições deletadas com ele.

Também já tentei, não tive sucesso. Agora, por um motivo desconhecido, tenho a opção de formatar. Vou fazer isso e ver se consigo recuperar alguma coisa depois. Grato pelo tempo de vocês.

Assim que terminar aqui eu volto pra dar o resultado. Hehhe.

Os erros dão a entender que a tabela de partições não está alinhada corretamente, a solução mais simples seria deletar a tabela, criar uma nova e formatar.

Tenta montar a partição bypassando a detecção da tabela de partição, uma vez que você já conseguiu a informação de seus limites. Usa losetup. Abaixo exemplo de eu montando uma partição dessa maneira:


[debian10 ~]# fdisk -l /dev/sda
Disco /dev/sda: 3,7 TiB, 4000787029504 bytes, 7814037167 setores
Modelo de disco: Expansion       
Unidades: setor de 1 * 512 = 512 bytes
Tamanho de setor (lógico/físico): 512 bytes / 4096 bytes
Tamanho E/S (mínimo/ótimo): 4096 bytes / 4096 bytes
Tipo de rótulo do disco: gpt
Identificador do disco: CC7CB1A6-5F2C-4B0F-A767-BAD1F397EB77

Dispositivo Início        Fim    Setores Tamanho Tipo
/dev/sda1       34     262177     262144    128M Microsoft reservado
/dev/sda2   264192 7814035455 7813771264    3,7T Microsoft dados básico

A partição 1 não inicia em um limite de setor físico.
[debian10 ~]# losetup -v -f -o $((264192*512)) --sizelimit $(((7814035455-264192)*512)) /dev/sda
[debian10 ~]# mount /dev/loop0 dest/
FUSE exfat 1.3.0
WARN: file system in sectors is larger than device: 7813771264 * 512 > 4000650886656.
WARN: volume was not unmounted cleanly.
[debian10 ~]# umount dest
[debian10 ~]# losetup -d /dev/loop0
[debian10 ~]# 

Segui a dica desse site https://dustymabe.com/2012/12/15/mounting-a-partition-within-a-disk-image/ mas acho que dá pra entender só pelo código