Movimentação do Mouse dentro do CS2 está apresentando "engasgos" no Ubuntu 24.04 LTS

Bom dia a todos! Este é a minha primeira publicação! Estou começando a usar linux no meu dia a dia, pois quero me habituar com o sistema, e a princípio estou gostando bastante. Para iniciar, estou usando o Ubuntu 24.04 LTS. E para que eu passe a utilizar ainda mais essa distro, pensei em instalar o CS2, que estou jogando bastante.

Mas estou tendo um problema quanto a movimentação do mouse dentro do jogo, onde ele apresenta “engasgos” quando realizo uma movimentação mais rápida, tanto em movimentos horizontais quanto para movimentos verticais, eu uso as mesmas configurações e hardware no Windows, e não apresenta isso. O mouse que uso é um Redragon Cobra V2 Cherry M711C.

Até procurei em alguns fóruns do reddit e alguns mencionaram que trocaram do Wayland para o Xorg resolveria o problema, mas no meu caso quando troco para o X11 ele até diminui esses “engasgos” mas não remove completamente, e acaba que meu monitor/tv de 23" acaba sendo reconhecido como um monitor de 32" (sabe Deus porquê), e não aparece as resoluções acima de 1366x768. Quando o Ubuntu está com o Wayland, as configurações e resoluções do monitor aparecem e funcionam normalmente.

Quero saber se alguém já enfrentou esse problema e conseguiu Alguém que tem um hardware semelhante ao meu pode sugerir alguma outra distro linux que eu possa testar?

Desde já agradeço!

Olá, seja bem-vindo!

Você desativou a aceleração de mouse nas configurações do GNOME (que é a interface gráfica utilizada pelo Ubuntu)?

Se possível, dê mais informações do seu sistema: rode inxi -Fazy no terminal e coloque aqui a saída, por favor

1 curtida

Olha, a melhor resposta que eu tenho pra te dar é que cs2 esta ruim no windows, e pior ainda no linux, provavelmente é um bug do jogo e da compilação deles pra vulkan.

No meu pc eu tenho engasgos de fps direto no windows(sendo q meu pc é bem potente) e quando tento jogar no linux perco uns 40% de fps

Algumas dicas são botar max_fps 999 no console do jogo
Jogar no modo janela sem bordas

parece ser um bug conhecido e ignorado pela valve, assim como tantos outros

Boa tarde @GaaSantAna ! Tive que sair de casa, assim que voltar eu rodo o comando. Sobre a aceleração de mouse, eu tinha desativado ele dentro das configurações do GNOME já.

Boa tarde @freeQ !

Olha, a principal diferença mesmo que senti rodando no linux é a parte de estabilidade, mesmo eu perdendo uns 20% de fps, eu senti que o jogo é mais estável, mas não entendo pq só apresenta esse problema com o mouse, pois a movimentação com o teclado funciona perfeitamente.

Vou testar também essa questão de rodar em janela sem bordas, estava tentando rodar apenas em fullscreen.

Eu não sei se meu hardware q não é ideal pra jogar cs2, mas sinceramente eu nunca mais abri competitivo, só jogo 2x2 com meu amigo quando da vontade e deu.

tanto no meu pc intel + radeon quando no amd + nvidia o jogo ta rodando muito mal, pegando menos fps q lies of P e forza 5, não da pra entender

Resposta do inxi:

PU:
  Info: model: AMD Ryzen 5 4500 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x60 (96) stepping: 1 microcode: 0x8600106
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 664 high: 3569 min/max: 400/4208 scaling:
    driver: amd-pstate-epp governor: performance cores: 1: 400 2: 400 3: 400
    4: 400 5: 400 6: 3569 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400
    bogomips: 86244
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cppc cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt x2apic xgetbv1 xsave xsavec xsaveerptr xsaveopt
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; STIBP:
    always-on; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected

Oi, desculpa a demora!
Acho q está faltando informações nesse output. Era pra aparecer informações sobre gráficos e áudio por exemplo. Pode executar de novo, por favor?

Há algum tempo experimentei o Ubuntu 24.04 LTS e tive o mesmo problema, especialmente no Wayland. Pensei que poderia ser uma consequência da falta do protocolo de tearing no GNOME, somada à algum conflito com o Freesync. Porém, ao instalar o Arch Linux também com GNOME, não tive esse problema, e estou jogando CS2 normalmente no Wayland.

Portanto, minha dica seria tentar uma distribuição diferente do Ubuntu. O problema está em alguma coisa nele.

Quanto ao desempenho, está rodando super bem no alto em UWFHD (2560x1080p) aqui, sem qualquer engasgo. Contudo, meu hardware (Ryzen 7 5700X + 32GB RAM + Radeon RX 7600 XT 16GB) sobra para esse jogo, e isso pode fazer diferença.

Estou tendo o mesmo problema utilizando GNOME no Fedora, não creio que seja somente no Ubuntu

Att: O erro no meu caso estava vinculado a resolução do jogo, ao esticar no 4:3 meu mouse estava praticamente batendo em uma parede invisível que não o deixava funcionar de forma fluída. Não resolvi o erro in game, mas consegui contorna-lo alterando a resolução do meu sistema GNOME nas configurações para 1024 x 768 e ao entrar no CS 2 o erro deixou de existir completamente

Bom dia! Desculpa a demora pra responder tbm kkkk

Executei o mesmo comando e aparece as mesmas informações, não teve alterações.

Olá! Irei testar com o Arch e com outras distros baseadas. Depois de realizar os testes volto com o resultado kkk

Muito obrigado pela dica!