[MINT] - "VOCÊ NÃO É O PROPRIETÁRIO, LOGO VOCÊ NÃO PODE ALTERAR ESSAS PERMISSÕES"

Olá!

Tenho uma partição em meu SSD chamada “Dados”. Nesta partição deixo meus arquivos, como por exemplo, meu projeto no R e seus scripts.
Sempre acessei o projeto direto desta pasta e abri normal no R. Entretanto, hoje está aparecendo que os arquivos desta pasta não possuem permissão de alteração.

Quando entro para dar a permissão manualmente, vejo essa mensagem “Você não é o proprietário, logo você não pode alterar essas permissões”.

Já tentei:

rtheodoro@rtheodoro:~$ sudo chown rtheodoro:rtheodoro /media/rtheodoro/Dados

chown: alterando o dono de ‘/media/rtheodoro/Dados’: Sistema de arquivos somente para leitura
rtheodoro@rtheodoro:~$ sudo chmod 777 -R /media/rtheodoro/Dados
chmod: alterando permissões de ‘/media/rtheodoro/Dados’: Sistema de arquivos somente para leitura

Fiz os mesmos procedimentos como root, deram as mesmas respostas.
root@rtheodoro:/home/rtheodoro# sudo chown root:root /media/rtheodoro/Dados

chown: alterando o dono de ‘/media/rtheodoro/Dados’: Sistema de arquivos somente para leitura
root@rtheodoro:/home/rtheodoro# sudo chmod 777 -R /media/rtheodoro/Dados
chmod: alterando permissões de ‘/media/rtheodoro/Dados’: Sistema de arquivos somente para leitura

Alguém pode me ajudar?

cara, Vê se te ajuda:

Eu sei que às vezes usar o -R não funciona mesmo com discos externos, precisando fazer por pasta. Eu resolvo colocando um * no final do caminho (ex: /media/rtheodoro/*), mas aí precisa fazer nas subpastas tbm

1 Curtida

Então, digitei os códigos e não apareceu nenhuma mensagem.

Quando eu abro os arquivos tá ok ! Consigo alterá-los e salvar.

Entretanto, quando eu clicko com o botão direito, vou em “propriedades” e depois em “permissões”, ainda esta a mensagem “Você não é o proprietário, logo você não pode alterar essas permissões”.

Como está seu /etc/fstab

Adicione aqui a saída do comando abaixo:

cat /etc/fstab

rtheodoro@rtheodoro:~$ cat /etc/fstab

/etc/fstab: static file system information.

#Entry for /dev/sda5 :
UUID=ef8f8b15-c587-4779-a898-d89a58f60462 / ext4 errors=remount-ro 0 1
#Entry for /dev/sda2 :
UUID=48C5-1D99 /boot/efi vfat umask=0077 0 1
#Entry for /dev/sda7 :
UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g defaults,nodev,nosuid,locale=pt_BR.UTF-8 0 0
#Entry for /dev/sda6 :
UUID=e1d74c09-98dd-49b9-8557-c6976a09f4b5 none swap sw 0 0

Isso ?

OK…
Mude para

UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g uid=userid,gid=groupid,dmask=022,fmask=133 0 0

E veja se funciona

Desculpa, mas como faço isso ?

edite o fstab
Se estiver usando ubuntu, o editor de texto é gedit
Por exemplo

sudo gedit /etc/fstab

edite a entrada
#Entry for /dev/sda7 :
UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g defaults,nodev,nosuid,locale=pt_BR.UTF-8 0 0

e mude
defaults,nodev,nosuid,locale=pt_BR.UTF-8
para
uid=userid,gid=groupid,dmask=022,fmask=133

e reinicie o pc

se não funcionar, vc também pode tentar remover esta entrada no /etc/fstab

lembrando que qualquer problema
é só voltar ao como estava antes
#Entry for /dev/sda7 :
UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g defaults,nodev,nosuid,locale=pt_BR.UTF-8 0 0

Cara, deu ruim.

Reiniciei e o Mint não entra mais, segue tela

Já tentei as opções da tela, não dá nada

ok.

coloque a senha root

e então acesse o fstab com nano

nano /etc/fstab

em
#Entry for /dev/sda7 :
UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g defaults,nodev,nosuid,locale=pt_BR.UTF-8 0 0

deixa apenas o defaults
#Entry for /dev/sda7 :
UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g defaults 0 0

para salvar

pressione as teclas
ctrl+x

reinicie o sistema

1 Curtida

engraçado que deveria funcionar, pois não é root

Obrigado ! Voltou a funcionar !

Depois que voltou tentei mudar o código de novo, mas não deu certo novamente.

ok

deixando apenas o defaults vc tem permissão de escrita

senão pode tentar adicionar o rw

#Entry for /dev/sda7 :
UUID=867451FC7451F003 /media/rtheodoro/Dados ntfs-3g rw,defaults 0 0

Provavelmente há erros no sistema de arquivos e o ntfs-3g está montando como somente-leitura, mesmo que pedidno para abrir com edição.

Use no windows o comando “chkdsk /f” no drive.

Eu tenho um HD com Linux, um HD com Windows e outro HD com dados em NTFS.

Esse erro acontece comigo quando eu acesso o Windows e existe alguma atualização pendente. O Windows faz o processo da instalação da atualização ao desligar. Mas precisa que reinicie novamente o boot no Windows para concluir a atualização.

Se o Windows começa a atualização ao desligar o pc, mas eu não volto a ligar o windows para dar continuar a atualização… E faço o boot pelo Linux, não consigo escrever nada no HD de dados. Até que eu dê boot no windows e ele conclua a instalação da atualização… O windows altera alguma coisa no Sistema NTFS que não deixa meu Linux escrever nesse HD.

2 Curtidas