Mint - Erro Grub em dual boot

Boa noite pessoal, tudo bem?
Aqui em casa estamos usando o Mint no notebook.
Resolvi instalar no desktop também, no entanto fazendo um dual boot com o windows 10.

Antes segui as dicas do Diolinux deste vídeo: Como fazer DUAL BOO

Fiz, em teoria tudo certinho, mas no final da instalação o sistema me apresentou esse erro: “Dec 4 18:53:01 mint grub-installer: grub-install: erro: failed to register the EFI boot entry: Operação não permitida.”

A partir daí nada mais iniciava, nem windows e nem Linux.
Apanhei bastante e procurei neste e em outros fóruns e achei posts relacionado, mas não algo que eu conseguisse aplicar.

E depois de muita luta, consegui restaurar o boot do windows com o “cd” de instalação.

Agora estou bem receoso de testar novamente, já que não consegui achar uma solução.

Alguém tem alguma ideia?

Obrigado;

Qual o modelo da placa-mãe?

Boa noite! Bem vindo ao fórum.

Sempre que for instalar qualquer distro Linux, procura tirar o Secure Boot. O duro de notebook é que normalmente as bios são travadas, não dá pra mexer muito.

Se for fazer dualboot com Win, procura fazer assim:

1 - Partição EFI pro Linux
2 - Partição root pro Linux
3 - Restante pro Windows, deixa ele particionar automático

Eu instalo Win por último e dá certo normal, mas se você não puder, procura deixar a partição EFI do Win separada da do Linux. Isso aumenta o boot um pouco, mas pelo menos não lasca com seu pc.

Sugiro também ver se a instalação só dá problema com o Linux Mint. Notebooks costumam dar problema em um negócio chamado ACPI. É um controle de energia. Sempre que ia instalar no meu eu tinha que desativar e usar um mouse externo, do contrário era certeza que falhava a instalação. Tenta por o Pop!_OS, que é otimizado pra notebooks (pelo menos pra mim tem funcionado), e ve se o erro permanece o mesmo.

Opa, obrigado pela resposta.
A placa que tenho é a Gigabyte B450.

Boa noite, obrigado pela resposta.

Secre.Fox, desativei o securet boot.

Segui exatamente este formado de partição que vc sugeriu. Inclusive se não tiver a EFI a instalação não prossegue.

Como já tenho essa instalação do Windows a algum tempo, não quero refaze-la. Quero tentar mais algumas vezes fazer o dual boot.

Esse erro aconteceu no desktop.

Obrigado;

1 Curtida

Amigo, sugiro tentar instalar outro sistema como o Pop!_OS pra ver se o problema está no Linux Mint.

Aliás, qual versão do Linux Mint está usando? 19.3 ou 20? Aqui eu consigo utilizar qualquer sistema sem problemas.

Em que ponto exatamente está falhando a instalação? Se for no final, mas o sistema fica instalado sem bootar, dá uma olhada com o gparted se a partição efi está com as flags EFI (boot e efi). Abaixo uma foto:

image

Caso não tiver, entra pelo instalador e coloca. Pode ser que tenha tido problemas em definir isso pelo instalador, mas manualmente pode conseguir resolver. Boa sorte aí!

edit: procura ver se ela está em fat32 também.

failed to register the EFI boot entry

Estou achando que tem alguma opção na BIOS/Firmware que está impedindo o sistema operacional de adicionar uma nova entrada na NVRAM do UEFI. Amanha vou ver certinho o manual dessa placa, mas tem vários modelos dela. Precisa ver qual é o exato pra eu pegar o manual.

1 Curtida

Segundo eu vi na pagina 28 e 29, pode ser que boot esteja bloqueado. É a opão Security Option. Se ela estiver System, eu acho que não vai dar pro sistema operacional criar uma nova entrada de boot e deixá-la padrão. Recomendo deixar na opção Setup

Recomendo também usar opção CSM Support para Disabled, assim garantindo que o seu computador só vai operar no modo UEFI.

A opção Fast Boot também deve estar Disabled para o Linux.

2 Curtidas

Boa noite.

Delirium, criei coragem e fiz novamente a instalação.
Versão do Mint: 20
Placa mãe: B50M Gaming

  1. Informações da bios

  2. Instalação do Mint:

  3. Ao iniciar o sistema aparece o grub, mas não carrega nada .

  4. Para eu restaurar o Windows, coloquei o disco de instalação e em reparar. Não funcionou.
    Tive que dar um reset na bios, ai o win voltou ao normal.

Certeza que estou fazendo algo de errado, mas não consigo enxergar.

Boa noite Secret.Fox.

Estou utilizando o Mint 20.
A falha acontece bem no final. Quando a instalação só esta configurando o Grub, ou seja, o sistema fica instalado mas não inicia: nem o Linux nem o Windows.

Sobre a tag ESP, sim tenho uma partição com esta característica, veja:

sobre o esp, está formatando como fat32?

pois o esp tem que ser neste formato.

Swatquest, isso mesmo, ficou como fat32, olha só:

OK…

pela imagem

o ponto de montagem tem que ser /boot/efi
e o formato fat32

se funcionou…
ok

Estou tentando entender de fato o problema, não apenas resolve-lo.

Não sabia de fato o que era EFI, e agora nesta minha segunda tentativa frustrada, pesquisei e descobri que é a “nova” bios.

Então fui entender como se o Windows esta utilizando o novo ou o velho.

Listei as partições e nela não pude ver o EFI, entendi que estava utilizando o velho modo.

Pra ter certeza, no Windows, acessei informações do sistema e comprovei que o Win esta usando o Legacy, ou seja, método antigo.

Aí ficou minha dúvida. Consigo instalar um dual boot com um sistema utilizando o Legacy e outro utilizando o EFI?

Será que o erro não acontece por isso?

Se for no mesmo hd ou ssd não.
Mas se for instalar o modo automático em distros linux, o sistema de instalação detecta isso.

1 Curtida

Aí é deixar a home junto com o / e depois do sistema instalado, vc pega outra partição e atribui como home. O tutorial é pro Manjaro, mas serve pro Mint, já que a ferramenta usada é o Gnome Discos, que tem no Cinnamon, no MATE e no XFCE:

Como a instalação será em legacy, ele só deixa criar 4 partições estendidas. Mas dá pra pegar uma e criar uma partição lógica a partir dele. Então, usa o mesmo pendrive que instalou o Mint, entra pelo Gparted e cria a partição lógica.
É isso ou reinstalar tudo em modo UEFI - mó trabalhão
Falei alguma bobagem, @swatquest?

Swatquest, deixa eu ver se entendi: caso eu instale o linux em um outro hd/ssd posso usar o legacy em um e o EFI em outro?

“Mas se for instalar o modo automático em distros linux, o sistema de instalação detecta isso.”

Essa sua afirmação, entendi que se utilizarmos o métodos padrões “Instalar ao lado do Windows” ou “Apenas o Mint”, o sistema vai conseguir realizar a configuração corretamente?

Para instalar o efi.
Sua placa-mãe tem que ter suporte uefi.

Sobre uefi, tem gente que já instalou em legacy.

Veja aqui para entender um pouco

@Rodrigo_Chile, entendi mais ou menos.

Meu primeiro problema é que não consigo acessar sistema algum depois do erro do Grub.
Se eu for colocar o /home em outra partição, de pois do linux instalado, tenho que fazer isso por um “live cd” ou um usb.

Neste processo não tenho nenhuma integração ou instalação do Grub.

Agora, o que eu entendi é que cada vez estou mais próximo de ter que instalar tudo de novo rsrsrs.

Vou fazer mais umas buscas e reporto aqui.

Obrigado

1 Curtida

Daria para instalar um sistema em Legacy e outro em UEFI no mesmo disco. Mas só que o GRUB (UEFI) não vai conseguir iniciar o sistema que estiver em Legacy na (MBR). Nesse caso somente o usuário usando o boot menu da própria placa mãe conseguiria escolher o outro sistema operacional que não fosse o padrão.

Mas então, mudando CSM Support para Disabled realmente não vai mais carregar o windows, pois ele foi instalado no modo Legacy (Herdado). No seu caso vc vai precisar manter em Enabled pra carregar o windows. Acho que não dá pra mudar a instalação do windows pra UEFI, teria que se informar mais ou então reinstalar o windows :frowning:

Agora se quiser instalar o linux Mint desse modo, vc vai precisar da boot no pendrive também em modo legacy… Deixando o CSM Support enabled, deverá haver dois jeitos de dar boot no seu pendrive. E aí vc está escolhendo o modo que é UEFI. Manda uma foto da tela do “Boot Menu” onde vc escolhe dar boot no pendrive pra eu ver.

Mas se mesmo assim não houver um outro jeito, eu sei que o Ubuntu tem uma malandragem pra instalar o GRUB no dois modos (UEFI e legacy ao mesmo tempo), mas pra isso vc vai precisar criar uma partição de 1 mega do tipo “biosgrub”. Eu não sei direito como funciona pois nunca fiz…

Outra coisa estranha é que o windows detecta como fat32 a partição EFI, mas o gparted detecta como ext4. Tem algum xabu nessa história, possivelmente foi criada primeiro como ext4 e depois formatada em vfat no windows. Daí o windows não removeu completamente a assinatura ext4 da partição. Já aconteceu um rolo parecido aqui comigo e só o “dd” pra apagar os primeiros 4M da partição e zerar no modo bruto.

Agora que já expliquei o que eu acho que aconteceu, posso trazer a possível solução no meu entendimento: Instalar o Mint e criar também aquela partiçãozinha biosgrub deve resolver. Daí vc empurra pra frente essa novela que é o método “legacy e o dual boot nos tempos atuais”. Um dia que vc tiver bem disposto formata tudo em UEFI (alterando o CSM Support pra disabled) e facilita a sua vida pro multi boot.

1 Curtida