Manjaro não conecta ao wifi e problemas ao usar o terminal para corrigir

Quando percebi que meu wifi não estava conectando logo busquei um tutorial para solucionar o problema. A solução que achei foi a seguinte:

  1. abrir terminal;
  2. sudo su;
  3. vi /etc/NetworkManager/NetworkManager.conf

Após digitar o ultimo comando me apareceu o seguinte:

"# Configuration file for NetworkManager.
# See "man 5 NetworkManager.conf" for details.
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
"/etc/NetworkManager/NetworkManager.conf" 2 lines, 88 characters"

O próximo passo seria adicionar a entrada “dhcp=dhclient” no seu arquivo de configuração. Porém, por algum raio de motivo, eu não consigo editar nada no meu terminal. Eu simplesmente não consigo ir até a terceira linha para escrever o comando.

Alguém tem uma solução?

Desde já agradeço.

Tenta com o nano, sudo nano /etc/NetworkManager/NetworkManager.conf

1 curtida

Me apareceu isso:

Adicione a entrada e veja se funciona. Onde vc achou essa “solução”?

1 curtida

Bom, vou mandar o link antes de adicionar a entrada, só por garantia. Segue:

1 curtida

Procura por solução semelhante no fórum do Manjaro, o suporte oficial é dado lá

2 curtidas

Aparece os ssids?

O roteador está configurado certo para seu pc?
Se não tiver suporte na configuração do roteador, não conecta.

Usa windows, e nele conecta?

1 curtida

Primeiro atualize a possivel lista de conexões com:

nmcli device wifi rescan

Então verifique se sua rede aparece com:

nmcli device wifi list

Caso sua rede apareça tente se conectar com:

nmcli device wifi connect <nome-da-rede> password <senha>
1 curtida

Adicionei a entrada e dei Ctrl + O pra salvar. E agora? Eu até fui no fórum do Manjaro mas é muita informação. Não que muita informação seja ruim, mas as vezes confunde…

Apareceu “Erro: Scanning not allowed while unavailable”

É um notebook. Assim que peguei ele já instalai o Manjaro rs. Nem fiz as confgs iniciais do Windows.

Tente

sudo systemctl start wpa_supplicant

E então, teste novamente os comandos descritos acima…

1 curtida

O erro persiste :frowning:

Aparece os ssids?

Qual a saída do comando?

systemctl list-unit-files --state enabled

1 curtida

Desculpa minha ignorância, mas o que seria “ssids”?

Aparece e os nomes das redes wifi para conectar?

1 curtida

SSID em inglês “Service Set Identifier” basicamente é o termo técnico para seu nome de rede.

Qual a saída deste comando:

systemctl status NetworkManager

E caso queria abordar a possível solução ao qual apresentou, você pode simplesmente seguir com sem a necessidade de abrir o vi ou o nano

sudo echo 'dhcp=dhclient' >> /etc/NetworkManager/NetworkManager.conf

Lembre-se depois de editar o /etc/NetworkManager/NetworkManager.conf, reinicie o serviço do NetworkManager para sutir efeito, com:

sudo systemctl restart NetworkManager
1 curtida

Aparece normalmente. Quando clico na rede o sistema pede a senha e após escreve-la não conecta, fica em um loop de perguntar a senha mesmo ela estando correta.

O teclado está configurado corretamente?

Já fez um teste escrevendo a senha num bloco de notas?

2 curtidas

Soltei um palavrão agora. Era isso. Misericória.

Obrigado… e desculpa por isso. No fim não era exatamente um problema tão grave rsrsrsr.

2 curtidas