Lubuntu não reconhece monitor

Boa noite a todos,

Eu sou novo no mundo Linux, passei a utilizá-lo a poucas semanas. Queria saber como posso fazer para resolver um problema. Meu PC tem um hardware muito antigo, portando pesquisei distros que usem menos recursos do sistema, como o Lubuntu 18.04.1 (sistema atual). Acontece que após a instalação do sistema operacional, a resolução da tela está 640x480, mas eu sei que meu monitor é 1024x768.

Já fiz um breve uso do LMint Xfce e Xubuntu, ambos funcionaram, mas devido ao hardware, com muita lentidão.

Processador: Intel Pentium 4 (Northwood) 2.60 GHz
Monitor: AOC LM522 [Cod. TFT1560PSA] LCD 15 polegadas
RAM: 2 GB
HD: 146 GB

Não há drivers adicionais para serem adicionados.

gustavo@gustavo-STI:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480       73.00* 

gustavo@gustavo-STI:~$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync

gustavo@gustavo-STI:~$ sudo xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
[sudo] senha para gustavo: 
xrandr: Failed to get size of gamma for output default 

gustavo@gustavo-STI:~$ sudo lshw -c video
  *-display DISPONÍVEL      
       descrição: VGA compatible controller
       produto: CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro]
       fabricante: VIA Technologies, Inc.
       ID físico: 0
       informações do barramento: pci@0000:01:00.0
       versão: 01
       largura: 32 bits
       clock: 66MHz
       capacidades: vga_controller bus_master cap_list
       configuração: latency=32 mingnt=2
       recursos: memória:d8000000-dbffffff memória:dc000000-dcffffff memória:c0000-dffff  

Em lspci, um dos resultados é:

 01:00.0 VGA compatible controller: VIA Technologies, Inc. CN700/P4M800 Pro/P4M800 CE/VN800 Graphics [S3 UniChrome Pro] (rev 01) 

Criei e enviei o arquivo xorg.config com os códigos abaixo:

gustavo@gustavo-STI:~$ sudo Xorg :1 -configure
X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-119-generic i686 Ubuntu
Current Operating System: Linux gustavo-STI 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:37:27 UTC 2018 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=620aa2b4-4178-4171-9ecc-a687a943b98b ro quiet splash vt.handoff=1
Build Date: 13 April 2018  08:08:02PM
xorg-server 2:1.19.6-1ubuntu4 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.34.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Jan 14 12:08:52 2020
List of video drivers:
    ati
    intel
    nouveau
    qxl
    radeon
    vmware
    vesa
    modesetting
    fbdev
    amdgpu
(++) Using config file: "/home/gustavo/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"

Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /home/gustavo/xorg.conf.new

To test the server, run 'X -config /home/gustavo/xorg.conf.new'

(EE) Server terminated with error (2). Closing log file.

gustavo@gustavo-STI:~$ sudo cp xorg.conf.new /etc/X11/xorg.conf

Fazendo uso do comando apt-cache policy xserver-xorg-core, percebi que possuo o pacote xserver-xorg-core 2:1.19.6-lubuntu4 instalado

Bom, fiz a instalação do driver openchrome:

gustavo@gustavo-STI:~$ sudo apt install xserver-xorg-video-openchrome
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os NOVOS pacotes a seguir serão instalados:
  xserver-xorg-video-openchrome
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 496 não atualizados.
É preciso baixar 153 kB de arquivos.
Depois desta operação, 555 kB adicionais de espaço em disco serão usados.
Obter:1 http://br.archive.ubuntu.com/ubuntu bionic/universe i386 xserver-xorg-video-openchrome i386 1:0.6.0-3 [153 kB]
Baixados 153 kB em 0s (1.087 kB/s)                    
A seleccionar pacote anteriormente não seleccionado xserver-xorg-video-openchrome.
(Lendo banco de dados ... 145089 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../xserver-xorg-video-openchrome_1%3a0.6.0-3_i386.deb ...
A descompactar xserver-xorg-video-openchrome (1:0.6.0-3) ...
Configurando xserver-xorg-video-openchrome (1:0.6.0-3) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
A processar 'triggers' para man-db (2.8.3-2) ...

gustavo@gustavo-STI:~$ apt-cache policy xserver-xorg-video-openchrome
xserver-xorg-video-openchrome:
  Instalado: 1:0.6.0-3
  Candidato: 1:0.6.0-3
  Tabela de versão:
 *** 1:0.6.0-3 500
        500 http://br.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
        100 /var/lib/dpkg/status 

Reiniciei o computador e não aconteceu nada. Continua com o mesmo resultado para xrandr:

gustavo@gustavo-STI:~$ xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
    default connected 640x480+0+0 0mm x 0mm
       640x480       73.00* 

O que posso fazer para resolver este problema?

Da uma olhada nesse link:

https://ubuntuforum-br.org/index.php?topic=123186.0

Talvez essa resposta te ajude.

1 Curtida

Tava com um PC dual-core de 2,4 ghz de 2008 com 2 gigas de RAM, e usava nele o Lubuntu. Mas como o Mint tem tudo e tudo funciona (sou nutela), mudei pra ele com XFCE e desativei o compositor de janelas e a maioria dos serviços que iniciam junto. Deixei somente o policykit, o gerenciador de energia e o gerenciador de atualizacoes iniciando junto com o sistema e achei que o desempenho ficou igualzinho ao do Lubuntu. O consumo de memória também era quase o mesmo.

1 Curtida

Obrigado pela atenção!

Fiz conforme descrito na resposta e tudo deu certo.
Esta é a resposta do xrandr agora:

gustavo@gustavo-STI:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024 x 768+0+0 0mm x 0mm
1024 x 768 76.00*

Em Programas e atualizações há muitas coisas para serem instaladas. Posso fazer sempre a instalação de todas?

Pode sim, você pode instala usando interface ou pode instala elas pelo terminal usando esse comando:

sudo apt update && sudo apt dist-upgrade

Eu não cheguei desativar os demais pacotes tanto no LMXfce quanto no Xubuntu, mas acredito que poderia ter melhorado um pouco. Agora com o Lubuntu está ótimo. Evitando o excesso de multitarefas, ele deve fazer um excelente trabalho!

1 Curtida

Fiz a atualização, deu tudo certo.

Obrigado pela ajuda! :wink: