Linux mint não ajusta brilho

Olá pessoal, eu juro que não estaria fazendo um tópico se já não tivesse procurado em tudo quanto é canto a respeito. Sempre que uso o comando no terminal xrandr --output HDMI-A-0 --brightness 0.5 com qualquer porcentagem de brilho segundos depois ele já volta ao normal, tentei baixar o brightness-controller ou mesmo usar algumas extensões direto da loja e absolutamente nada funciona, questão de segundos ele já volta ao brilho original, desinstalei as extensões e programas, e pesquisei em alguns fóruns em ingles, mas a maioria soluções que eu já tentei e não funcionou alguém sabe como posso resolver?

Detalhes do SO:
Linux Mint 20 Cinnamon
versão do cinnamon 4.6.7
kernel 5.4.0-81-generic
processador AMD Ryzen 5 2400G with Radeon Vega Graphics × 4

https://wiki.archlinux.org/title/backlight

HDMI-A-0 está correto?

Amigo, tenho um hardware parecido com o seu, note amd ryzen 5 e tive um problema bastante semelhante em todas distros base ubuntu, sempre que eu reiniciava ou desligava o note ele voltava com brilho em 100%, consultei o terminal com sudo systemctl --failed e obtive o erro, esqueci a saida agora kkk, infelizmente, mas felizmente consegui solucionar o problema.
Pelo terminal, use seu editor favorito, eu uso nano /etc/default/grub…ai é só adicionar acpi_backlight=video no final da linha GRUB_CMDLINE_LINUX_DEFAULT="quiet…
ficaria assim, GRUB_CMDLINE_LINUX_DEFAULT=“quiet acpi_backlight=video”
depois update-grub
e pronto, comigo funcionou usando o ubuntu, abraço.

3 curtidas

HDMI-A-0 está coreto sim, tentei a solução do Csantaniel,reiniciei a máquina e resolveu, pelo visto era isso mesmo , vlw

1 curtida