Linux Mint 19.3 não Atualiza pelo Gerenciador de Atualizações

Bom Dia.
Estou tentando atualizar o Linux Mint pelo Gerenciador de Atualizações. Ao clicar em Instalar Atualizações, o programa simplesmente não responde, aparece a mensagem no rodapé da tela de atualização: “Não foi possível instalar as atualizações de segurança”.
Os arquivos disponíveis para atualização aparecem normalmente na tela e voltam a aparecer após a tentativa.

O aplicativo FONTES DE APLICATIVOS, também não responde ao clicar.

Utilizando os comandos a seguir eu consigo atualizar e as atualizações disponíveis desaparecem mas, toda vez que chega uma atualização nova, é sempre a mesma coisa.

sudo rm /var/lib/apt/lists/lock
sudo apt update && sudo apt dist-upgrade

Um outra informação é que parece que foi alterada(sem querer) a fonte de atualizações e depois disso é que começou apresentar o problema mas, como estou sem abrir a FONTE DE APLICATIVOS, pelo modo gráfico, não sei como reverter.

Mais outra informação que não sei se é relevante, ao executar o comando “sudo apt update”, no final da tela do terminal aparece a seguinte informação:

Lendo informação de estado… Pronto
3
packages can be upgraded. Run ‘apt list --upgradable’ to see them.
N: Skipping acquire of configured file ‘contrib/binary-i386/Packages’ as repository ‘Index of http://download.virtualbox.org/virtualbox/debian bionic InRelease’ doesn’t support architecture ‘i386’

Estranho!! Isso eu nunca vi!

Você pode remover/desabilitar esse PPA usando o comando abaixo. O comando vai abrir a lista de fontes no editor que você escolher, ai é só remover a linha ou colocar o “#” no início para desabilitar.
sudo apt edit-sources

Existe isso no arquivo:
#deb cdrom:[Linux Mint 19.3 Tricia - Release amd64 20191213]/ bionic contrib main non-free

Observei um outra coisa. Não consigo acessar uma pasta como root, clicando com botão direito do mouse. A pasta root (etc\root) está com um X em cima, também não consigo abrir o aplicativo USUÁRIOS. Está parecendo que meu usuário não está como root. Isso não estava assim, não sei como aconteceu. Acredito que se eu tornar o usuário root, conseguirei efetuar as atualizações. Pelo terminal consigo ficar root, mas não consigo tornar o usuário o tempo todo, como root. Alguém pode me ajudar ?

Eita! Tem bastante coisa quebrada então!
Você lembra da última ação que você fez antes dos problemas começarem? Algum comando ou modificação de alguma configuração? Alguém mais tem acesso root no sistema?

Não entendi. Tem como enviar uma print-screen dessa tela?

Esse é o comportamento padrão. Não é nada recomendado usar o sistema como root o tempo todo. Então se você conseguir rodar alguma coisa como sudo, é o que precisa. Porém, não conseguir abrir os programas por falta de permissão não é normal. Tem certeza que está colocando a senha correta? Aparece alguma mensagem de erro, ou de falta de permissão?

Para verificar melhor a questão dos PPAs/Repositórios, execute esse comando para imprimir o conteúdo de todos os arquivos “.list” (que contêm essas informações):

find /etc/apt/* -iname "*.list" -printf '\n* %p\n' -exec cat {} \;

E execute esse comando para verificar em quais grupos do sistema o seu usuário está:

grep $(whoami) /etc/group

Depois copie/cole os resultados aqui.

A última coisa que fiz foi instalar o virtualbox 6.0. É um notebook e só eu faço uso. Quando senha está correto, nem pede a senha, simples mente não executa a pasta como root(a exemplo de Clicar em INSTALAR ATUALIZAÇÕES). É como se não tivesse clicando em nada. Não aparece mensagem de erro ou de falta de permissão.

Uma correção sobre a localização da pasta root, não \etc\root, somente \root.

[email protected]:~$ find /etc/apt/* -iname ".list" -printf '\n %p\n’ -exec cat {} ;

Do not edit this file manually, use Software Sources instead.

deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main

deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse

deb Index of /ubuntu bionic-security main restricted universe multiverse
deb Index of /ubuntu bionic partner

  • /etc/apt/sources.list.d/teamviewer.list

TeamViewer DEB repository list

NOTE: Manual changes to this file

- prevent it from being updated by TeamViewer package updates

- will be lost after using the ‘teamviewer repo’ command

The original file can be restored with this command:

cp /opt/teamviewer/tv_bin/script/teamviewer.list /etc/apt/sources.list.d/teamviewer.list

which has the same effect as ‘teamviewer repo default’

NOTE: It is preferred to use the following commands to edit this file:

teamviewer repo - show current repository configuration

teamviewer repo default - restore default configuration

teamviewer repo disable - disable the repository

teamviewer repo stable - make all regular TeamViewer packages available (default)

teamviewer repo preview - additionally, make feature preview packages available

teamviewer repo development - additionally, make the latest development packages available

deb http://linux.teamviewer.com/deb stable main

deb http://linux.teamviewer.com/deb preview main

deb http://linux.teamviewer.com/deb development main

  • /etc/apt/sources.list.d/insync.list
    deb http://apt.insync.io/mint tricia non-free contrib

  • /etc/apt/sources.list.d/google-chrome.list

THIS FILE IS AUTOMATICALLY CONFIGURED

You may comment out this entry, but any other modifications may be lost.

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
[email protected]:~$

O outro comando:

grep $(whoami) /etc/group

[email protected]:~$ grep $(whoami) /etc/group
adm:x:4:syslog,ernandes
cdrom:x:24:ernandes
sudo:x:27:ernandes
dip:x:30:ernandes
plugdev:x:46:ernandes
lpadmin:x:112:ernandes
ernandes:x:1000:
sambashare:x:128:ernandes
libvirt:x:133:ernandes
vboxusers:x:130:ernandes

Esse diretório /root é simplesmente o diretório do usuário Root, e normalmente fica vazio. É normal ficar com esse “X”, pois os usuários comuns não tem permissão de acesso nela.

Sobre o problema do PPA do VirtualBox, o mesmo está configurado no arquivo /etc/apt/sources.list.d/virtualbox.list. De acordo com o site do Virtualbox é necessário ter o [arch=amd64] logo após o “deb”, pois caso contrário o APT tentará instalar as libs em 32bits do programa, o que não existe. Então esse seria uma solução. Porém, o Virtualbox já é disponibilizado nos repositórios oficiais, e pode ser instalado tanto pela loja quanto pelo terminal sem a necessidade de adicionar novos PPAs/Repositórios. Isso evita problemas e melhora a compatibilidade do programa com o sistema. Só é recomendado usar uma outra versão caso você realmente sinta a necessidade, por falta de algum recurso, o que não é o caso na grande maioria das vezes.

  • Para editar esse arquivo você pode navegar até o diretório em que ele está, clicar na opção de abrir como Root (no menu que aparece ao clicar com o botão direito em algum lugar vazio da pasta), e depois editá-lo com o editor padrão. Ou, basta executar algum dos comandos abaixo para remover ou abrir o editor de texto:
    • Para remover: sudo rm /etc/apt/sources.list.d/virtualbox.list
    • Para editar: sudo xed /etc/apt/sources.list.d/google-chrome.list

Para remover a versão instalada do Virtualbox e usar a versão padrão, entre no aplicativo “Fontes de Aplicativos”, entre na aba “Manutenção” e depois clique na opção “Rebaixar as versões dos pacotes de terceiros”. Depois selecione o Virtualbox (se estiver na lista) e clique em “Rebaixar versão”.

Sobre os grupos, está tudo correto. Você está no grupo “sudo”, o que permite que você acesse as configurações e execute comandos com o “sudo”.

Obrigado Bruno pelas instruções mas veja as seguintes situações:

1 - Instalei o Virtualbox 6.0 pq a versão que tem na loja não deixava eu acessar pendrive, nem leitora de cartão (Gmalto).
2 - O meu real problema não é o Virtualbox, só postei aquilo lá no começo achando que poderia sere relevante para a solução. O meu real problema é não consigo instalar atualizações. Nenhum tipo de atualização. Quando clico em instalar, simplesmente não acontece nada. Veja a imagem abaixo:

Eu clico em INSTALAR ATUALIZAÇÕES, ele pisca e não acontece nada.

A instrução: “Para editar esse arquivo você pode navegar até o diretório em que ele está, clicar na opção de abrir como Root…” também não funciona.

A instrução: “Para remover a versão instalada do Virtualbox e usar a versão padrão, entre no aplicativo “Fontes de Aplicativos”, entre na aba “Manutenção” e depois clique na opção “Rebaixar as versões dos pacotes de terceiros”. Depois selecione o Virtualbox (se estiver na lista) e clique em “Rebaixar versão”.” também não consigo abrir FONTES DE APLICATIVOS.

1 curtida

Ah sim, ai tudo bem.

Isso é causado pelo erro do PPA. Tente executar o comando abaixo no terminal (que fazem basicamente a mesma coisa do Gerenciador), que os erros aparecerão:
sudo apt update; sudo apt upgrade

Qualquer erro em algum dos PPAs/Reps o APT vai reclamar, e dizer que não pode fazer nada, pois não tem a segurança que as informações que possui estão corretas/atualizadas. Corrija o arquivo como eu comentei e isso deverá ser corrigido.

As atualizações foram feitas mas, continuo sem acesso À FONTE DE APLICATIVOS e às CONFIGURAÇÕES DE USUÁRIOS/Usuários e Grupos. também não sei se quando tiver novas atualizações disponíveis, conseguirei fazer pelo modo gráfico!

Obs.: a imagem foi printada após as atualizações pelo terminal.

Blz! Que bom.

Mas o que exatamente aparece ao clicar em algum desses aplicativos?
O que acontece ao executar o programa pelo terminal?
$ cinnamon-settings-users

Qual o resultado desses comandos?

Você fez a modificação no arquivo do /etc/apt/sources.list.d/virtualbox.list?

Sem essas informações fica difícil de ajudar.

Sim, fiz a modificação em: /etc/apt/sources.list.d/virtualbox.list com o comando a seguir, conforme sua instrução(remoção):
sudo rm /etc/apt/sources.list.d/virtualbox.list

Resultado do comando: cinnamon-settings-users

[email protected]:~$ cinnamon-settings-users
The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.
[email protected]:~$ ^C
[email protected]:

Parece que não foi encontrado.

Hmm… Isso indica que ou você removeu/modificou esse arquivo /etc/shells, ou que você está usando um Shell diferente.

Qual o resultado dos seguintes comandos:
echo ${SHELL}
cat /etc/shells

Só para comparação, os meus são:

[email protected]:~
$ echo ${SHELL}
/bin/bash
[email protected]:~
$ cat /etc/shells 
# /etc/shells: valid login shells
/bin/sh
/bin/bash
/bin/rbash
/bin/dash

Ou seja, estou utilizando o Bash, como é o padrão, e o arquivo shells contém o bash.

[email protected]:~$ echo ${SHELL}
vboxusers

[email protected]:~$ cat /etc/shells

/etc/shells: valid login shells

/bin/sh
/bin/bash
/bin/rbash
/bin/dash

Ai está o erro. “vboxusers” é apenas o nome do grupo, e não um Shell. Por isso você não consegue abrir nada, pq tudo gira em volta do Shell.

Já tentou reiniciar ou pelo menos reiniciar a sua sessão?
Se sim, e não funcionou, qual a saída desse comando (pode deixar que não vai aparecer a sua senha)?
$ grep $(whoami) /etc/passwd

Já reiniciei o sistema várias vezes. A sessão, fiz isso agora. Não resolveu.

[email protected]:~$ grep $(whoami) /etc/passwd
ernandes:x:1000:1000:ernandes,:/home/ernandes:vboxusers

Ok.

Edita esse arquivo (como sudo) e modifica essa linha para ficar assim:
ernandes:x:1000:1000:ernandes,:/home/ernandes:/bin/bash

(troque o vboxusers por /bin/bash)

Depois reinicie o PC e deve voltar tudo ao normal.

1 curtida

Agora sim, resolveu.

Obrigado pela sua paciência e tempo. Você é o cara!!!

1 curtida