Linux e Bluetooth

Estou com o um notebook da Lenovo, o Legion y530. Nele tenho o Ubuntu 20.04, mas não consigo conectar nenhum dispositivo Bluetooth.
Tela da configuração:


Fala para ligar, mas quando clico no botão para isso, nada acontece.

tentei instalar o Blueman, sem sucesso.
Olha só o que me retorna:

$ blueman-adapters
blueman-adapters version 2.1.2 starting
blueman-adapters 20.02.04 ERROR Adapter:53 init : No adapter(s) found

Mesmo Utilizando um dongle bluetooth nada acontece

A chave chega a ficar roxa? Tipo ativa mas n encontra os dispositivos bluetooth? ou a chave não se move?

1 curtida

Qual kernel vc está usando?

1 curtida

Tá me cheirando kernel mesmo mas, tenta fn+f8 para ver. Este comando habilita ou desabilita o modo avião.

Edited: Percebi o bug do Edited +1 em menos de 1 minuto. Se eu responder para a ultima mensagem citando ela dá nisso… Não é algo que atrapalha mas @thespation. Edited/

1 curtida

fica roxa, mas quando eu mudo de “aba” de configurações e volte ele volta àquela foto lá de cima

Vamos ter certeza de que há um dispositivo bluetooth e qual é. Posta aí a saída dos comandos lsusb e uname -r

Um de cada vez, Mateus

Não sei dizer qual desses é…

$ dpkg --list | grep linux-image
rc linux-image-5.4.0-42-generic 5.4.0-42.46 amd64 Signed kernel image generic
ii linux-image-5.8.0-41-generic 5.8.0-41.46~20.04.1 amd64 Signed kernel image generic
ii linux-image-5.8.0-43-generic 5.8.0-43.49~20.04.1 amd64 Signed kernel image generic
ii linux-image-generic-hwe-20.04 5.8.0.43.49~20.04.29 amd64 Generic Linux kernel image

Primeiro coloca aí o uname -r. Aí copia aqui
Daí digita o lsusb e copia aqui… mas já temos uma primeira pista… assim que vc mandar aqui, vou te dar uma ideia

entendi kkk
foi mal
uname -r
5.8.0-43-generic

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04ca:7070 Lite-On Technology Corp. Integrated Camera
Bus 001 Device 002: ID 18f8:0f97 [Maxxter] USB OPTICAL MOUSE
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Olha aí… nem achou nada de bluetooth… agora reinicia o pc, no grub vá em opções avançadas e inicie com o kernel 5.4 (parece que está instalado pelo que vc mandou no grep). Se sim, rode os 2 comandos novamente, um de cada vez - um pra se certificar que estamos rodando o 5.4, o outro pra ver se aparece o dispositivo

1 curtida
off

Caso cite a mensagem logo acima da sua, por ser uma mensagem direta, o sistema entende como redundante e remove automaticamente.

1 curtida

Uma coisa já descobri aqui - é o famigerado Qualcomm Atheros. Acredito que só com o Kernel 5.4 que funcionará

Não aparece nenhum kernel 5.4 no grub
Acho que vou ter de instalar

1 curtida

Eu instalo o 5.4 mesmo?

1 curtida

Sim… sabe como?

Estou aprendendo, acho que me viro por enquanto.
Obrigado