Língua Padrão do XFCE

Hello, mates ;D

Como mudar a língua padrão do XFCE4 para o Inglês Britânico?

Cptos

Não sei que distro vc está usando no momento, se for arch pode editar o locale.conf.
Caso utilize outra distro pode exportar ou setar no bashrc ou zshrc se utilizar zsh.

# export LANGUAGE=en_GB.utf8
# export LANG=en_GB.utf8
# export LC_ALL=en_GB.utf8

2 Curtidas

Obrigado, @Danielaustlab.

Já consegui uma solução. Ei-la aqui, caso outros também tenho o mesmo problema:
"
language is a system setting and not available inside xfce4-settings:

edit /etc/locale.gen as root (or with sudo) and make sure British English is not commented out (# in front)

sudo locale-gen

then set it:
sudo localectl set-locale LANG=en_GB.UTF-8
"

1 Curtida

É interessante depois de editar o locale.gen rodar o comando sudo locale-gen antes do sudo localectl set-locale LANG=en_GB.UTF-8

1 Curtida

Conforme a tua sugestão, que foi bem lembrada, adicionei-a à solução.
É melhor.