Lentidão no Boot

Glr, o boot do meu notebook ficou extremamente lento após uma tentativa de um dual boot com Mint vs Kali.
Rodando o comando $systemd-analyze blame, ele e retorna isto:

       575ms dev-sda1.device
       513ms networkd-dispatcher.service
       473ms upower.service
       448ms ubuntu-system-adjustments.service
       441ms udisks2.service
       339ms NetworkManager.service
       336ms ModemManager.service
       256ms zram-config.service
       248ms ufw.service
       ......

Rodando o comando systemd-analyze me retornou:

   Startup finished in 34.999s (kernel) + 3min 631ms (userspace) = 3min 35.631s
graphical.target reached after 1min 31.227s in userspace

por fim, rodei o systemd-analyze critical-chain e o retorno foi:

    graphical.target @1min 31.227s
└─multi-user.target @1min 31.227s
  └─getty.target @1min 31.227s
    └─getty@tty1.service @1min 31.227s
      └─system-getty.slice @1min 31.226s
        └─setvtrgb.service @1min 31.100s +125ms
          └─systemd-user-sessions.service @1min 30.825s +33ms
            └─network.target @1min 30.823s
              └─NetworkManager.service @1min 30.482s +339ms
                └─dbus.service @1min 30.397s
                  └─basic.target @1min 30.384s
                    └─sockets.target @1min 30.384s
                      └─acpid.socket @1min 30.384s
                        └─sysinit.target @1min 30.381s
                          └─apparmor.service @1.020s +172ms
                            └─local-fs.target @1.016s
                              └─run-user-1000-gvfs.mount @1min 33.098s
                                └─run-user-1000.mount @1min 32.487s
                                  └─local-fs-pre.target @395ms
                                    └─keyboard-setup.service @265ms +129ms

Uso SSD, o boot antes era muito rápido; poderiam ajudar?

Uma sugestão: dê uma repensada nas configurações e pacotes que tu mudou para instalar e fazer o dual boot com o Kali e reverta…
Parece que a etapa que mais demora é entre:

run-user-1000.mount @1min 32.487s
                                  └─local-fs-pre.target @395ms

local fs? Local filesystem, sistema local. Vc mudou algo no fstab? Vc mudou a swap de lugar?

Parei na montagem do sistema, deu um erro na instalação e decidi pesquisar mais sobre(uso para o estágio q faço); na montagem em si, eu não modifiquei nada, apenas criei um / com o que estava sobrando SSD e compartilhei o /home, /boot e swap.

Coloque aqui seu fstab

Outra coisa

Já tentou tirar o quiet do grub e ver o progresso da inicialização?

2 Curtidas

Tentei verificar enquanto a inicialização ocorre (aperto o ESC e ele geralmente mostrava o que estava sendo montado), mas agora n aparece nd.

segue:

 # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb1 during installation
UUID=3148f82b-6fb9-425d-97c4-8bd58e9661c0 /               ext4    errors=remount-ro 0       1
# /backup was on /dev/sdb4 during installation
UUID=7a5b0ad6-eb74-4d9a-8478-be613de92553 /backup         ext4    defaults        0       2
# /boot was on /dev/sdb2 during installation
UUID=c4afc4dd-ec4e-4664-bf2e-9031668496c7 /boot           ext4    defaults        0       2
# /home was on /dev/sda1 during installation
UUID=6f65548f-a51f-411a-8fe8-7f2e5412f673 /home           ext4    defaults        0       2
# swap was on /dev/sdb3 during installation
UUID=27d90a95-f8ef-407a-8936-1c1026b99630 none            swap    sw              0   `    0`

Tente ver com

lsblk -f

Se as UUIDs estão corretas

Tente tirar o quiet do /etc/default/grub

É depois atualize

Uma outra opção é ao inicializar o grub, tecle a letra e , tire o quiet da linha do kernel e aperte F10

Segue:

NAME   FSTYPE LABEL       UUID                                 MOUNTPOINT
sda                                                            
├─sda1 ext4               3148f82b-6fb9-425d-97c4-8bd58e9661c0 /
├─sda2 ext4               c4afc4dd-ec4e-4664-bf2e-9031668496c7 /boot
├─sda3 swap               e1cade7b-3be3-406c-bfe1-3b2304d9b720 [SWAP]
└─sda4 ext4               7a5b0ad6-eb74-4d9a-8478-be613de92553 /backup
sdb                                                            
└─sdb1 ext4               6f65548f-a51f-411a-8fe8-7f2e5412f673 /home
sdd                                                            
└─sdd1 vfat   External HD 4A54-E8A1                            
zram0                                                          [SWAP]
zram1                                                          [SWAP]
zram2                                                          [SWAP]
zram3                                                          [SWAP]

Me parece sem alteração.

O uuid do swap está errado

Pelo comando

sda3 swap e1cade7b-3be3-406c-bfe1-3b2304d9b720 [SWAP]

No fstab

UUID=27d90a95-f8ef-407a-8936-1c1026b99630 none swap sw

Troque do fstab…

dei um free -h e ele tá com 4gb, antes eram 2gb… na instalação do kali eu n criei 2gb, coloquei p aproveitar o que já tinha…

como resolveria este problema?

Edita o /etc/fstab com seu editor preferido e coloque no fstab que a uuid que sai com comando lsblk…

O sistema usa o que esta na saida do lsblk

Troque o uuid da swap…

Se nao usa zram, veja como remover no sistema

o que sai no comando lsblk é

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    0 238.5G  0 disk 
    ├─sda1   8:1    0  46.6G  0 part /
    ├─sda2   8:2    0   488M  0 part /boot
    ├─sda3   8:3    0   1.9G  0 part [SWAP]
    └─sda4   8:4    0  65.2G  0 part /backup
    sdb      8:16   0   477G  0 disk 
    └─sdb1   8:17   0   477G  0 part /home
    sdd      8:48   0 465.8G  0 disk 
    └─sdd1   8:49   0 465.7G  0 part 
    zram0  252:0    0 717.9M  0 disk [SWAP]
    zram1  252:1    0 717.9M  0 disk [SWAP]
    zram2  252:2    0 717.9M  0 disk [SWAP]
    zram3  252:3    0 717.9M  0 disk [SWAP]

seria colar isto no /etc/fstab ?

tirarei o zram

lsblk -f

Para ver a uuid

Veja as uuid das montagens e coloque exatamente a uuid que é mostrada com o comando acima

1 Curtida

Não apenas modifique a uuid

Entendeu?

Sim, estou modifcando as UUID e em seguida darei um reboot.

Após o reboot, o tempo de inicialização diminuiu mas ainda continua muito grande…
Segue analyze:

Startup finished in 34.943s (kernel) + 1.843s (userspace) = 36.787s
graphical.target reached after 1.829s in userspace

583ms upower.service
           553ms dev-sda1.device
           450ms ubuntu-system-adjustments.service
           405ms systemd-journal-flush.service
           388ms networkd-dispatcher.service
           366ms NetworkManager.service
           364ms udisks2.service
           253ms ufw.service
           188ms networking.service
           181ms virtualbox.service
           175ms accounts-daemon.service
           171ms ModemManager.service
           171ms zram-config.service
           159ms apparmor.service
           152ms systemd-udev-trigger.service
           151ms keyboard-setup.service



graphical.target @1.829s
└─multi-user.target @1.829s
  └─getty.target @1.828s
    └─getty@tty1.service @1.828s
      └─system-getty.slice @1.827s
        └─setvtrgb.service @1.823s +3ms
          └─systemd-user-sessions.service @1.606s +53ms
            └─network.target @1.605s
              └─NetworkManager.service @1.238s +366ms
                └─dbus.service @1.202s
                  └─basic.target @1.176s
                    └─sockets.target @1.176s
                      └─uuidd.socket @1.176s
                        └─sysinit.target @1.171s
                          └─apparmor.service @1.010s +159ms
                            └─local-fs.target @1.005s
                              └─boot.mount @980ms +24ms
                                └─systemd-fsck@dev-disk-by\x2duuid-c4afc4dd\x2de

O problema aí é o kernel… 34.943s

Vc modificou a pasta do boot, as imagens initrd

Vc usa mint?

Teria que ver qual pacote o mint utiliza…

Tente reinstalar o kernel para recriar a uma em…

Acho que com

apt -f install kernel…

Vc consegue fazer isso.

Seria interessante ver o tamanho das imagens no /boot

1 Curtida

Sim, utilizo o Mint.

no /boot :

hiyan@mint19:/boot$ du -shc *
233K	config-5.4.0-45-generic
233K	config-5.4.0-47-generic
7.2M	grub
66M	initrd.img-5.4.0-45-generic
66M	initrd.img-5.4.0-47-generic
du: cannot read directory 'lost+found': Permission denied
12K	lost+found
179K	memtest86+.bin
181K	memtest86+.elf
181K	memtest86+_multiboot.bin
4.4M	System.map-5.4.0-45-generic
4.4M	System.map-5.4.0-47-generic
9.0M	vmlinuz-5.4.0-45-generic
9.0M	vmlinuz-5.4.0-47-generic
167M	total

Suas imagens que estão boot estão com tamanho de 66M

dependendo do compressor que usa irá demorar…

Vc modificou o programa de gerenciamento da imagem do boot?

1 Curtida

Não não, nunca mexi nelas; no máximo nas att do Kernel, mas nada que influencie assim.