Jogos não abrem na Steam, Linux Mint

Fala galera! Vamos ver se alguém consegue me ajudar.

Após a instalação e configuração do Linux Mint, vários jogos da Steam não abrem, ao tentar abrir simplesmente aparece uma tela preta e fecha. Isso acontece somente no Mint, no Debian todos eles rodavam normalmente.

Linux Mint XFCE 64bits, já adicionada à arquitetura i386, ultima atualização mesa/vulkan… Se alguém tiver uma luz, pq a única que eu vejo é ¨limar¨ o Mint daqui. kkk

Já vi que o problema é entre a Steam e o Vulkan… Se eu rodar o jogo através do NOSTEAM direto na pasta do jogo, ele abre, porém a Steam não salva os progressos.
Agora é tentar descobrir pq os dois estão se estranhando.

Registro:

  • Removi drivers de vídeo, instalei novamente;
  • Removi pacotes referentes a GPU Intel, instalei novamente;
  • Desinstalei alguns jogos, restaurei por backup, outros baixei novamente;
  • Removi e reinstalei o OpenGL;
  • Utilizei várias Opções de Inicialização nas propriedades dos jogos.

Por enquanto nada resolveu. ¨Tenebroso¨.

Só uma pergunta, pq ta usando i386?? Pergunto, pq os processadores de 10 anos pra cá ja suportam SO de 64 bits. Nesse caso recomendo por o Mint de 64 bits e fazer o teste se funciona.

2 Curtidas

Isso aí estar bem esquisito nunca tive problema de Steam em nenhuma distro baseada no Debian, nem mesmo no Fedora, no Arch só na instalação que faltava algumas bibliotecas Nvidia 32bits que não tinha e depois de instalar resolveu, uma boa idéia é reinstalar o Mint e depois intalar os drivers de video proprietário (caso use Nvidia) e depois a Steam para ver se o erro persiste

1 Curtida

Tá vendo, deveria ter continuado no Debian! Kkkk
Acho que vc não vai lembrar de mim, mas nós conversamos no seu vídeo sobre o Lutris e PlayonLinux. :joy:
Zueiras a parte… O Sistema é 64bits. Só adiantei ali em cima que adicionei a arquitetura i386.

1 Curtida

Também nunca tive problemas no Debian. Tô achando que tenha algo a ver com a renderização do XFCE.

Depois que terminar um serviço aqui, eu vou instalar o Cinnamomum ou o Gnome e fazer o teste. Fora isso, ainda não consegui pensar em mais nada.

Ahhh ta, pq ali tava parecendo q vc ta usando Linux em 32 bits !!!

1 Curtida

Falha minha, estava estranho mesmo. kkkk
Alterei pra ficar mais fácil.

1 Curtida

@Keviny e @CanalOCaraDoTI.
Sem chances, instalei o Cinnamon e também não funcionou. Fiz tantos testes aqui que o sistema quebrou. Kkk
Voltei pro Debian e os jogos rodaram normal.

1 Curtida

Você estar usando qual interface gráfica no Debian?

Só no Mint que isso acontece?

No Debian eu uso Gnome. Mas o teste que fiz foi no Debian XFCE, pra ficar igual. Funcionou direitinho.

Até hoje só aconteceu no Mint, só não entendi pq. kkk

1 Curtida

O meu Mint 19.1 também tive problemas, não abria os jogos na steam, exceto o CS:GO se não me falha a memória, como ontem saiu o ubuntu 19.04, e eu queria testar, estou com ele (ubuntu) instalado e rodando meus jogos da steam de boa.

Não entendi nada, pq antes meu mint rodava de boa os jogos da steam…

1 Curtida

Sei que o tópico já está fechado, mas como encontrei uma solução(?), vou atualizar aqui para ficar registrado, caso mais alguém venha precisar.

Para os jogos nativos que não abrem ao clicar em jogar, ou abrem e fecham, enfim… Resolvi rodando eles pelo Proton! Sim, mesmo sendo nativo, habilitei o jogo para rodar através do Proton e funcionou.

1 Curtida