Jogo da GOG não abre Linux Mint

gog
linux-mint
#1

Boa tarde, estou com um problema para abrir um jogo, não abre de jeito nenhum. aparece assim pra mim :

zeclaudio@Linux-L2G:~/GOG Games/Baldurs Gate Enhanced Edition$ ./start.sh
Running Baldur’s Gate Enhanced Edition
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
X Error of failed request: GLXBadContext
Major opcode of failed request: 156 (GLX)
Minor opcode of failed request: 4 (X_GLXDestroyContext)
Serial number of failed request: 132
Current serial number in output stream: 133
zeclaudio@Linux-L2G:~/GOG Games/Baldurs Gate Enhanced Edition$

0 Likes

#2

tens de instalar os drivers para 32bits

0 Likes

#3

Eu já tinha feito, fiz igual esse site https://www.edivaldobrito.com.br/suporte-a-32-bits-no-ubuntu-de-64-bits/, porém não obtive sucesso.

0 Likes

#4

Qual é o driver??
Instalaste os pacotes recomendados do wine??

0 Likes

#5

mesmo sendo pra linux precisa de pacotes do wine ?

0 Likes

#6

tenta isto

sudo ln -s /usr/lib32/libjson-c.so /usr/lib32/libjson.so.0

0 Likes

#7

Coloquei pra download denovo e vou fazer isso antes de instalar novamente.

0 Likes

#8

sudo ln -s /usr/lib32/libjson-c.so /usr/lib32/libjson.so.0
[sudo] senha para zeclaudio:
ln: falha ao criar link simbólico ‘/usr/lib32/libjson.so.0’: Arquivo ou diretório inexistente

0 Likes

#9

cd ~/GOG Games/Baldurs Gate Enhanced Edition/lib
mv libstdc++.so.6 back_libstdc++.so.6
mv libstdc++.so.6.0.19 back_libstdc++.so.6.0.19

se nao funcionar tenta instalar o mesa para 32bits se usares intel ou amd

0 Likes

#10

Como o jogo é nativo não tem nada a ver com Wine.

Tenta atualizar os teus drivers.

Se utilizar AMD ou Intel: Tutorial

Se utilizar NVIDIA intala a versão proprietária do gestor de drivers do Mint.

0 Likes

#11

Nada, se eu instalar a versão da steam será que tenho mais sucesso ?
A versão do drive seria essa OpenGL version string: 3.1 Mesa 18.3.3 - padoka PPA ?

0 Likes

#12

Tu tem o mesmo jogo na Steam? Acho que as chances de sussesso na Steam são de quase 100%. haha

0 Likes

#13

Blz, vou comprar ele lá

0 Likes

#14

vi um site dizendo pra instalar

How to install:

  1. apt-get install libjson0 libopenal1
  2. Unpack the archive, Enjoy.

for debian / ubuntu amd64

  1. dpkg –add-architecture i386
  2. apt-get install libjson0: i386 libopenal1: i386
  3. Unpack the archive, Enjoy.

Attention: This game REQUIRES libjson0

Só que não acontece nada

zeclaudio@Linux-L2G:~$ sudo apt-get install libjson0
[sudo] senha para zeclaudio:
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
E: Impossível encontrar o pacote libjson0
zeclaudio@Linux-L2G:~$

0 Likes

#15

esse pacote já nao está nos repositorios do ubuntu, acho que agora é este:
sudo apt install libjson-c-dev

0 Likes