Irpf2020 Debian Buster, só com open jdk alguém sabe processo de instalação?

Tentei com java que não tenho e a instalação do mesmo é automática qdo baixar o irpf, mas está bugada.
Tentei jar, mandam executar um txt que não consigo localizar.
Se alguém puder listar os comandos para usar só o open jdk ficarei agradecido.

Tentou baixar diretamente do site como é recomendado nas instruções? Desculpe, não ficou claro.

https://www.java.com/pt_BR/download/manual.jsp

Ali tem, ao lado do download para sua versão, as instruções de instalação.

1 Curtida

Então, Wielewski, o que queria e não baixar esta bagaça. Sempre dá problemas. Queria usar o irpf2020 com o openjdk sem java. Qdo baixar o irpf ele automaticamente te manda pro java só que tem bug no link ou sei lá onde e não complementa a instalação nem do irpf nem do java.

Aqui ta funcionando com o OpenJDK no Mint 19.3

➜  ~ java --version    
openjdk 11.0.6 2020-01-14
OpenJDK Runtime Environment (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1)
OpenJDK 64-Bit Server VM (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1, mixed mode, sharing)

O processo de instalação foi…
Baixei a versão .jar do instalador no site da receita
http://receita.economia.gov.br/interface/cidadao/irpf/2020/download/solaris-outros-jar

Depois segui o procedimento de instalação:

Ou seja… abra um terminal na pasta onde fez o download do programa e execute o instalador com o comando

java -jar IRPF2020v1.0.jar

Obs: a versão .bin deu erro na instalação indicando que não havia Java instalado.

Agora é só localizar a pasta onde você instalou e este é o programa:
IRPF2020

Para abrir o programa você pode fazer pelo terminal com o comando:

java -jar irpf.jar
ou
criar um atalho contendo o comando para o programa:
java -jar caminho_para_o_programa/IRPF2020/irpf.jar
ou marcar o irpf.jar como executável, para executar com o click
ou de outra maneira que você já está acostumado fazer no seu sistema :slightly_smiling_face:

1 Curtida

segue no link com o processo

1 Curtida

Ainda não testei esse ano. Mas no ano passaro resolvi facilmente com esse tutorial do Leandro Ramos.

1 Curtida

Rogério, muito obrigado. Acho que chegou a instalar, mas tá dando esta mensagem:
us@us:~$ java -jar irpf.jar
Error: Unable to access jarfile irpf.jar
Fiz com root deu a mesma mensagem.
image
OUTRA DÚVIDA: A chicrinha de café é o ícone do java. Então no seu sistema não seria o java execuntando ao invés do openjdk?

Você tem que abrir o terminal dentro da pasta de instalação IRPF2020
ou então passar o caminho completo até o programa
java -jar ~/local_onde_instalou/IRPF2020/irpf.jar

O openjdk é uma “versão do java” que não é feito pela Oracle

OpenJDK é uma implementação livre e gratuita da plataforma Java, Edição Standard. É o resultado dos esforços da Comunidade Java para a evolução atemporal da linguagem. Serve como incubadora de novas ideias que normalmente são implementadas no JDK comercial da Oracle para serem rentabilizadas posteriormente.

Obs. Não precisa usar root.

He, he agora sim. Muito obrigado Rogerio!

1 Curtida

Swatquest consegui sem java(ORACLE) com a dica do Rogerio. Obrigado.
Tnsampa, obrigado. Na verdade como foram muitas tentativas, resolvi remover tudo que estava instalado, e aí começou a dar certo. Não podemos ter preguiça no linux, rs rs rs.

A vida de um analfa digital não é nada fácil:
root@us:~/ProgramasRFB# java -jar /root/ProgramasRFB/IRPF2020/irpf.jar
Redirecionando msgs de erro para ‘IRPF2020.log’…
Redirecionando msgs de erro para ‘IRPF2020.log’…
arq log = /root/ProgramasRFB/IRPF2020/IRPF2020.log
TinyLaF v1.4.0
Theme: jar:file:/root/ProgramasRFB/IRPF2020/irpf.jar!/Default.theme
Proporcao da tela eh menor que 16:9, reduzindo aba lateral…
Executando download…
Mostrando toast…
Fechando dlg…
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by foxtrot.pumps.ConditionalEventPump$1 (file:/root/ProgramasRFB/IRPF2020/lib/foxtrot.jar) to method java.awt.EventDispatchThread.pumpEvents(java.awt.Conditional)
WARNING: Please consider reporting this to the maintainers of foxtrot.pumps.ConditionalEventPump$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
URL:https://wsrascunhoirpf.receita.fazenda.gov.br/barramentoirpfpgd/rest/captcha
Como resolvo?

Você ta tentando executar como root? Não precisa executar como root, e quando for instalar também não precisa ser como root.

Rogerio, acho que de ficar instalando e desinstalando, no debian, ficaram pedaços por aí e só permitiu eu instalar no diretório root. Se desse um endereço diferente ele dizia que já existia e não instalava. Experimentei trocar a pasta e nada feito. No desespero para entregar essa bagaça, deixei assim mesmo, em root e aí só acesso esse endereço se tiver logado como administrador (sudo su). Tentei o vídeo para instalar um atalho e também não aparece na tela nem no iniciar.

Você já começou a preencher a declaração? Se sim faça um backup dos dados. Aqui ele criou uma pasta na ‘home’ chamada “ProgramasRFB” e dentro uma chamada “IRPF2020” copia esta pasta. Eu acho que dá para importar depois em outra instalação.
Tenta executar o pgd-updater.jar pelo terminal talvez corrija o problema.

Abra um terminal dentro da pasta IRPF2020 e digite o comando no terminal
java -jar pgd-updater.jar

Como você desinstalou? Você usou o uninstaller.jar? você executou ele como root ou como usuário?

Se nao me engano… para funcionar tem que ser a versao 8
Instale e teste novamente

Rogerio, lembro-me de como root ter removido com rm-r … arquivos.
Qdo deu pra deletar deletei com del a instalação(foram várias tentativas de instalação)
Vou tocar assim mesmo pois tive que retificar a 2017 e já deu no saco.
Acho que deveríamos entupir a receita com reclamações pois tá tudo bugado.
Pedir para cortar o endereçamento ao java e que fosse criado o ícone direto na tela inicial.
Esses caras ganham uma fábula, pra fazer essa ■■■■■.
Ps: Já estou na versão l.5(última versão) do jar do programa, e o java jar atualizaria estou correto?

Olá @Rogerio e @malachias ,

É triste… ano após anos e surgindo problemas de configuração e instalação do programa nas versões para linux.

Como já sou um usuário linux faz muitos anos, mesmo me considerando razoavelmente leigo para muitas coisas de informática, consigo fazer todas minhas atividades dentro do linux e este tipo de problema não me afasta do uso de sistemas operacionais linux… Mas para muita gente que conheço isso é motivo para nunca mais querer saber de linux na vida. A pessoa perde a confiança no programa e depois no sistema operacional, uma vez que já na instalação do software fica tendo estes erros e atribui a culpa ao linux. Sabemos que erros no windows também acontecem, mas essas instituições podiam disponibilizar versões mais funcionais para leigos completos ou criar uma versão (funcional é claro) que funcionasse pelos navegadores.

Será que é tão difícil fazerem uma solução que funcionasse pelo navegador ou então em que a pessoa instale o programa mesmo pela loja de app da distribuição ou com poucos cliques após baixar o arquivo direto do site oficial já não seria possível ter o programa todo funcional e com todos os complementos adicionais já configurados? Ou será que consideram que o tamanho de público atingido não compensa o esforço?

Outra coisa que me decepciona são bancos como caixa e bb e a aquele tal de complemento warsaw. Tantos bancos hoje em dia em que tudo já funciona direto pelo navegador e eles insistindo neste tal recurso de warsaw que tem de ser instalado no pc, que de tempos em tempos dá problema. A empresa não poderia se adaptar e criar soluções em que os pré-requisitos (como este warsaw) funcionassem no servidor dela ao invés de introduzir esta tarefa para o usuário leigo, o que por vezes acaba por virar barreira de uso?

Maioria dos usuários de computadores apenas quer usar o equipamento e resolver o seu problema. Não quer ficar aprendendo diversas configurações, ainda mais se não funcionarem. Isso que as empresas parecem não entender.

Mas enfim… enquanto isso vamos nos virando…

1 Curtida

Assino embaixo e reconheço firma.

@malachias,

Sinto muito por sua situação, mas nem vou gastar tempo tentando procurar e apresentar soluções, pois este tipo de erro e situação (que deveria ser respondido e solucionado pelas empresas que criam os programas) já me fez passar muita raiva no passado. Horas e dias literalmente “brigando” com java, este open jdk, ou o tal do warsaw para muito pouco aprendizado computacional.

Já teve anos que consegui fazer funcionar o programa no linux, enviar adequadamente as declarações, em outros não.

Agora você pensa, como vou apresentar esta solução para pessoas que lidam com contabilidade diariamente, como escritórios ou autônomos?

Ninguém quer uma ferramenta que não funciona, e de quebra vai ficar achando que o problema é do linux. Tenho a consciência de que o problema não é o linux, mas da falta de interesse de quem cria o programa em dispor adequadamente as formas de obtermos um adequado funcionamento dele.

Qualquer coisa em último caso usa uma máquina virtual ou o próprio windows mesmo, caso o período da declaração estiver encerrando.

Por educação, não vou fazer mais postagens aqui, até para não correr o risco do assunto abordado ficar OFF Topic.

Se tiver outras dúvidas em outros tópicos aqui no fórum tento ajudar com o maior prazer se souber. Mas com questões de warsaw e instalação deste programa, eu já não aguento mais.

Desejo sorte e realizações em seus caminhos e aprendizados! Até uma próxima.

2 Curtidas

Já estou no final da declaração. Vou conseguir entregar(acho) rs rs.
Desde já agradeço o empenho, e só esclarecendo acho que deveríamos cobrar da receita federal o perfeito funcionamento, caso contrário demitimos os programadores que só lembrando, somos nós que pagamos, e pagamos uma fortuna mensalmente.
PS: Aliás, a minha reclamação já foi postada na receita federal.