Instalar o Network Manager

#1

Estou tentando instalar e configurar o Network Manager junto com um Tray para gerir minha rede numa instalação mínima do LXQT.

Já procurei todo tipo de instrução na Web, mas não consigo fazer funcionar apropriadamente.

  1. Instalo o ‘network-manager’ e o ‘network-manager-gnome’
  2. Faço nesta ordem:
    ‘sudo systemctl stop systemd-networked’
    ‘sudo systemctl disable systemd-networked’
    ‘sudo systemctl start NetworkManager’
    ‘sudo systemctl enable NetworkManager’
  3. Re-logo no sistema e aparece o ícone de rede na área de notificações. Só que com um ‘x’ no ícone e informando “device no managed”.

Já fui ‘/etc/NetworkManager/NetworkManager.conf’ e no item ‘managed’ editei para ‘true’, mas continuou do mesmo modo. Acredito que não seja isto.

Gostaria que alguém me ajudasse a fazer isto de forma certa. Se alguém puder me ajudar, ficaria grato…

0 Likes

#2

Bom vamos lá, amigo

Voce disse que ja alterou ```
/etc/NetworkManager/NetworkManager.conf

de managed=false para managed=true nao é isso?

após isso voce deu o comando

sudo service network-manager restart
??
Opção simples ,instalar o wicd gerenciador e verificar se ele reconhece.
Alternativamente, você pode remover a interface de /etc/network/interfaces.

faça backup do arquivo de interfaces atual:

sudo cp /etc/network/interfaces /etc/network_interfaces_backup

Exclua tudo nesse arquivo e copie e cole o seguinte:

auto lo
iface lo inet loopback

Salve e de um restart no network manager:

sudo service network-manager restart

0 Likes

#3

Talvez não seja o modo mais correto, mas eu já consegui fazer funcionar aqui. Eu fiz assim…
Em
/etc/netplan/01-network-manager-all.yaml
Deixei da seguinte forma:

#This file describes the network interfaces avaliable on your system
#For more information, see netplan(5).
network:
version: 2
renderer: NetworkManager

este arquivo estava diferente, e o item ‘renderer’ estava antes como ‘networkd’.

Executei o seguinte comando:

sudo ip link set enp0s3 up

E fiz um reboot. Quando voltou, já voltou normal, só tive que fazer um link do ‘resolv.conf’ da pasta ‘/run/systemd/resolve/resolv.conf’ substituindo o de ‘/etc/’. Fiz um novo reboot e estava tudo certo.

0 Likes

#4

Acho que assim deve funcionar também. Mas antes tem que instalar o pacote ‘ifupdown’, não?

Vou tentar dessa forma no virtualbox depois pra ver se vai também…

0 Likes

#5

já vi muitos casos do NetworkManager não funcionar corretamente… o systemd-networked é ruim? systemd-networked esse que vc usava anteriormente?

0 Likes

#6

O systemd-networked é o padrão que o Ubuntu utiliza na instalação para baixar os pacotes durante a instalação do sistema. Ele é bem limitado e parece não permitir configurações de modo “amigável”…

0 Likes

#7

Cara, não entendi sua pergunta… você quer instalar o network-manager para gerenciar as conexões via interface gráfica, correto?

No meu, instalei da seguinte forma:

apt-get install network-manager

As configurações realizei diretamente via interface mesmo.

0 Likes

#8

Caramba! Nunca pensei que o Ubuntu pudesse ser mais trabalhoso que o Arch. No Arch foi só instalar os pacotes e rodar um enable e start com o systemctl que tudo ficou funcionando de boas.

0 Likes