Instalação do Hplip no Pop_OS!

Olá pessoal

Estou tentando efetuar a instalação do HPLIP no Pop_OS 20.04
O instalador automático dele não é compatível com o POP_OS, mas é compatível com o Ubuntu 20.04. Então tentei me basear na versão do Ubuntu para isso.
Durante a instalação ele informa que terá que instalar algumas dependências para poder prosseguir:

plip-install[79495]: info: :Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
hplip-install[79495]: info: :Package-Name Component Required/Optional
hplip-install[79495]: info: :libjpeg base REQUIRED
hplip-install[79495]: info: :libtool base REQUIRED
hplip-install[79495]: info: :cups-devel base REQUIRED
hplip-install[79495]: info: :cups-image base REQUIRED
hplip-install[79495]: info: :libusb base REQUIRED
hplip-install[79495]: info: :sane-devel scan REQUIRED
hplip-install[79495]: info: :libavahi-dev scan REQUIRED
hplip-install[79495]: info: :xsane scan OPTIONAL
hplip-install[79495]: info: :dbus fax REQUIRED
hplip-install[79495]: info: :libnetsnmp-devel network REQUIRED
hplip-install[79495]: info: :libcrypto network REQUIRED
hplip-install[79495]: info: :python3-notify2 gui_qt5 OPTIONAL
hplip-install[79495]: info: :python3-pyqt4-dbus gui_qt4 OPTIONAL
hplip-install[79495]: info: :python3-pyqt4 gui_qt4 REQUIRED
hplip-install[79495]: info: :python3-pyqt5-dbus gui_qt5 OPTIONAL
hplip-install[79495]: info: :python3-pyqt5 gui_qt5 REQUIRED
hplip-install[79495]: info: :python3-reportlab fax OPTIONAL

Tentei efetuar a instalação das dependências manualmente, mas por exemplo a dependência libjpeg não existe nos repositórios do Pop_OS!.
Achei a lib libjpeg62, mas instalando ela o instalador não indica que ela está instalada no sistema.
Talvez criando um link simbólico para o arquivo da dependência com outro nome funcione, mas não tenho idéia de qual seria.
Alguém já passou por esse caminho das pedras e poderia dar uma luz aqui?

1 Curtida

Bom, como não obtive respostas fui a caça.
Achei esse site que me deu a dica:
https://www.yourtechshow.com/2020/02/install-hp-printer-in-ubuntu-elementary.html

Basicamente, o Pop_OS ja tem os pacotes, só tinha que instalar a base e a GUI com o comando:

sudo apt install hplip hplip-gui

Valeu galera!

1 Curtida