Graficos dos jogos estão quebrados, ubuntu 20.04 lts

Vc pode ajudar ele a testar essa config? Colocando em SNA ou UXA, DRI2 ou 3?

Posso…

Passo o caminho, mas como falei, tem que configurar e ir testando

2 curtidas

entendi mas não entendi mas estou compreendendo.

Tentamos usar uma versão mais recente do mesa, porém sem sucesso. Vc poderia fazer o procedimento com ele configurando um xorg testando com aceleração uxa e dri2 ou 3?

info
https://wiki.archlinux.org/title/intel_graphics
https://packages.ubuntu.com/search?keywords=xserver-xorg-video-intel

Vamos lá.

habilitar dri
tentar primeiro modesetting
tentar drive intel

habilitar dri

instale o adriconf

sudo apt install adriconf

Abra o programa, clique em default e salvar.

Recomendo antes ver se você tem o arquivo /etc/X11/xorg.conf . Caso exista pode fazer um backup dele.

por exemplo
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bkp

Primeiro vamos tentar configurar com modesetting. Várias distros recomendam usar eles, em vez do drive da intel, mas vai depender de cada máquina.
Normalmente já é utilizado por padrão, caso nenhum seja configurado.

Provavelmente não terá esta pasta no ubuntu, mas pode criar sem problema

sudo mkdir -p /etc/X11/xorg.conf.d/

então crie o arquivo 20-modesetting.conf dentro dela

/etc/X11/xorg.conf.d/20-modesetting.conf

E adicione

Section "Device"
    Identifier      "Intel Graphics"
    Driver          "modesetting"
    Option          "AccelMethod"   "glamor"
    Option          "PageFlip"      "on"
EndSection

Reinicie a máquina e tente novamente
E veja como fica.

Se não funcionar, podemos tentar o drive da intel
para intel veja se tem instalado xserver-xorg-video-intel

se não tiver
sudo apt install xserver-xorg-video-intel

Apague o arquivo /etc/X11/xorg.conf.d/20-modesetting.conf
E crie o arquivo /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"		"true"
   Option      "DRI"			"3"
   Option      "AccelMethod"		"sna"
EndSection

Atenção
vc pode ir modificando os valores para ver se melhora ou não

Option “DRI” “3”
Option “AccelMethod” “sna”

para

Option “DRI” “2”
Option “AccelMethod” “uxa”

Pode tentar somente o dri ou somente AccelMethod.

o seu pc é o Ivy Bridge

pode ver este tópico para ativar funções

Suporte de recursos

Generation Chipset OpenGL OpenGL ES OpenCL VAAPI Vulkan VIDEO_CARDS
Gen 1 810, 815 No No No No No unsupported
Gen 2 i830M, 845G, 855GM, 865G 1.3 No No No No intel i915
Gen 3 915G/GM, 945G/GM, G/Q33, Q35, Atom D4xx/D5xx/N4xx/N5xx 1.4 No No No No intel i915
Gen 4 965G/GM/Q, G35, G41, G/Q43, G/GM/Q45 2.1 2.0 No G/GM45: MPEG2 only No intel i965
Gen 5 Nehalem (Ironlake) 2.1 2.0 No Yes No intel i965
Gen 6 Sandy Bridge 3.3 3.0 No Yes No intel i965
Gen 7 Ivy Bridge , Valley View[table 1] 3.3 3.0 1.1[table 2] Yes Partial intel i965
Gen 7.5 Haswell 4.5 3.1 1.1[table 2] Yes Partial intel i965
Gen 8 Broadwell , Cherryview[table 3] 4.5 3.1 1.1[table 2] Yes Yes intel i965
Gen 9 Skylake , Broxton[table 4] 4.5 3.2 1.1[table 2] Yes Yes intel i965
Gen 9.5 Kaby Lake , Coffee Lake 4.5 3.2 2.1[table 2] Yes Yes intel i965

Desculpe a demora, fiz esse método porém sem resultados =/

@swatquest o @anon34547030 levantou a hipótese que seja uma incompatibilidade dos drivers de video com a minha cpu, acho que faz total sentido e que talves seja esse o motivo pelo qual o linux min não tem esse problema, ele deve usar uma versão mais antiga ou que já tenha compatibilidade.

acredito que a melhor solução seja ir pro linux mint novamente, agradeço a todos que se esforçaram até aqui, o tópico ficara aberto para novas soluções.

O mint usa xorg e o Ubuntu wayland.

Vc pode tentar trocar para o xorg

No gerenciador de login.

Mude para xorg e veja se o funciona

vou tentar

no gerenciador de login estava a seguinte situação

Ubuntu
Ubuntu wayland

acho que já estava em xorg porque a primeira opção era a selecionada

Mude para Ubuntu wayland

E veja se melhora

ja fiz, não mudou nada =/

Tenta mudar o kernel para o kernel lts

1 curtida

acho que já é lts, pq eu havia baixado a versão lts no site

1 curtida

Pode ser meio inutil, mas tente reinstalar a interface gnome com:
sudo apt install --reinstall gnome-shell
Como no Mint está ok (Cinnamon) e no Ubuntu (GNOME) não, pode ser este o problema
Podes tentar reinstalar o xorg tbm com:
sudo apt install --reinstall xorg (se não me engano)

1 curtida

posso testar

1 curtida

Mas está em uma nova instalação. Não acredito que seja isso.

Faz um teste…simples.

Desative todas as extensões…
E teste novamente…

Pelo que vi vc quer usar gnome.

Já tentou instalar outra distro. Fedorq, manjaro, pop-os e etc…