Gnome 3.36 no Pop OS congela e volta ao normal aleatoriamente

Minhas aplicações aleatoriamente travam enquanto realizo qualquer atividade, sendo somente possível mexer no mouse e abrir o multitarefas do Gnome, espero alguns segundos e ele retorna ao normal, porém, isso acontece repetidamente e é estressante. Alguém já passou pelo mesmo problema, sabe identificá-lo ou tem algo a supor? Agradeço cada feedback.

1 Curtida

Você poderia fornecer mais detalhes?

  • Qual a quantidade de memória RAM do computador?
  • Você usa gráficos integrados ou uma GPU da Nvidia ou AMD?
  • Você já passou por problemas parecidos em outras distribuições?
1 Curtida

E também poderia verificar se algum erro é registrado no log ?

journalctl -f

1 Curtida

Recomendo para primeiro testar desativando as extensões, desative todas e veja se o erro persiste
Se funcionar, ative uma por uma para ver qual que está ocasionado o erro.

1 Curtida

Tem que detalhar, mas, isso está com cara de falta de RAM, uso elevado do processador ou erro de disco.

1 Curtida

Opa! A quantidade de memória RAM no meu computador é 8Gb DDR4.

Sim, tenho um notebook de placa híbrida NVidia.

Nunca passei por esse problema, o
último sistema que usei foi o Windows usando o WSL para programar, porém resolvi voltar pra um Linux puro por não me sentir tão produtivo. Até maio do ano passado usava Ubuntu 20.04 e não tinha nenhum problema.

Acabo de verificar e felizmente não há nenhum erro registrado, todos os processos mostrados estão como bem sucessidos na execução.

Seria interessante deixar um terminal aberto com o comando

jounalctl -f

rodando.

Quando o desktop travar, ver se aparece alguma mensagem de erro no log.

1 Curtida

Acabo de analizar meu HD e estou vendo que ele está com vários setores ruins. Pode isso influenciar no problema que estou tendo?

Jan 02 09:13:40 pop-os kernel: ata1.00: exception Emask 0x0 SAct 0x7f800000 SErr 
0x50000 action 0x0
Jan 02 09:13:40 pop-os kernel: ata1.00: irq_stat 0x40000008
Jan 02 09:13:40 pop-os kernel: ata1: SError: { PHYRdyChg CommWake }
Jan 02 09:13:40 pop-os kernel: ata1.00: failed command: READ FPDMA QUEUED
Jan 02 09:13:40 pop-os kernel: ata1.00: cmd 60/40:b8:98:76:70/05:00:1f:00:00/40 tag 23 
ncq dma 688128 in
                                    res 43/40:40:b0:78:70/00:05:1f:00:00/40 Emask 0x409 (media error)<F>
Jan 02 09:13:40 pop-os kernel: ata1.00: status: { DRDY SENSE ERR }
Jan 02 09:13:40 pop-os kernel: ata1.00: error: { UNC }
Jan 02 09:13:40 pop-os kernel: ata1: hard resetting link
Jan 02 09:13:40 pop-os kernel: ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
Jan 02 09:13:40 pop-os kernel: ata1.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
Jan 02 09:13:40 pop-os kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
Jan 02 09:13:40 pop-os kernel: ata1.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
Jan 02 09:13:40 pop-os kernel: ata1.00: ACPI cmd ef/10:06:00:00:00:00 (SET FEATURES) succeeded
Jan 02 09:13:40 pop-os kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
Jan 02 09:13:40 pop-os kernel: ata1.00: ACPI cmd b1/c1:00:00:00:00:00 (DEVICE CONFIGURATION OVERLAY) filtered out
Jan 02 09:13:40 pop-os kernel: ata1.00: configured for UDMA/100
Jan 02 09:13:40 pop-os kernel: sd 0:0:0:0: [sda] tag#23 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE cmd_age=11s
Jan 02 09:13:40 pop-os kernel: sd 0:0:0:0: [sda] tag#23 Sense Key : Medium Error [current] 
Jan 02 09:13:40 pop-os kernel: sd 0:0:0:0: [sda] tag#23 Add. Sense: Unrecovered read error - auto reallocate failed
Jan 02 09:13:40 pop-os kernel: sd 0:0:0:0: [sda] tag#23 CDB: Read(10) 28 00 1f 70 76 98 00 05 40 00
Jan 02 09:13:40 pop-os kernel: blk_update_request: I/O error, dev sda, sector 527464624 op 0x0:(READ) flags 0x4000 phys_seg 101 prio class 0
Jan 02 09:13:40 pop-os kernel: ata1: EH complete

Creio que esse seja o motivo do que está acontecendo comigo, obrigado pela ajuda!

1 Curtida

Você instalou alguma extensão antes desse problema acontecer? Se sim, verifique as extensões que você instalou e desative as mesmas.

1 Curtida

Nenhuma extensão, somente as que já vieram com o sistema. Tava olhando o estado do meu HD e ele está com vários setores ruins. Verifiquei a atividade do meu computador através do ctljournal e a kernel está acusando setores ruins obrigando ele a dar um freeze no sistema e alocar memoria em outros setores.

1 Curtida

Eita pau, Igor !

Você tem um plano B ?
Eu só imagino “comprar outro HD e reinstall tudo de novo”.

1 Curtida

A unica coisa que vem em mente, comprar um SSD kkkk. Tenho quase 4000 setores danificados.

Se eu fosse você, começaria a salvar os arquivos, talvez para algum dispositivo de armazenamento externo ou em nuvem antes que o HD fique comprometido.

3 Curtidas

Irei fazer, obrigado!

Olá @theoneaboveall. Se você conseguir fazer o back up dos seus arquivos, tenta o fsck, ele isola bad blocks. Mas primeiro você deveria verificar partição com fdisk -l

Por exemplo: fdisk -l o retorno for /dev/sda então fsck /dev/sda
O sistema vai performar um “isolador de bad blocks” e depois de completo você terá o sistema intacto para uso.

:vulcan_salute:

2 Curtidas

Procedimento realizado, obrigado pela ajuda!

1 Curtida

Pode sim, dependo do nível dessas falhas, idade do HD, etc. Como eu imaginei, pelo seu relato deve ser problema de hardware. O HD é muito antigo? Já caiu alguma vez?

2 Curtidas

Tenho 2 anos com ele, comprei em janeiro de 2019. Nunca caiu, mas problemas acontecem e já providenciei um ssd novo para ele.

2 Curtidas