GIMP - Mudando as cores quando salvo em .png

Pessoal, tudo bem?

Estou usando o GIMP para fazer um flyer para um evento.

Mas estou tendo um probleminha. Sempre que eu exporto o .xcf para .png algumas cores mudam!

De azul vai pra roxo. Sabem o que pode ser?

Como está tua configuração de cores? A minha fica assim e dá tudo certo:


Uma imagem em azul:

Exportando:


Resultado:

Só as resoluções X e Y que estão diferentes.
Não sei por que, nunca mudei.

Olha como fica (deixei mais clara, a diferença reduziu):
Original
Captura de tela de 2020-11-10 19-39-12

PNG
Captura de tela de 2020-11-10 19-39-37

Se eu deixar o azul mais escuro:

Captura de tela de 2020-11-10 19-42-13 Captura de tela de 2020-11-10 19-42-54

Essa não altera cores, só a resolução da imagem (eu costumo colocar 600 dpi)
E sim, parece que há alguma diferença, pouca mas há

1 Curtida

Aqui a diferença é muita!!

1 Curtida

Uma alternativa é tentar com Krita (mantendo RGB 8 bits) ou Inkscape (testando CMYK ou RGB pra ver o que acontece)

A maneira mais simples e rápida, talvez seja dar um Reset geral nas Preferências.

Você perde as configurações que já fez, mas talvez seja interessante começar tudo de novo ─ e anotando num caderno ou num TXT tudo que alterar.

Fiz muito isso, quando estava começando, e me perdia no meio de tantas opções. ─ Depois de anotar, acabei me localizando no meio desse labirinto, e agora lembro bem as coisas que prefiro. Em poucos dias, configuro uma distro recém-instalada.

1 Curtida

Vou tentar amanhã!

2 Curtidas

Cara, não resolveu :frowning:
Captura de tela de 2020-11-10 19-53-09 Captura de tela de 2020-11-10 19-53-41

2 Curtidas

Verifique na barra do Menu > Image > Mode, por favor.

Está RGB?

Você deseja exportar como RGB?

1 Curtida

Ve se o modo de cor está em indexado:

Imagem ➝ Modo

Se estiver, coloque como RGB, na hora de exportar:

Sem título

Não deu também :frowning:

Manda o arquivo .xcf pra gente analizar

experimenta mandar o png pra si mesmo pelo zap ou telegram e veja se no celular o erro se mantém

mantém :frowning:

1 Curtida

Opa, hoje a tarde eu mando.

Tenta as opções RGB ou RGBA e veja o que ocorre, @rxtheodoro

Ei, aqui encontrei problema semelhante (ou talvez o mesmo). Quando exporto a imagem e abro pelo visualizador de imagens do GNOME, as cores sofrem esse desvio (justamente o azul fica roxo). Se abro em qualquer outro programa, isso não acontece. O navegador Chromium também altera as cores das páginas, coisa que não acontece no Firefox. Não sei porque isso ocorre. Veja se não seria isso…

O problema não parece ser o GIMP, mas sim o visualizador de imagens e o Chromium. Testei a imagem exportada em outro computador, com Windows, e o azul estava lá, perfeito…