FPAKMAN para distros baseadas em Debian/Ubuntu

Olá pessoal!

Vi a funcionalidade do FPAKMAN no Manjaro KDE pelo vídeo do Dio e de alguns gringos. Achei excelente. Porém, no próprio link do github, tem o passo a passo para por a aplicação em outras distros e não consigo executar o processo. O terminal sempre trave em alguma parte do passo a passo.

Alguém poderia me ajudar?

Minha distro é Pop!_Os 18.04 LTS em caso de dúvidas.

Chega a exibir alguma mensagem de erro?

1 Curtida

Meu bruxo, desculpe a demora em te responder! Rotina está muito pesada…

Consegui, mesmo com a minha newbiezisse fazer rodar o Fpakman. Neste mesmo tópico, nesta semana, vou fazer o meu passo a passo na perspectiva de um usuário na posição de entusiasta aqui pra galera que curtir a ideia do Fpakman, poder utilizar.

Saliento: A pontos que não sei o que significam, quando aparecem no terminal(nisto, creio que tu e outros usuários mais experientes, poderiam contribuir).

Não sei se faço vídeo OU um passo a passo escrito bem bonitinho.

Vou escrevendo no meu writter e tirando meus screenshots, se necessário, umas anotações bem objetivas pra galera ver.

2 Curtidas

fiquei interessado de qualquer forma sobre essa aplicaçao só que baseado no que vc postar estarei fazendo o debian por que tentei tambem e nao deu muito certo mas talvez atraves doseu tutorial eu consiga adaptar para o mesmo.

1 Curtida

Só lembrando que o fpakman foi renomeado para bauh

DICA: Em algumas distros o python-pip instala a versão python3-pip, em outras instala a versão python2-pip, e para funcionar o fpakman/bauh necessita do python3-pip.
No Arch por exemplo, quando se instala o pacote python-pip, na verdade vc esta instalando a versão python3-pip
Portanto antes de instalar, pesquise pelos pacotes python3-pip e python2-pip para diferenciar entre eles, vc terá sempre dois pacotes disponiveis para sua distro:

python-pip
python(2 ou 3)-pip -> se for 2, significa que o outro pacote é 3

2 Curtidas

Muito obrigado!

Na correria esqueci de por o link novo. Fpakman foi para BAUH, como no link do GitHub acima.

Agradecido! <3

Pessoal, segue o meu passo a passo para instalar o FPAKMAN/BAUH em sua distro baseada em Deb/Ubuntu. Saliento: É a perspectiva de um entusiasta de Linux, espero que a galera mais experiente complemente as lacuna, caso fiquem em abertas.

Primeiro, sigam para este link: GitHub - vinifmor/bauh: Graphical user interface to manage your Linux applications. It currently only supports Flatpak and Snap applications.

Como já foi citado neste tópico por @Pio, o projeto FPAKMAN no Github mudou de nome para BAUH.

É importante que façam o uso do terminal e dos itens a seguir no link correto, dessa forma eu não tive mais os erros que apareceram justamente por estar em um repositório desatualizado/descontinuado.

Ao entrar no link supracitado, irão ver estas opções:

*Debian-based distros

python3-venv

*Arch-based distros

python
python-requests
python-virtualenv
python-pip
python-pyqt5

Os itens em destaque, deverão ser instalados pelo terminal utilizando o comando:

  • Ex: sudo apt install python3-venv

Destacando que: Embora pareça que somente “Debian-based” usem aquele comando, não quer dizer que o seu sistema tenha os outros 5 no tópico do “Arch-based distros”. Por isso, verifique com o comando acima, se todos os itens estão no seu sistema . No caso, PYTHON e PYTHON-REQUESTS.
Os outros 3 no final: * python-virtualenv
* python-pip
* python-pyqt5

Devem ser instalados também.

E agora vem o final:

Não consegui instalar pelo PyPi, mas na instalação manual, foi tranquilo!

  • Lembrando, de fazer como “sudo env/bin/pip install bauh” no segundo comando sublinhado.

E depois, somente usar o ultimo comando manual para abrir o FPAKMAN/BAUH!