Falha ao atualizar os repositorios

Depois de atualizar o Ubuntu 19.10 para 20.04LTS, ele dá um erro no app de atualização de programas

Verifique a conexão com a internet, parece ser esse o erro…

Ou então pode ser algum problema de PPA. Tente ver o que se passa.

Camarada, ao que me parece você está tentando instalar um aplicativo pela loja do ubuntu budgie, certo? Isso acontece quando há um erro no arquivo que gerencia a lista dos provedores dos programas, assim ele não consegue acessar o arquivo para a instalação do aplicativo e informa um erro genérico. Recomendo que tente esses comandos para solucionar o teu problema:

$ cd /var/lib/apt
$ sudo mv lists lists.old
$ sudo mkdir -p lists/partial
$ sudo apt update

Estes comandos vão recriar o diretório responsável pela lista de provedores e tentar atualizá-los, desta forma, o problema poderá ser solucionado.

Atenciosamente.

Então eu não estava tentando instalar nenhum app, apenas atualizar para ver se tinha alguma atualização.

Ele depois de ler a lista de pacotes ele diz isso:

E: The repository 'cdrom://Ubuntu-Budgie 19.10 _Eoan Ermine_ - Release amd64 (20191017) eoan Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. E: The repository 'https://packages.microsoft.com/ubuntu/19.10/prod focal Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

Camarada, esta saída do seu terminal, foi consequência de qual comando?

Ao que parece, você está versão na 20.04, mas as configurações da sua maquina ainda estão no 19.10, por isso há um conflito que não te deixa atualizar os programas.

1 curtida

foi consequência do sudo apt update, como faço para ele substituir as configurações do 19.10 para o 20.04 ?

Vamos testando algumas coisas, talvez consigamos solucionar o problema. Você está utilizando a opção CD-ROM na loja de programas? Se estiver, desative.

Programas e Atualizações -> outros programas -> desative CD-ROM -> sudo apt update

E cole aqui outra vez a saída.

Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:2 http://repo.steampowered.com/steam precise InRelease                
Obter:3 http://br.archive.ubuntu.com/ubuntu eoan-updates InRelease [97,5 kB]   
Obter:4 http://repository.spotify.com stable InRelease [3.316 B]               
Atingido:5 http://packages.microsoft.com/repos/vscode stable InRelease         
Atingido:6 http://dl.google.com/linux/chrome/deb stable Release                
Obter:7 http://br.archive.ubuntu.com/ubuntu eoan-backports InRelease [88,8 kB] 
Atingido:8 http://archive.ubuntu.com/ubuntu focal InRelease                    
Atingido:9 http://archive.canonical.com/ubuntu focal InRelease                 
Obter:10 http://security.ubuntu.com/ubuntu eoan-security InRelease [97,5 kB]   
Atingido:11 http://ppa.launchpad.net/ubuntubudgie/backports/ubuntu focal InRelease
Obter:12 http://archive.ubuntu.com/ubuntu focal-updates InRelease [107 kB]     
Ign:13 https://packages.microsoft.com/ubuntu/19.10/prod focal InRelease        
Err:14 https://packages.microsoft.com/ubuntu/19.10/prod focal Release          
  404  Not Found [IP: 40.117.131.251 443]
Obter:16 https://mega.nz/linux/MEGAsync/xUbuntu_19.10 ./ InRelease [2.468 B]   
Obter:17 http://archive.ubuntu.com/ubuntu focal-backports InRelease [98,3 kB]  
Obter:18 http://archive.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Obter:19 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [27,4 kB]
Obter:20 http://archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [19,9 kB]
Obter:21 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [27,2 kB]
Obter:22 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [4.652 B]
Obter:23 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [532 B]
Obter:24 http://archive.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [16,6 kB]
Obter:25 http://archive.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [208 B]
Lendo listas de pacotes... Pronto                                          
E: The repository 'https://packages.microsoft.com/ubuntu/19.10/prod focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.```

Por gentileza, poste a saída do comando lsb_release -a

Distributor ID:	Ubuntu
Description:	Ubuntu 20.04 LTS
Release:	20.04
Codename:	focal

Vc esta procurando arquivos da versão 20.04 em um repositório 19.10

Digita no terminal:

software-properties-gtk

Desabilita todos os repositórios abaixo:

http://br.archive.ubuntu.com/ubuntu eoan-updates InRelease
http://br.archive.ubuntu.com/ubuntu eoan-backports InRelease
http://security.ubuntu.com/ubuntu eoan-security InRelease
https://packages.microsoft.com/ubuntu/19.10/prod focal InRelease
https://packages.microsoft.com/ubuntu/19.10/prod focal Release
https://mega.nz/linux/MEGAsync/xUbuntu_19.10 ./ InRelease

PS: Estes acima são todos da versão Ubuntu 19.10 (Eoan Ermine), vc esta utilizando a 20.04 Focal

Adicione a nova versão da Microsoft:

wget https://packages.microsoft.com/config/ubuntu/20.04/packages-microsoft-prod.deb -O packages-microsoft-prod.deb

sudo dpkg -i packages-microsoft-prod.deb

Baixe pelo site o MEGASync e reinstale novamente para atualizar o ppa.

Obrigado, isso resolveu meu problema !

1 curtida

E agora eu tenho novas atualizações do sistema ou tenho que colocar novos ppas para isso ?

Você ja tem os repositórios da nova versão do Ubuntu.

Precisa adicionar somente a versão nova da Microsoft e do MegaSync, o do Chrome, Steam e Spotify são padrões.