Erros ao tentar excluir partição de windows (Pelo linux e dos)

Caros, bom dia!

Por gentileza, preciso de ajuda com a exclusão de partição windows.

Já tentei excluir pelo gparted e não funciona:


Tentei pelo cmd do windows, utilizando disco de boot nos comandos do diskpart override, e mesmo assim, nada.
No diskpart, quando eu utilizo o comando delete partition, ele da um erro que o disco está protegido. Quando utilizo o override, diz que o comando é invalido.
fdisk tbem não está funcionando. Após excluir e salvar… Ele volta.

Tentei formatar o disco de diversas formas, e também não funciona. Diz que está protegido.

Tentei também limpar por programas de recuperação via boot. Nada… :frowning:
Preciso excluir essas partições para tentar reinstalar meu sistema que deu erro de ‘registry error’ no windows.

Desde já, grato!

Olá!

Você deseja limpar tudo?
Está no Gparted como superusuário?
Cada partição está desmontada?

Se a ideia é limpar tudo ao inveś de ficar deletando partição, vá em dispositivo e mata a tabela de alocação, cria um nova GPT e aplica. Depois cria as novas partições que desejar.

Tente também com o Disks se for o caso, pois parece que está usando um Ubuntu (live) no momento.

Opa @aarProTech!
Obrigado por me responder.

Sim, quero excluir todas as partições e começar do zero.
Sim, estou abrindo o gparted com a minha senha de su.

Sobre matar a tabela de alocação, por gentileza, poderia me falar mais como posso fazer?
Neste momento, estou utilizando um ubuntu instalado em outro pc para tentar excluir essas partições. Tentei pelo live uma vez, só para teste.

Sobre o Disks, eu já tentei utilizar algumas vezes, mas também da erro:

Tentei também apagar volume pelo cmd do diskpart, mas também erros. :frowning:

Verifiquei aqui e o Gparted pra criar nova tabela de partição ele primeiro precisa que o disco não tenha partições…

Pelo “Discos” você consegue ir direto em Formatar e ao menos limpar cada partição formatando e depois excluir cada uma e criar nova tabela e iniciar tudo do zero?

Outra coisa que pensei, ao invés de apenas dar direito de super user, logar como root mesmo e tentar fazer via terminal.

Se não der, ainda, sugiro tiraro nvme e colocar ele via uma “gaveta” um disco usb externo e tentar fazer.

Você falou que está usando um Ubuntu instalado em um outro PC… então você pegou o nvme de um PC e colocou ele em outro e está tentando apagar ele?

Outra coisa, você chegou a verificar o SMART desse nvme? Ele está funcionando, digo dando boot por ele carregando sistema e tudo? Porque erro de IO ou E/S pode ter algo de errado no hardware.

@aarProTech,

Então, eu já tentei formatar de diversas formas, mas nada…
Tentei novamente pelo discos:


Infelizmente não está rolando.

Eu estou utilizando o nvme em outro pc que tem o Ubuntu instalado.
Este nvme ficava ligado no windows em outro pc, porém, ele deu erro de registry error. Ai eu tentei arrumar e não rolou. Então resolvi reinstalar o windows, porém, não consigo limpar as partições nem formatar.
Estava analisando se tem algo no linux que ajudaria limpar, porém, esta difícil. rs!

Quanto a verificação do SMART, eu não sei como faz. Pode me ajudar?
Eu fiz backup de mais de 400gb que tinha neste nvme ontem, para tentar reinstalar hoje. Então na teoria ele está “funcionando”.

Rodei o comando nvme para verificar o nvme…

Tem um aviso sobre Read-Only.

Em outras mensagens pareceu que de fato ele está travado em modo read-only.
Pode ser alguma proteção como o Bit-locker do Windows.
Pesquise sobre isso que de repente tem um caminho fácil pra limpar tudo “expurgando” o bitlocker se for o caso.

Muito obrigado pela ajuda.

Eu já havia observado a questão do readonly através do diskpart, porém, o diskpart não conseguia resolver o problema. Sempre dava erro para tentar retirar essa condição.
Então por este motivo eu vim tentar resolver no linux.

Só para atualizar o tema, consegui resolver o problema.
A solução foi aplicada com o mesmo nvme que enviei o relatório acima (ultimo print). Rodei o comando

sudo nvme format /dev/nvme0n1

para formatar o disco. Então ele limpou todas as partições. Fez o mesmo que o diskpart não conseguia fazer com o clean disk.

Mais uma vez obrigado!

2 curtidas

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.