Erro na instalação do Zorin OS: "* A execução do grub-install/dev/sda6 falhou *"

Tente instalar a distro Zorin OS e estou recebendo esse erro, tentei tanto no modo automático com a opção instalar ao lado do Windows quanto manualmente criando as partições porém em ambas estou recebendo esse erro.
A instalação vai até quase o fim e o erro acontece na parte da instalação do grub.

Especificações da maquina:
Modelo: Ideapad320 15IAP
Cpu: Intel celeron n3350 1.10ghz
Gpu: intel hd 500 graphics

Tu usou qual programa para criar o pendrive de boot?
Desativou o secure boot?

1 Curtida

Usei o balenaEtcher.
Sim desativei o secure boot.
(Também cliquei na opção que aparece no inicio do zorin, onde faz um check na imagem)

Tenta instalar o Zorin Lite por que é mais leve. Tem certeza que o pendrive que não tá ruim?

1 Curtida

Vou preparar outro pendrive e tentar!
Eu usei o mint porém apenas o cinamon estava reconhecendo a rede sem fio, será se após instalar ela funciona no mate?

Nem ideia. Só testando pra saber. Não sei qual o seu adaptador de rede o kernel usado no Mint no momento. Ai fica dificil de ajudar

1 Curtida

O Zorin deve usar algum kernel da série 4, o Mint usa o 5.4, se não me engano (não sei se alguma versão mais nova já usa o 5.10 - eles costumam usar LTS)
Eu testaria o Manjaro XFCE ou Plasma pra ver se funciona direito, ele usa o 5.10 e o Calamares, instalador diferente do Mint e Zorin, que usam Ubiquity (por ser base Ubuntu)

1 Curtida

tenta instalar novamente utilizando o ventoy.

1 Curtida

A partição está em gpt ?

Se tiver em gpt, tem que deixar 1 Mb de espaço livre para instalar em modo legacy

Lembrando que a partição efi tem que estar em fat32 e tem que ser tipo efi.

2 Curtidas

Bem lembrado - mas, em tese, o particionamento automático, que ele usou, deveria resolver isso, o que torna o erro ainda esquisito

A mensagem de erro de kernel no mesmo instante de falha do grub-install é um indicativo que a falha ocorre em um nível mais baixo do que o sistema de arquivos… Possivelmente algum bug de implementação do UEFI no notebook?? Está com a BIOS atualizada? Talvez adicionar um parâmetro de boot para desativar alguma funcionalidade que esteja causando o erro (noapi / noacpi / efi=nochunk )?? Não sei…

Desativou a hibernação do Windows?
O Windows está instalado em MBR ou UEFI?

1 Curtida

Finalmente consegui instalar!
Acompanhei um vídeo que me recomendou não conectar a internet antes da instalação e não marcar a opção de instalar programas de terceiros onde ele instala os codecs.
Mesmo com isso ainda deu o erro porém estranhamente também apareceu que a instalação foi concluída então após instalar e ainda no modo live eu usei a ferramenta boot repair(mesmo sem saber o que fazer) e ele fez alguns procedimentos, após reiniciar apereceu a opção lite lunix no boot menu, ao clicar nele consegui acessar o grub.
Obrigado pelas dicas de todos, e espero que se alguém passar por essa situação possa tirar proveito da minha experiência.

1 Curtida