Erro com o Gamemode

Olha só se não é o Fórum mais confiável e atencioso que eu conheço :smiley:
E é por esses motivos que eu vim aqui pedir ajuda e conhecimentos de pessoas mais inteligentes, experientes e sábias do que eu.

Como qualquer jovem com um computador em casa, baixei joguinhos e fui jogar no grandioso Pop!Os.
Rola tudo bem com a maioria dos jogos, nada a reclamar, exeto com um programa aparentemente muito útil do qual não tive a oportunidade de usa-lo ainda… o tal do Gamemode
“Por quê?”
Por causa disso:

“ERROR: ld.so: object ‘/usr/$LIB/libgamemodeauto.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.”

Minha falta de conhecimento a respeito do Linux me impede de decrifrar tais linhas.
Por isso venho pedir ajuda e orientação.
Muito provavelmente só essa print e a linha em que o erro é mostrado não são o suficiente pra achar a raíz do erro, por isso, não hesite em pedir mais informações caso queira ajudar :smiley:

1 curtida

Olá @Batatinha2105 tudo beleza?

No Pop!_OS o gamemode vem instalado por padrão, mas para utilizá-lo você adiciona um parâmetro no lançador do jogo. Temos alguns conteúdos sobre como usar o gamemode, dá uma conferida.

:vulcan_salute:

3 curtidas

Tenda definir a variavel de ambiente: LD_PRELOAD="$LD_PRELOAD:/usr/$LIB/libgamemodeauto.so.0"

o que é “definir a variável de ambiente”?

Obrigado pela resposta :0
Darei uma olhada e espero que me ajude :smiley:
Tenha um bom dia!

Eu vi os posts e eles realmente dizem que você precisa dizer ao lançador do jogo que quer usar o gamemode.
Mas…

Como você pode ver na janela da direita, a do Lutris, o gamemode tá ativado. [insira carinha triste]

Ah… e… acho que essa informação é útil

Eu baixei essa extensão pra saber se o gamemode tá funcionando mesmo quando eu inicio um jogo usando ele.
https://extensions.gnome.org/extension/1852/gamemode/

E eu recebo uma notificação afirmando que sim
image

Então o que esses erros no terminal significam?

systemctl --user status gamemoded

Se estiver assim quando o jogo estiver rodando é porque está funcionando

2 curtidas

Para definir uma variavel de ambiente no lutris ficaria assim:

ok…
e agora?
era pra ficar diferente?

ok. parece que tá funcionando sim. obrigado :D
mas esses erros ainda tão me deixando curioso