Erro - BusyBox v1.27.2 ubuntu initramfs - Constante

Pessoal, boa tarde!

Seguinte, a mais ou menos 2 semanas atras ao iniciar o PC (linux mint 19.1 mate 64bit) ele retornou nessa tela de boot :

“BusyBox v1.22.1 (Ubuntu 1:1.22.0-15ubuntu1) built-in shell (ash)
Antes ‘help’ for a list of built-um commands.
(initramfs):”

Já li a “solução” no fórum mesmo, executando o “fsck” na partição em questão.

Inicialmente resolveu, porém ocorreu a mesma coisa essa semana, e novamente executei o “fsck”, reiniciei e funcionou, porém no dia seguinte a máquina deu boot e voltou na mesma tela…Existe alguma solução definitiva para o caso???

Obrigado!

2 Curtidas

Olá, não trago diretamente a solução, porém informações que podem ajudar… Podem existir dados alocados em setores defeituosos, honestamente precisará que alguém mais entendido nisso te aconselhe, só poderia indicar o e2fsck ou formatação
Outra questão, mais importante, é que também passei por isto, você usa SSD? Percebi que dependendo da temperatura que estava meu SSD, sua capacidade de alocação dos dados era prejudicada. Posso estar falando abobrinha, mas com essa ideia em mente fui pesquisar sobre temperatura de trabalhos dos chips e tráfego dos dados no disco, vi que ao desligar o computador os dados poderiam não estar sendo armazenados estaticamente e eram perdidos. Um suporte com bom cooler resolveu meu caso desse erro recorrente.

2 Curtidas

Sim, uso SSD.
Caramba cara, que loucura…Bom, posso até verificar esse lance de temperatura, acompanhar e fazer testes…vamos ver, bem curioso isso…
Obrigado pela ajuda!!

1 Curtida

Faça um teste da seguinte forma, antes de desligar o computador (ou suspender) aguarde uns 20/30 segundos sem fazer nada e só depois desligue. Identifiquei o problema quando agi assim por uma ocasião qualquer e o erro não mais ocorreu. Desligando direto: Busybox rs

Olá companheiro. Estava usando a Distro Mint, e estava tendo constantemente esse mesmo problema. Pensando que talvez poderia ser algum problema com a distro, troquei para ubuntu, mas o problema continua da mesma forma. Está relacionado a como eu desligo meu computador, ainda não descobri o que é, mas as primeira vez que aconteceu foi por que travou e eu fui desligar o computador na tora, parece que isso desencadeou esse problema.

Outra coisa interessante é que: quando o sistema já iniciou e da o problema, o sistema começa a acusar que todas as pastas dentro do meu sda2 estão com permissão somente leitura, quando isso acontece, batata! Pode reiniciar e preparar para usar o fsck no BusyBox. Caso tenha conseguido uma solução deixa aqui. Uso o computador pra programar aqui no trabalho e to quase passando pra Windows pq toda vez, chegar e ligar o computador e cair no BusyBox está sendo meu inferno pessoal rsr.

Abraço e obrigado por compartilhar.

Edit1: meu disco não é SSD é um HD de notebook de 1TB

2 Curtidas

Desculpem reviver um tópico tão antigo mas estou tendo o mesmo problema direto no meu notebook, tenho algumas observações.

1 - O meu notebook fecho a tampa e ele hiberna, pratico pois ele liga mais rápido, observei que muitas vezes isso acontecia depois de algum tempo sem dar um boot, agora estou tentando me lembrar de dar o boot uma vez por dia.

2 - Não uso SSD e sim um HD de 1 TB.

Se alguem tiver uma outra observação e quiser deixar aqui para a gente ver fique a vontade;

Pode ser problema com badblock tambem.

Mesmo problema aqui Mint-19.3 xfce HD mecânico de notebook de 160GB no aguardo e ansiosa por alguém da o suporte para resolver.

Estou desconfiando que o computador nesses casos é tão rápido que desliga antes de finalizar os procedimentos de gravação em disco das últimas alterações, o que poderia causar corrompimento dos dados e ser necessário o fsck na reinicialização.

Tente executar o comando pra desligar:
shutdown -H now
ou
halt
ou
systemctl halt

Esse comando vai realizar todo o procedimento para desligar o sistema operacional mas não efetivamente desligá-lo. Ele vai ficar parado na tela de desligamento e você terá que desligar o computador no botão (segurando 2 segundos).

Caso desligando desse jeito pare de aparecer essas mensagens do initram, dá pra procurar uma solução definitiva. Caso continue aparecendo as mensagens então precisa de mais investigação como problemas físicos no HD, realizando checagem via SMART (comando smartctl)

A instalação padrão do Mint usa o Plymouth para colocar as imagens na inicialização e desligamento. Se quiser ver os detalhes do desligamento precisa desativar o plymouth adicionando como parâmetro do kernel plymouth.enable=0 durante a inicialização (é aquela maracutaia de apertar e no menu do grub para entrar manualmente parâmetros)

3 Curtidas

Resolvi com:
fsck /dev/sda* -y

Mas é bom rodar também esse comando.

2 Curtidas