Erro ao tentar instalar league of legends

Tentei instalar o lol pelo lutris porém deu esse erro, alguém sabe como resolver ou alguma outra forma de baixar?

Vinicius, você está tentando instalar usando o script disponível no site do Lutris, ou executando o EXE diretamente?
Esse erro está acontecendo pois o instalador necessita que o Directx9 esteja instalado. No script isso deveria ser feito automaticamente, mas ainda assim, dá pra fazer manualmente usando o Winetricks. Só selecionar as opções “d3dcompiler_43 d3dx9” na seção de "DLL e Componentes. Faça isso e depois reexecute o instalador, usando o mesmo prefixo. Lá naquele tutorial que eu passei no outro tópico é explicado como se faz isso.

2 curtidas

eu tentei instalar diretamente pelo site do lutris, dai deu esse erro.
eu meio que me perdi no passo 3 do tutorial “Run exe inside wine”, o arquivo de instalação seria oq exatamente?
e ao abrir o lutris aparece essa mensagem é normal?
“lutris was unable to detect vulkan support i368 architecture”

Estranho. Pelo o que diz no site o script é considerado bastante funcional. Eu mesmo testei aqui e deu certo. Você usou o script que tem uma bolinha amarela (Gold)?

Seria o arquivo que é baixado na página do LoL, na página de Download.

Você precisa instalar as bibliotecas de 32Bits do Vulkan. Você pode fazer isso com o comando:
sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386 libgl1-mesa-dri:i386
(Fonte: docs/InstallingDrivers.md at master · lutris/docs · GitHub)

eu tentei novamente instalar pelo site do lutris e deu o mesmo erro, porém dessa vez apareceu isso


e em relação as bibliotecas de 32bits de isso
E eu baixei o arquivo no site do lol e depois do " run exe inside wine prefix " e selecionar o arquivo não acontece nada :confused:

Você está usando algum PPA?
De onde que veio esse pacote wine-lol?

Para instalar o Wine use apenas:
sudo apt install wine-installer

Não é recomendado usar os PPAs no Wine, a não ser em casos muitos específicos, pq causam mtos conflitos. E o próprio Lutris fornece um “runner” (uma compilação do wine) próprio para o LoL:
https://lutris.net/runners/wine/lutris-lol-5.5-2-x86_64/games

Ou seja, no máximo vai usar uma ou outra lib do Wine do sistema, mas no fim o que realmente vai será usado é o lutris-lol, e não o wine do sistema.

Acho que não, não sei o que é ppa.
esse pacote do wine lol foi de um vídeo q vi ontem no youtube ensinando a instalar…

Abra o programa “Fontes de Aplicativos” e entre na aba “PPAs”. Aparece algum item na lista?

tem mais alguns embaixo

Pois é, esse é o motivo do problema. Remova, ou desabilite, pelo menos o do Wine. Para isso é só selecionar o item e clicar em “Remover”, ou apenas desmarque a opção para desabilitar. Depois remova todos os pacotes do wine, atualize o cache do Apt e depois tente novamente:

sudo apt purge wine*
sudo apt autoremove
sudo apt update
sudo apt install wine-installer

esses são os outros, mas nenhum deles tem wine no nome

Desabilite todos então, com exceção do Lutris. Todos os outros são feitos para o Ubuntu 16.04, e não tenho ideia de quais pacotes fornecem, mas com certeza algum fornece versões alternativas do Wine. O Mint 19.3 utiliza como base o 18.04 (bionic), e o Xenial (16.04) trazia versões bem diferentes de cada pacote. Se o pacote foi pensado para o 16.04, as dependências também serão do 16.04, o que pode conflitar com as versões do 18.04.

Além disso, usar PPAs desconhecidos traz riscos ao sistema, pois você estará instalando um pacote cujo conteúdo é desconhecido. Por exemplo, pode haver modificações mal-intencionadas nos códigos-fontes, que são bem difíceis de serem identificadas.

1 curtida

acho que deu certo, eu consegui instalar normal pelo site do lutris,agora aparece isso ao tentar iniciar ambos os jogos

Pode ser que, no meio dessas desinstalações, o Vulkan tenha sido removido sem querer.
Reinstale-o com o comando:

sudo apt install vulkan-utils libvulkan1 libvulkan1:i386 mesa-vulkan-drivers mesa-vulkan-drivers:i386 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1 libgl1:i386

1 curtida

Consegui! muito obrigado^^
em relação a isso eu aceito?

1 curtida

Blz! Que bom!

Acho que sim, até porque pelo o que diz a mensagem o jogo não irá funcionar corretamente se escolher “Não”. Isso só irá alterar a configuração, pois o Lutris já traz um Runner próprio para o LoL, provavelmente já com as modificações necessárias.

1 curtida