Epic Games no Play on Linux

fiz a instalacao da Epic games store mas na hora que ela tenta atualizar ela retorna uma “falha na instalacao de pre requisitos” e a propia epic me sugere o seguinte:

Baixei todos esses instaladores da microsoft e executei na mesma maquina da epic, mas nada aconteceu. Posso muito bem ter feito isso errado
Alguém sabe me dizer o que eu posso tentar fazer?
Qualquer ajuda eu agradeço

2 curtidas

Esse é o erro que da quando tenta-se instalar os pre requisitos:

image

A solução parece estar nesse video:

Parte relevante apos o minuto 3:35

mas como seria adicionar o -SkipBuildPatchPrereq no wine?
Obrigado

Amigo, existe o Heroic Game Laucher, que é um client não oficial da Epic Games para o Linux. Recomendo dar uma olhada:

Vida longa e próspera :lizard: :vulcan_salute:

2 curtidas

Caso mesmo assim ainda prefira o laucher oficial, roda ele pelo Lutris, aqui esta funcionando certinho pelo lutris

então @M.Mazur, eu rodava perfeitamente no lutris mas acho que ou alguma atualização quebrou ele ou eu mexi em algo que não devia
Será que você poderia mandar um print das suas configurações no lutris?

Postei no imgur (Aqui )

O resto ta em defalt

instala pelo lutris, que lá pelo lutris ele já instala tudo o que é necessário para rodar a loja, eu mesmo aqui no meu pop os instalei a epic games pelo lutris e rodou de boa, o unico ruim que o game que eu queria rodar não consegui (acho que por causa do anti-cheat) que foi o fortnite mais acho que outros titulos devem rodar de boa…

@JG22 , nao funcionou, eu baixei a heroic e baixei o Rocket League, abri o jogo e deu de jogar tranquilamente. mas quando eu fecho eu não consigo abrir novamente o jogo.
Eu estou precisando reinstalar o jogo para jogar ele novamente

Pelo lutris não instala, por algum motivo, fica o tempo todo na tela de carregamento

@MATEUS_WITECK estranho, aqui comigo no meu computador eu instalei pelo lutris e vai de boa, pois o lutris instala todos os recursos necessários incluindo esses do visual c++ entre outros e logo em seguida a loja da epic games.

Olha ai a epic games funcionando no POP OS via lutris

@MATEUS_WITECK recomendo vc reinstalar o lutris seguindo passo a passo no site do lutris.net, e em tbm instalar o wine mais recente seguindo o passo a passo na pagina de download no site do WINE HQ, que é possivel que vc consiga instalar e fazer ficar funcional a loja da epic games através do lutris.Se tiver alguma duvida acesse esse link abaixo do blog diolinux, onde ele demonstra de forma simples e facil como instalar a Epic Games Store:

Rodei no terminal a loja da heroic e ela retorna isso quando tento rodar o rocket:

launching Sugar
GameMode not installed
Launch Command: /opt/heroic/resources/app.asar.unpacked/build/bin/legendary launch Sugar --wine /usr/bin/wine --wine-prefix ‘/home/mateusw/.wine’
launching Sugar

Já reinstalei o lutris e o wine mas mesmo assim não instala a epic games store. Como disse, ela rodava perfeitamente até que parou de abrir, dai eu desinstalei e o lutris não instala mais

Baixa o GameMode então. Aparenta ser uma dependência do laucher

Instalando o gamemode parou de dar esse erro no terminal, mas o jogo continua sem abrir