Emulador de Super Nintendo

Boa noite pessoal!

Eu costumava usar um emulador de Super Nintendo, o Zsnes, no Ubuntu. Porém, depois que eu formatei e instalei o Debian, não consigo mais instalar. Alguém sabe como instalar ou pode recomendar algum outro?

Obrigado!

1 Curtida

Estranho, n lembro de n ter conseguido instalar o pacote zsnes no Debian. Tente estas alternativas:

  • Mednafen - uso ele, apesar de n ter uma interface tão legal quanto o zsnes, ele é um multi emulador muito bom (ao todo emula 17 consoles diferentes).

  • Higan - aparentemente ele tbm emula SNES.

  • Snes9X - emula apenas SNES.

Para instalar algum destes q citei, o nome do pacote é simplesmente o próprio nome do emulador. Há tbm o RetroArch que é um multi emulador com interface que lembra o sistema do PS3. Eu só n recomendo usá-lo pq pessoalmente n tive boas experiências de uso.

2 Curtidas

O Snes9x nao consegui instalar via terminal. Já o Mednafen eu consgui, vou testar aqui, obrigado!

1 Curtida

O Higan tenta ser um emulador o mais preciso possível, por isso é bem mais pesado. Se você não liga pra isso, recomendo usar o snes9x.

1 Curtida
1 Curtida

@raw, não sei como é no Debian, mas lhe contarei como é minha experiência no *ubuntu (como um é baseado no outro, talvez seja bem similar).

O ZSNES é um programa que não tem port para 64bit, portanto você precisa habilitar o suporte para 32bit nos seus repositórios através do comando sudo dpkg --add-architecture i386
Então quando eu pesquisava por “zsnes” no Synaptic, eu só encontrava o pacote zsnes-dbg:i386. Ao marcá-lo para instalá-lo, o gerenciador de pacotes automaticamente marcará o pacote zsnes:i386

O pessoal critica muito por ser antigo, mas cara, o ZSNES roda tudo que é jogo (na verdade tive mais problemas com emuladores novos) e é super leve. O único problema que vi é que dizem que o ZSNES tem um problema de segurança, mas creio que seja difícil de acontecer algo com você, especialmente se você não é o tipo de pessoa que fica rodando toda sorte de ROM hackeada. Passei anos e anos usando o ZSNES 1.51 e nunca tive problemas, o problema de segurança é grave, mas me parece que é algo que dificilmente aconteceria com alguém.

Bom, fora o ZSNES, eu prefiro usar o snes9x com interface gráfica. O povo recomenda muito o Retroarch, mas este programa tem uma interface medonha, nada amigável.

1 Curtida

Discordo, o problema n é a interface e sim a falta de praticidade do programa. Antigamente, inclusive, era + fácil usá-lo do que hoje em dia (eu lembro de um script que já baixava o RetroArch com todos os cores).

Já tentou instalar pelo Flatpak:
https://flathub.org/apps/details/com.snes9x.Snes9x

Sugestões o pessoal já deu. Agora, qual o problema está encontrando? Ele tem nos repositórios, normalmente um “sudo apt install zsnes” e tudo está resolvido.

Eu já tentei e isto aparece.

@raw, você já ativou o suporte a 32bit como te falei? O comando é este:
sudo dpkg --add-architecture i386

Acho que você precisará atualizar os repositórios, portanto rode o comando abaixo:
sudo apt update

Para instalar use o comando abaixo:
sudo apt install zsnes:i386

A propósito, instale o gerenciador de pacotes Synaptic, é melhor para encontrar programas.


Você não conseguiu porque esse programa não está nos repositórios oficiais do *ubuntu. Mas dá para instalá-lo via PPA, dê uma olhada no artigo abaixo:

Eu tou rodando o Higan no Debian Bullseye (testing). Funciona bem, fora que eu não consegui mapear o teclado direito nos direcionais para o master system, de resto funciona bem, apesar de alguns tearings nos sprites em algumas roms. Mas ele é um baita emulador, estou bem satisfeito.

2 Curtidas

usa o retroarch, tem um monte de emulador lá
recomendo o core snes9x-recent, uma curiosidade: um tablet com cpu arm dual core que configurei para 600mhz cada (0.6ghz) eu testei o retroarch com snes9x-2002 e rodou muito bem, outros cores ficarem lentos. (testei gba também, o mgba rodou muito bem nos 600mhz dual-core; os demais ficaram lentos)

2 Curtidas

Muito obrigado! agora consegui instalar e abrir o emulador!!

Resolvido!

1 Curtida