Desativar função de boot, ao abrir a Tampa do Notebook Samsung E30

Tenho um notebook Samsung E30, que em sua configuração padrão com Windows 10, ele dá boot ao levantar a tampa.
Isso pode ser desativado instalando o aplicativo Samsung Settings, somente no Windows.
Como não está mais na garantia, instalei o POP OS, e tudo funciona perfeitamente. Porém, a função de boot ao levantar a tampa continua ativa.
Na BIOS, não tem opção para tal finalidade. Segundo o Suporte da Samsung, somente desativa com o Samsung Settings.
Tentei sem sucesso, editar o arquivo /proc/acpi/wakeup, pesquisando sobre a opção LID ou LID0. Mas não existe essa opção.
Alguém tem algum parâmetro, onde eu possa desativar essa função?

Tenta pesquisar em inglês, mais provável q vc encontre uma solução.

Eu sempre pesquiso em inglês (apesar de não dominar). Mas ainda não encontrei uma solução.
Continuo pesquisando.

:wave:t2: @sergios seja bem-vindo ao Diolinux Plus.

No Pop!_OS instala o acpitool atravéz do comando:
sudo apt-get install acpitool

Depois no terminal roda o comando: acpitool -w irá aparecer uma lista e nela terá LID se tiver Enable roda o comando acpi-tool -W LID depois roda o acpitool -w para ver se mudou para Disable. Feito tudo isso reinicia o computador e faça o teste.

:pray:t2:

Com o comando “sudo acpitool -w”, aparecem várias opções, menos a LID.

Abaixo, a resposta do comando “acpitool -W LID”,
$ sudo acpitool -W LID
Function Toggle_Wakeup_Device : invalid device number 0.
Run ‘acpitool -w’ to get valid device numbers .

Pesquisando, encontrei outro caminho do LID, o qual descreve o seu estado. Porém, as permissões do arquivo, não permitem que ele seja alterado, nem como root.
$ cat /proc/acpi/button/lid/LID0/state
state: open

Continuando com as pesquisas, fiz a instalação do evtest. Este por sua vez, permite a alteração, passando seu parâmetro de “localização”. Mas a alteração da LID, faz com que o SO para no grub.
Ou seja, continua dando boot ao levantar a tampa.

$ sudo evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0: Lid Switch
/dev/input/event1: Power Button
/dev/input/event2: Power Button
/dev/input/event3: AT Translated Set 2 keyboard
/dev/input/event4: Video Bus
/dev/input/event5: ATML3000:00 03EB:2168 Mouse
/dev/input/event6: ATML3000:00 03EB:2168 Touchpad
/dev/input/event7: HDA Intel PCH Mic
/dev/input/event8: HDA Intel PCH Headphone
/dev/input/event9: HDA Intel PCH HDMI/DP,pcm=3
/dev/input/event10: HDA Intel PCH HDMI/DP,pcm=7
/dev/input/event11: HDA Intel PCH HDMI/DP,pcm=8
/dev/input/event12: HDA Intel PCH HDMI/DP,pcm=9
/dev/input/event13: HDA Intel PCH HDMI/DP,pcm=10
/dev/input/event14: Web Camera: Web Camera
/dev/input/event15: Bluetooth Mouse M336/M337/M535 Mouse
/dev/input/event16: Bluetooth Mouse M336/M337/M535 Consumer Control
/dev/input/event17: Bluetooth Mouse M336/M337/M535 Keyboard
Select the device event number [0-17]: 0

Continuo na minha luta.

1 Curtida

Entendi…

Quando puder faz um teste, executa o comando:
dmesg | grep Lid

E mostra aqui para nós qual é a saída.

Se não me engano isso é feito na bios, vc desativa lá.

Ao levantar a tampa ele liga o computador, está certo?

Se for isso, depois eu confirmo a opção, mas acho que é o fast boot na bios…

Se for isso, ok.

Se não for esta opção, tire fotos das opções da bios para ver qual pode ser.

@RuKsu , segue a resposta do comando sugerido.
$ sudo dmesg | grep Lid
[ 0.616337] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[ 0.616354] ACPI: Lid Switch [LID0]

1 Curtida

Então @swatquest , também achava que estaria na BIOS esse parâmetro.
Mas certamente a SAMSUNG modificou a BIOS desses notebooks, Pois tem poucas opções de configuração, bem diferente das bios tradicionais.

Suponho que o Samsung Settings, passe parâmetros para a Bios. Mas eles não estão disponíveis (visíveis) na Bios,

É a opção Fast Bios Mode
Desativa ela que deve resolver isso.

Qualquer coisa envie as fotos da Bios para ver se o nome é outro.
Até.

Essa opção já está desativada.
A Bios é a mesma da sua imagem.

ok…
Acho que tem que desativar o secute boot control também…

caso não funcione
tente procurar o pacote samsung-tools
https://launchpad.net/samsung-tools

veja se ele te fornece a configuração do autotart do boot

no popos não sei qual é o nome

:smiley:Alright.

Temos um parametro, vamos verificar se ele esta Enable digitando este comando no terminal:
cat /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/power/wakeup

Bem provavel que vai estar Enable então passaremos o Disabled para ele com este comando:
echo disabled | sudo tee /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/power/wakeup

Mas tem um detalhe, ele vai “se perder” ao reiniciar o computador então para manter isso direto vamos criar uns arquivos:

1st No bloco de notas nomeie como “DeactivateWakeupOnLidOpen.service”, cola o comando abaixo e salva:

[Unit]
Description=DeactivateWakeupOnLidOpen

[Service]
Type=oneshot
ExecStart= /lib/systemd/system-sleep/DeactivateWakeupOnLidOpen.sh

[Install]
WantedBy=multi-user.target

Depois você vai precisar ter permissões para copiar este arquivo, então abra o gerenciador de arquivos pelo terminal usando “sudo” exemplo “sudo Nautilus” se você usa o Nautilus. Então copia este arquivo e vá até a pasta /etc/systemd/system/ e cola o arquivo lá

2nd No bloco de notas crie um arquivo e nomeie como “DeactivateWakeupOnLidOpen.sh” cola o comando abaixo e salva:

#!/bin/sh
echo disabled | sudo tee /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/power/wakeup

No mesmo esquema você abre o gerenciador de arquivos pelo terminal usando “sudo” copia este arquivo e vai até a pasta /lib/systemd/system-sleep e cola o arquivo lá.

3rd Finalizando temos de dar as permissões para a funcão executar automaticamente quando ligar ou reiniciar o computador, no terminal digita:
para conceder as permissões:
sudo chmod +x /lib/systemd/system-sleep/DeactivateWakeupOnLidOpen.sh
e por fim ativar o serviço:
sudo systemctl enable DeactivateWakeupOnLidOpen.service

Então reiniciar o computador e fazer os testes :crossed_fingers:t2:.
:pray:t2:

@swatquest , procurei alguma relação nesse pacote, mas não encontrei.

@RuKsu , cara, que mão de obra você teve pra elaborar isso.
Infelizmente não surtiu efeito, continua dando boot ao abrir a tampa.

1 Curtida

@sergios

veja se resolve
https://wiki.archlinux.org/index.php/laptop#Modify_wake_events

Modify wake events

Events which cause the system to resume from power states can be regulated in /proc/acpi/wakeup. Writing an entry from the Device column toggles the status from enabled to disabled, or vice-versa.

For example, to disable waking from suspend (S3) on opening the lid, run:

# echo LID > /proc/acpi/wakeup

Reason: “Permanent toggling” is not the desired behaviour considering that systemd-tmpfiles can be run repeatedly. (Discuss in Talk:Laptop#)

This change can be made permanent with tmpfiles.d(5):

/etc/tmpfiles.d/disable-lid-wakeup.conf

w /proc/acpi/wakeup - - - - LID