Desabilitar aceleração do mouse no XFCE 4.16

Olá, recentemente comecei a utilizar linux e percebi que na distro manjaro (xfce), não consigo desativar a aceleração do mouse, sendo que no Windows, você desabilitava uma opção “Aprimorar precisão do ponteiro”, mas no linux, eles pedem pra você fazer uns comandos malucos e criar arquivos .conf, não teria uma maneira mais fácil? E eu já tentei ir nas configurações de mouse e touchpad, mas, a opção de “aceleração” que deveria estar acima da sensibilidade, não aparece, e agora?

Qual é a versão do manjaro que ja vem com Xfce 4.16 ? :thinking:

O manjaro 20.2

já veio com Xfce ou voçê instalou depois ?

Não precisei instalar nada, já veio junto com o sistema! (Acho eu, talvez eu tenha feito alguma atualização e nem vi que tinha algo sobre xfce)

Você sabe como desativar a aceleração do mouse no xfce? Eu preciso desativar, pois jogo vídeo-jogos de tiro, e a aceleração faz com que eu perca percisão, isso é muito chato, coisa que no windows basta apenas desmarcar uma caixinha de seleção.

A aceleração do mouse mudou drasticamente nas versões recentes do servidor X; usar xset para desativar a aceleração não funciona como antes e não é mais recomendado. As mudanças recentes em PointerAcceleration podem ser lidas aqui .

Desativar a aceleração do mouse significa que uma função linear será usada para mapear os movimentos do mouse físico para virtual. A configuração de velocidade do mouse controla a inclinação desta função linear.

Para desativar completamente qualquer tipo de aceleração / desaceleração, crie o seguinte arquivo:

/etc/X11/xorg.conf.d/50-mouse-acceleration.conf

Section "InputClass"
	Identifier "My Mouse"
	MatchIsPointer "yes"
	Option "AccelerationProfile" "-1"
	Option "AccelerationScheme" "none"
	Option "AccelSpeed" "-1"
EndSection

e reinicie o X.

com libinput

Alternativamente, desde libinput -1.1.0-1 e xf86-input-libinput -0.15.0-1 você pode usar um perfil de aceleração simples. Para habilitá-lo, crie o seguinte arquivo:

/etc/X11/xorg.conf.d/50-mouse-acceleration.conf

Section "InputClass"
	Identifier "My Mouse"
	Driver "libinput"
	MatchIsPointer "yes"
	Option "AccelProfile" "flat"
	Option "AccelSpeed" "0"
EndSection

e reinicie o X. Observe que, sob certas condições (por exemplo, se você tiver um Pointer Speed valor diferente para o seu mouse no Plasma 5.13), seu ambiente de área de trabalho pode tentar substituir alguns desses valores, mesmo se você tiver este arquivo de configuração do X.

Outra opção é este comando:

$ xinput --set-prop ‘libinput Accel Profile Enabled’ 0, 1

Que não precisa de um reinício do X, mas não é persistente. Embora possa ser configurado para ser executado automaticamente com o Autostarting .

Para confirmar que a aceleração foi desativada, digite o seguinte:

$ xinput list-props {1…50} 2>/dev/null | fgrep ‘libinput Accel Profile Enabled (’

O perfil deve ser lido 0, 1 .


Fonte:

https://wiki.archlinux.org/index.php/Mouse_acceleration#Disabling_mouse_acceleration

Gerenciador de configurações / Mouse e touchpad / na aba Dispositivos em Botões e retornos procure por Velicidade do ponteiro , por padrão vem em 5,0 ai voçê desliza para esquerda ou direita para controlar , ou veja se no centro do mouse tem um botão proximo ao scroll , pois no meu tem 3 velocidades diferentes , se o seu tambem tiver esse botão vai ver que cada vez que clicar nele vai haver uma diferença de sensibilidade do ponteiro.

OBS: Essa configuração se refere ao XFCE .


veja na imagem um botão proximo ao scroll , ele controla a sensibilidade , são entre duas ou três velocidades diferentes . dependendo ma marca ou do modelo , no meu caso eu uso um kit da =>Fortrek-WCF102 Wireless.<=

Obrigado pela resposta! Vou testar no meu sistema!

Obrigado pela resposta! Vou testar no meu sistema!!

Como eu reinicio o “x”?

Um Logoff login já resolve.

Essa configuração do 550-mouse-acceleration.conf é permantente? ou eu tenho que configurar toda vez que reiniciar o sistema?
Como eu sei que estou usando servidor x ou libinput?

Valeu, funcionou aqui com o libinput.

1 Curtida