Debian GRUB Rescue - Problema de boot

Pessoal tenho uma grande duvida na minha vida!
Comprei um SSD XPG Gammix S41 258 GB
Parcionei o SSD em 2 partes

128GB pra Windows
128GB pra Debian

Porém ai que veio o grande problema, eu tinha um linux intalado em dual boot com o windows, ai ele funcionava normal o GRUB e talls, ai eu pensei:
-Vou tirar o linux do HD e instalar um novo no SSD
Seria facil, se não fosse dificil… Pois a instalação reconhecia normalmente o SSD e consegui fazer tudo certinho! Só que tive um grande problema que era na instalação do GRUB
Por mais que eu fizesse uma partição chamada /BOOT ele não reconhecia e por mais que falasse que instalou o GRUB ele não bootava o linux de jeito nenhum, e quando eu forçava ele bootar em UEFI ele jogava pra uma tela:
grub recue>_
Ai comecei a suspeitar que essa tela do GRUB não era do meu SSD que eu tinha instalado neste instante, comecei e notar que nao importa se eu excluisse totalmente a partição do linux, ainda continuava com essa tela de
grub recue>_
Ou seja, provavelmente ele foi instalado no Windows(Não tenho certeza)
Ai a unica solução que eu tive foi EXCLUIR a partição do windows por completo junto com a do linux! E pra minha surpresa no final funcionou TUDO ! Foi direto pro grub e deu dual bot!
Fiz toda configuração só que eu cometi o vacilo de excluir a partição errada pelo WINDOWS e exclui a do linux…

Ai depois que tanto o windows como o Linux ja estavam tudo PRONTO! Advinha?
Perdi meu linux denovo! E agora estou a exatamente com O MESMO PROBLEMA e me perguntando “COMO RESOLVER SEM TER QUE APAGAR O WINDOWS”
OBS:

Não adianta eu usar:
set boot=(hd1,gtp3) //Que no caso é a partição do /boot
set prefix=(hd1,gpt3)/grub
set root=(hd1,gtp3)
insmod normal

(Vai aparecer que Normal não foi encontrado)
Ou seja… Não funciona, não teria uma forma de resolver isso? Tipo se eu soubesse pelo menos onde fica esse GRUB que eu suspeito que ta instalado no WINDOWS
Juro pra vocês eu ja instalei esse LINUX umas 31x seguidas, juro por tudo ! E não importa a forma que seja, particionamento ASSISTIDO, particionamento manual, particionamento assitido com /home separado, manual com/home separado! tudo! O DEBIAN INSTALA! mais o GRUB NUNCA instala

Eu já tive esse problema e para min isso funcionou veja se da certo para você :wink:

1 curtida

Recomendo a aula completa do prof Kretcheu pra entender o processo de boot, tipos de boot e como o grub funciona na inicialização dependendo do tipo de boot e formato da tabela de particionamento do disco. Depois da aula vc já vai conseguir diagnosticar o que está acontecendo no seu computador.

Fiz tudo certinho, porém chegou na parte do grub-install, ele não vem no live boot, tentei instalar mais não obtive sucesso

era qual sistema ?

Kali Linux

tente no ubuntu