Debian 11 (64bits) & Steam

Prezados, boa noite!

Poderiam me ajudar numa situação?
Estou há mais de 5 dias tentando solucionar isto e não consigo.
Ocorre que, não consigo instalar a Steam no Debian 11 (64bits), ele fala que tem um monte de dependências, mas não vai instalar. então, estou desde a semana passada instalando um monte de coisa e tentando vários tutoriais, mas nada ajuda, o problema persiste. Eis o problem:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libatomic1:i386 : Dépend: libc6:i386 (>= 2.3.6-6~) mais il n'est pas installable
 libbsd0:i386 : Dépend: libc6:i386 (>= 2.25) mais il n'est pas installable
 libdrm-amdgpu1:i386 : Dépend: libc6:i386 (>= 2.28) mais il n'est pas installable
 libdrm-intel1:i386 : Dépend: libc6:i386 (>= 2.17) mais il n'est pas installable
 libdrm-nouveau2:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libdrm-radeon1:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libdrm2:i386 : Dépend: libc6:i386 (>= 2.17) mais il n'est pas installable
 libedit2:i386 : Dépend: libc6:i386 (>= 2.28) mais il n'est pas installable
 libelf1:i386 : Dépend: libc6:i386 (>= 2.28) mais il n'est pas installable
 libexpat1:i386 : Dépend: libc6:i386 (>= 2.25) mais il n'est pas installable
 libffi7:i386 : Dépend: libc6:i386 (>= 2.7) mais il n'est pas installable
 libgcc-s1:i386 : Dépend: libc6:i386 (>= 2.2.4) mais il n'est pas installable
 libgl1:i386 : Dépend: libc6:i386 (>= 2.1.3) mais il n'est pas installable
               Dépend: libglx0:i386 (= 1.3.2-1) mais il n'est pas installable
 libgl1-mesa-dri:i386 : Dépend: libc6:i386 (>= 2.29) mais il n'est pas installable
 libglapi-mesa:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libglvnd0:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libgpg-error0:i386 : Dépend: libc6:i386 (>= 2.28) mais il n'est pas installable
 libllvm11:i386 : Dépend: libc6:i386 (>= 2.29) mais il n'est pas installable
 libmd0:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libpciaccess0:i386 : Dépend: libc6:i386 (>= 2.7) mais il n'est pas installable
 libsensors5:i386 : Dépend: libc6:i386 (>= 2.29) mais il n'est pas installable
 libstdc++6:i386 : Dépend: libc6:i386 (>= 2.23) mais il n'est pas installable
 libtinfo6:i386 : Dépend: libc6:i386 (>= 2.16) mais il n'est pas installable
 libudev1:i386 : Dépend: libc6:i386 (>= 2.30) mais il n'est pas installable
 libvulkan1:i386 : Dépend: libc6:i386 (>= 2.29) mais il n'est pas installable
                   Recommande: mesa-vulkan-drivers:i386 mais il n'est pas installable ou
                               vulkan-icd:i386
 libx11-6:i386 : Dépend: libc6:i386 (>= 2.28) mais il n'est pas installable
 libxau6:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libxcb-dri3-0:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libxcb1:i386 : Dépend: libc6:i386 (>= 2.28) mais il n'est pas installable
 libxdmcp6:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libxext6:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libxinerama1:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 libz3-4:i386 : Dépend: libc6:i386 (>= 2.30) mais il n'est pas installable
 libzstd1:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
 steam:i386 : Dépend: libc6:i386 (>= 2.15) mais il n'est pas installable
              Recommande: libasound2-plugins:i386 mais il n'est pas installable
              Recommande: libxss1:i386 mais il n'est pas installable
              Recommande: mesa-vulkan-drivers:i386 mais il n'est pas installable
 zlib1g:i386 : Dépend: libc6:i386 (>= 2.4) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

PS:. Não encontro a maioria dos pacotes para instalar.
PS2:. Sinto que o Debian não gosta de mim.
PS3:. Estou tendo diversos problemas por conta do suporte multiarch que, aparentemente não funciona aqui.
OBS:. Já reinstalei o Debian mais de uma vez para tentar soluções diferentes de forma separada ou conjunta, o problema está justamente no fato de ser requerido dependências que se quer consigo encontrar.

Você está instalando via APT ou baixando o .Deb do site da Steam?
Tente habilitar a arquitetura x86: sudo dpkg --add-architecture i386
@eddiecsilva você que está no Debian hoje…

2 curtidas

Sem habilitar o suporte à 32bits no Steam “do repositório” não instala.

Estou no Debian SID e estou com o Steam instalado via repositório. Mas, caso você não queria habilitar as bibliotecas de 32bits no seu sistema, basta instalar o Steam via Flathub.

:vulcan_salute:

3 curtidas

Aparentemente, você está instalando um .deb que requer pacotes do unstable, estando na versão stable.
Se você conseguir que isso funcione, corre risco de quebrar seu sistema posteriormente.
A melhor solução é, como o colega falou, usar o flatpak.

2 curtidas

Já fiz isso logo no começo, essa mensagem que colei do terminal foi justamente após fazer esse comando.

O flatpak dá o mesmo erro e não instala. Já tentei.

Fiz das duas formas, mesmo erro.

Se vc quebro o sistema vc tem que reparar antes de instalar o Flatpak.
O Flatpak esta no repositório então é seguro.
Apos instalar o flatpak reinicia o sistema, o tutorial a seguir é esse aqui: Flatpak—the future of application distribution
Você devia ter usado Flatpak desde o inicio, sempre que tiver um distribuição de software em flatpak e Snap e AppImage prefira eles do que usar um pacote distribuído fora do Debian.
O pacote do site da Steam é montado para o Ubuntu apesar de poder usar em outros sistema ele é para o Ubuntu.
Você pode confirmar isso no suporte Steam.

1 curtida

Felizmente não quebrei o sistema e sim, já tentei usar eles desde o começo, mas não funcionou.

Instalei a versão de 32bits do Debian.
Problema resolvido, obrigado pela atenção gente <3
Mas infelizmente não vislumbro solução no 64bits e optei por ficar no 32bits mesmo.

Você tentou ativar a arquitetura x86?

Não faz sentido instalar um sistema 32 bits only em 2021…

2 curtidas

Acredito que a solução era essa:

sudo dpkg --add-architecture i386
sudo apt update
sudo apt install steam

2 curtidas

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.