CS:GO não abre (Manjaro KDE)

Salve, galera! Acho que já vimos um título parecido algumas vezes aqui no fórum e fora dele, mas eu realmente tentei várias coisas e até agora nada deu certo. É como está aí: o CS:GO não abre no meu Manjaro KDE. Eu clico pra carregar o jogo na Steam, a tela fica preta como se fosse carregar e então fecha. Não dá nenhum erro, não diz nada, simplesmente fecha.

Saída do inxi -F:

Resumo

Host: almi-manjaro Kernel: 5.4.101-1-MANJARO x86_64 bits: 64
Desktop: KDE Plasma 5.21.2 Distro: Manjaro Linux
Machine:
Type: Laptop System: Acer product: Aspire A515-51G v: V1.18
serial:
Mobo: KBL model: Charmander_KL v: V1.18 serial:
UEFI: Insyde v: 1.18 date: 03/29/2018
Battery:
ID-1: BAT1 charge: 38.6 Wh (100.0%) condition: 38.6/48.9 Wh (78.9%)
CPU:
Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP cache:
L2: 3 MiB
Speed: 797 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 797 2: 754
3: 781 4: 792
Graphics:
Device-1: Intel HD Graphics 620 driver: i915 v: kernel
Device-2: NVIDIA GM108M [GeForce 940MX] driver: nvidia v: 460.56
Device-3: Quanta HD Webcam type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting,nvidia
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2)
v: 4.6 Mesa 20.3.4
Audio:
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.4.101-1-MANJARO running: yes
Sound Server-2: PulseAudio v: 14.2 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp2s0f1 state: down mac: fc:45:96:f8:dd:47
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
driver: ath10k_pci
IF: wlp3s0 state: up mac: 5c:c9:d3:a0:82:73
Bluetooth:
Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB
driver: btusb
Report: This feature requires one of these tools: hciconfig/bt-adapter
Drives:
Local Storage: total: 238.47 GiB used: 80.87 GiB (33.9%)
ID-1: /dev/nvme0n1 model: NE-256 size: 238.47 GiB
Partition:
ID-1: / size: 58.81 GiB used: 18.36 GiB (31.2%) fs: ext4
dev: /dev/nvme0n1p3
ID-2: /boot/efi size: 511 MiB used: 312 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 170.24 GiB used: 62.45 GiB (36.7%) fs: ext4
dev: /dev/nvme0n1p4
Swap:
ID-1: swap-1 type: partition size: 4 GiB used: 64.2 MiB (1.6%)
dev: /dev/nvme0n1p2
Sensors:
System Temperatures: cpu: 55.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 184 Uptime: 28m Memory: 7.66 GiB used: 2.79 GiB (36.4%)
Shell: Bash inxi: 3.3.02

O que eu já fiz:

  • Conferi o driver (aparentemente eu tenho que usar o video-hybrid-intel-nvidia-prime; a outra opção é o bumblebee-prime que tem várias reclamções a respeito na internet).
  • Já tentei abrir utilizando -nojoy nas opções de inicialização do CS:GO, sem sucesso.
  • Já tenho o gamemode instalado, tentei abrir o jogo com ele rodando e sem ele rodando, sem sucesso.
  • Já voltei para a versão 5.4 do kernel ao invés da 5.9 oferecida pelo Manjaro, não abre nem em uma versão nem na outra.
  • Já tentei ver se o problema era o tema global (sei lá, eu tentei de tudo kkkkk), sem sucesso.

O que eu andei pensando depois de ficar quebrando a cabeça com isso:

  • Será problema do Manjaro?
  • Será problema do KDE (por estar na versão mais recente, 5.21)?
  • Será problema do driver de vídeo?
  • Será que preciso fazer alguma configuração especial no CS:GO, usar o Proton, sei lá?

Enfim, quem puder me ajudar, eu agradeço muito, principalmente quem joga no Manjaro ou ainda no Manjaro KDE.

2 Curtidas

Opa, então… Recomendo não usar paramentros de inicialização com o CS, até mesmo o GameMode pode dar uns problemas. Recomendo você manter-se no Kernel 5.4 só por via das dúvidas e, quando for jogar alguma coisa, abrir o terminal e selecionar a GPU dedicada “na marra”: sudo prime-select nvidia.
Já tentou verificar os arquivos locais do game?

Olha o que deu:

[almijr@almi-manjaro ~]$ sudo prime-select nvidia
[sudo] senha para almijr:
sudo: prime-select: comando não encontrado

Já, tudo certinho.

É, então você não instalou o driver da Nvidia, ué! Bumblebee, até onde li nos fóruns gringos e documentação do openSUSE, já caiu em desuso. O usado agora é o prime

https://youtu.be/01KCtHcB2D0 da uma averiguada no vídeo, pois ele ensina a instalar os drivers da Nvidia

Então, essas são as opções de driver oferecidas pelo Manjaro Settings Manager (o que é recomendado pelo vídeo que você mandou):

Aí quando tento instalar tanto o video-nvidia ou o video-nvidia-390xx dá o seguinte erro:

Quando pesquiso por nvidia no Pamac ele me retona vários pacotes, então eu não quis nem mexer pra não causar algum problema. Alguns, aparentemente, foram instalados automaticamente quando instalei o driver pelo Manjaro Settings Manager (afinal eu não instalei nada manualmente no Pamac). Por lá aparecem os pacotes (já instalados) linux54-nvidia e linux59-nvidia, além do mhwd-nvidia. Tem algum comando que dá pra rodar no terminal que lista tudo relacionado à Nvidia instalado? Não sei se isso pode ajudar.

Use o proton e veja se funciona.

1 Curtida

:wave:t2:

Adiciona o comando DRI_PRIME=1 %command% em “Setup Launch Options”. Este comando vai indicar o CS:GO para usar a vRAM da placa dedicada.

Obs.: Depois de ter adicionado este comando, aguarda cerca de 2 minutos para o jogo iniciar. Pode ser que ele não demore, vai depender do OS e hardware, mas é um bug que está em aberto ainda no Github da Valve. Problema de jogar os Pre shaders on cache.

:pray:t2:

1 Curtida

Verifica as integridades do cs, provavelmente ta faltando alguma coisa.
Em propri…, local files, verify integrity of game files…

1 Curtida

Proton não funciona. A Steam não deixa jogar e tem risco até de VAC. Gringos do reddit tavam falando isso num tópico antigo do r/linux_gaming…

1 Curtida

Então, eu fiz isso duas vezes e não obtive sucesso. O processo correu normal até o fim, mas o jogo não abriu.

É isso, eu até tentei (como só vi seu comentário depois, testei a dica do amigo), testei várias vezes e não funciona. Obtive até um erro “fatal error” por não conseguir instalar alguma coisa lá.

O teu driver não foi daqueles que foi descontinuado pela Manjaro?

Acabei partindo para uma alternativa que sendo sincero era até mais fácil, mas não sei porque não pensei antes. Eu removi o pacote da Steam que estava instalada (que no pamac tem o nome de Steam Native) e uma que vem acompanhada (Steam Runtime) que são empacotados pelo Manjaro. Aí eu instalei a versão Flatpak, instalei o CS:GO e… voilá! Abriu normal. Tudo certo. Única coisa é o FPS que tá lá embaixo (chega a 80fps no menu, o que na minha experiência indica que ficará em torno de 50~40fps em jogo).

Segui a sua dica (já versão flatpak da Steam) e não obtive aumento de fps, pode ser que eu precise fazer algo no Nvidia Server, sabe algo sobre isso? Também vou testar com o gamemode ativo pra ver se consigo melhorar o desempenho.

1 Curtida

Eu vi algo sobre isso no fórum do Manjaro, mas eu ACHO que a minha placa ainda recebe suporte (eu ainda não consegui confirmar isso com 100% certeza).

1 Curtida

Dá uma olhada:

1 Curtida

Cara, possa ser que seja alguma peculiaridade da Steam em flatpak, mas posso estar enganado. Dá uma olhada no último comentário (feito pelo mansurafa): Como forçar a steam a usar a gpu? - #4 by M.Mazur

1 Curtida

Valeu, @JG22 , infelizmente isso não daria pra mim por estar no Manjaro e aqui foi o contrário, foi o Flatpak que rodou kkkkkkkk

Inclusive, para deixar registrado, consegui algum ganho de FPS, mas ainda acho que pode ir mais (já joguei, acho que no Pop com 100~120fps), agora está chegando a 100fps, máximo. Eu coloquei nas opções de inicialização do CS:GO gamemoderun %command% -novid -high e um comando que rodo dentro do console, já no jogo, fps_max 0 que fez muita diferença aqui. Infelizmente em jogo, ele chega a 50fps, variando pra cima. Marquei Prefer Maximum Perfomance no Nvidia X Server também. Ainda preciso fazer mais alguma coisa pra melhorar, mas pelo menos dá pra jogar.

Pode ter algo a ver com isso, inclusive. Sobre a minha placa ter ou não suporte no Manjaro, eu só encontrei isso:

Nesse comentário, o colega diz que a minha placa é suportada pelo driver 455xx da Nvidia, bem recente. Infelizmente o comentário é de novembro do ano passado.

Pensando nisso, tô achando que pra ter uma experiência melhor eu teria que ir pra uma distribuição como o Pop, que tem um suporte mais direcionado para placas Nvidia. Não queria abrir mão de uma distro rolling release, devo dizer kkkkkkkkk mas se for o jeito… A longo prazo pode me incomodar não poder usufruir mais da minha placa (que não é lá essas coisas, mas tem gente aí que joga sem placa e tem um desempenho superior!).

1 Curtida

Duas ideias que me brotaram aqui (obviamente que essas experiências devem ser feitas com cuidado, fazendo snapshots com o Timeshift):

  1. Libere as permissões do Flatpak via Flatseal - pode ser que algo melhore
  2. Instale o driver mais recente da NVidia
1 Curtida

Tem algumas permissões lá já liberadas e outras não. Aceleração de GPU tá desmarcado, sabe se isso é melhor manter assim ou se eu liberar o desempenho do jogo pode melhorar?

Eu fiz isso justamente pra poder instalar algo que encontrei no Youtube, o optimus-manager que basicamente me dá uma aplicação onde posso trocar da GPU Intel para Nvidia e vice-versa com um clique. Testei aqui e parece que funcionou, viu? O FPS subiu consideravelmente! Eu estou na verdade bem satisfeito kkkkkkkk Vou manter. Tava meio quebrando a cabeça pra entender os tutoriais escritos, então achei esse vídeo e instalei numa boa (já reiniciei o sistema e rodou normal, então tô considerando que deu tudo certo kkkk):

1 Curtida

Se funcionou, ótimo! Mas o Flatseal é uma poderosa ferramenta, estude-a com atenção…

1 Curtida