Configurações do Pop_OS! não abre!

E ai, gente!

Definitivamente meu Pop_Os 20.1 tá bugado. Achei outro problema.

Estou tentando instalar uma VPN da usp, seguindo este tutorial:

Mas na parte de abrir o “Rede”, eu travo. Aqui não abre.
O mouse fica como se estivesse carregando, mas não abre nada.

Se eu tentar abrir as “Configurações”, acontece a mesma coisa. Antes funcionava normal.

O que eu posso fazer? Tem alguma forma de por o sistema só pra corrigir bugs?

------- EDIT

Se eu for na barra de atividades e clicar em “Configurações de Wifi”, também não abre.

Se eu tentar abrir pelo terminal, acontece isso:

xxxxxx@pop-os:~$ gnome-control-center
gnome-control-center: error while loading shared libraries: libpop_upgrade_gtk.so.0: cannot open shared object file: No such file or directory
xxxxxx@pop-os:~$ sudo apt install gnome-control-center
[sudo] senha para xxxxxx: 
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
gnome-control-center is already the newest version (1:3.38.1-2ubuntu1pop1~1605745629~20.10~4259dd4).
gnome-control-center configurado para instalar manualmente.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

1 curtida

Resolvido!

Abri uma Issue no github deles e um cara me respondeu.

Só rodei esse comando e as bibliotecas foram atualizadas, e aí funcionou:

sudo ldconfig

Quem tiver interessado em ver mais, está aqui: Settings not opening (Pop_OS 20.1) · Issue #130 · pop-os/gnome-control-center · GitHub

1 curtida

Tentei no Terminal sudo ldconfig e não funcionou, li no Git Hub Settings not opening e fiz conforme outro usuário no Terminal

$ sudo apt-get install libpop-upgrade-gtk mas apresentou o erro abaixo

Os pacotes a seguir têm dependências desencontradas:
libpop-upgrade-gtk : Depende: pop-upgrade (= 0.1.1~1607014658~20.04~5ad4389) mas 0.1.0~1603472643~20.04~05600dc está para ser instalado

fui desinstalar esse pacote mas pode dar zica da grande …

Os pacotes a seguir serão REMOVIDOS:
gnome-control-center libpop-upgrade-gtk pop-desktop pop-upgrade
Os seguintes pacotes mantidos serão mudados:
pop-upgrade
AVISO: Os pacotes essenciais a seguir serão removidos.
Isso NÃO deveria ser feito a menos que você saiba exatamente o que você está fazendo!
pop-desktop gnome-control-center (por causa de pop-desktop)

alguma dica ?

2 curtidas

Puts, nao sei não :frowning:

talvez tentar reinstalar o pacote… mas não sei viu :frowning: