Compartilhamento simples com samba entre máquinas com linux mint

Bem… todos os equipamentos ( 2 notes e 1 PC) estão com o Linux Mint 19.2 Cinnamon, na mesma rede.

O meu PC tem um HD de 2TB em NTFS com arquivos gerais (documentos, planilhas, músicas, vídeos, etc) e esta é montada automaticamente via fstab. Estou tentando compartilhar este HD na rede, compartilhamento simples, sem que seja um servidor parrudo, mas, que o usuário acesse digitando usuário e senha (pode ser o usuário do próprio PC), pois quero impedir que “visitantes” acessem o compartilhamento, ou seja, sem permissão para “convidados”.

Instalei o samba e configurei o smb.conf conforme “Ctrl V” abaixo:

# Definições Globais
[global]
	workgroup = lampugnani
	server string = Samba Server %v
	netbios name = PC-Elvio
	security = user
	map to guest = bad user
	dns proxy = no
	usershare owner only = false
;	encrypt passwords = yes
;	guest ok = no
;	guest account = nobody
	username map = /etc/samba/smbusers
	log file = /var/log/samba/smb.log

#============================ Share Definitions ============================== 
[Dados]
	path = /mnt/Seguranca
	available = yes
	browseable = yes
	writeable = yes
	force user = nobody
	valid users = elvio alessandra
	comment = Pasta de dados e arquivos no PC do Elvio
	create mask = 0777
	directory mask = 0777	

[Developer]
	path = /mnt/Developer
	available = yes
	browseable = yes
	writeable = yes
	force user = nobody
	valid users = elvio alessandra
	comment = Pasta de desenvolvimento(s) no PC do Elvio
	create mask = 0777
	directory mask = 0777

Porém, quando vou na máquina cliente, que vai acessar, digitando “smb://”, não localiza os compartilhamentos.

screenshot

Acho que está faltando algo… mas, ainda não descobri o que é.

Caso alguém tenha alguma sugestão, agradeço.

Minha sugestão é usar compartilhamento por NFS se todas as máquinas são linux.

No windows está funcionando? se sim, deixe como está.
No linux, faça o compartilhamento via NFS(Não importa a cor do gato, importa que ele pegue o rato).

sudo apt-get update && sudo apt-get install nfs-kernel-server
sudo nano /etc/exports
prencher:
‘caminho’ ip de quem pode acessar(permissões)
ex:
/mnt/seguranca 192.168.0.10(rw,async) se quiser que todos possam acessar use * no lugar de 10.

depois de salvar, execute os comandos:

sudo service nfs-kernel-server restart
sudo exportfs -v -a

e pronto, ta funcionando, basta montar nas maquinas clientes agora.

Espero ter ajudado.

Sobre o samba e o nfs, é como eu disse, Não importa a cor do gato, importa que ele pegue o rato.

Isso é minha opinião é claro, mas se conseguir solução, sem usar o nfs, compartilhe conosco.

valeu.

1 Curtida

ok - vou ver essa sugestão, afinal, não tenho Windows na rede, salvo eventual manutenção em notes/PCs de clientes/amigos!

valeu pelas dicas… não tenho máquinas Windows na minha rede… salvo, quando faço manutenção de notes/PCs de clientes.

1 Curtida

Bem… embora pareça ser rápido de configurar, vou testar nas férias…

Por hora, descobri o seguinte: o serviço “smbd” não está iniciando com o sistema… se eu inicializar o serviço manualmente, tudo funciona normal, mas, após o reboot, tenho que dar o comando manual…

$ sudo systemctl enable smbd.service

… veremos se no próximo boot vai automático!
:smiley:

Estranho, pois tenho um servidor ubuntu-server onde está utilizando o samba para os usuários da rede que utilizam windows, e também, NFS que neste caso está fazendo conexão com o DVR(gravador de câmeras).

No caso do ubuntu server o samba inicia automaticamente, ai vai depender de qual distribuição você está utilizando.

mas no seu caso, basta então você colocar esse comando no crontab, que ele vai executar sozinho ao iniciar.

sim… tb achei estranho… mas a ideia é essa… qq coisa, vai no crontab mesmo.!
A distro que estou utilizando é o Linux Mint 19.2

Agora ficou mais estranho ainda, o Mint devia iniciar automaticamente o samba.

você executou o comando: sudo apt-get install samba samba-common samba-client ?

Se não instale eles, e depois veja se resolve.

sim… até executei o comando novamente, para me certificar… estão instalados… realmente não entendi pq não iniciou automático… enfim… vou dar um reboot remoto e ver se inicializa o serviço.

1 Curtida

isso… com o " systemctl enable", após o reboot, funcionou… parece que o serviço agora inicializa normalmente.

É isso… valeu!

1 Curtida