Como retirar a interface gráfica do linux mint

Olá, pessoal.

Recentemente vendo uns vídeos sobre como o gnome do ubuntu era bom pra produtividade e foco, resolvi instalá-lo no meu mint pra ver se me adaptava a ele.
Fiz isso, mas larguei e voltei para o mate, que pra mim é ótimo.
O problema é que ao tentar retirar o gnome, quando desligo e ligo o pc novamente, eu não consigo logar. Mesmo refazendo instalção do mate, com apt-get install mint-meta-mate, eu ponho senha e volta para tela de login.
Tive que refazer a instalação do gnome.

Agora tenho o gnome e um monte de software duplicado no meu sistema que veio de brinde com ele. Como retiro o gnome e os softwares dele sem afetar o mate, de forma que eu logue normalmente?
Desde já agradeço.

Qual foi o nome do pacote com que instalaste o gnome?

1 curtida

Remova o gnome e instale o LightDM

sudo apt install lightdm

1 curtida

Você encontra um histórico com todos os pacotes instalados, por dia e por hora, em:

/var/log/apt/history.log

Basta localizar o dia e a hora que você instalou o gnome, e desinstalar todos os pacotes indicados ali.

Em geral, existem vários logs por ali, com o histórico do último ano:

/var/log/apt>$ ls -1
eipp.log.xz
history.log
history.log.1.gz
history.log.2.gz
history.log.3.gz
history.log.4.gz
history.log.5.gz
history.log.6.gz
history.log.7.gz
history.log.8.gz
(etc.)

Para restabelecer o LightDM, você também pode usar este comando:

sudo dpkg-reconfigure lightdm

Vai aparecer alguma coisa parecida com isso, daí basta você escolher o LightDM:

1 curtida

Perdão a demora, galera.

Eu dei o update no meu apt e depois rodei “sudo apt-get install gnome-shell”, como tem aqui: Não desinstale o Ubuntu, apenas mude a interface parte 7 – Gnome 3
Ainda não testei as sugestões, mas assim que eu testar, comento aqui se deu certo.
Dese já agradeço quem se disponibilizou a responder.

Nesse vídeo eu ensinei a instalar o KDE Plasma, e no final ensino a remover o DE antigo.

2 curtidas

Achei isso nos logs:

Start-Date: 2021-01-04  20:23:38
Commandline: apt-get remove gnome-shell
Requested-By: caio (1000)
Remove: gnome-shell-extension-redshift:amd64 (3.20.1-2), ubuntu-session:amd64 (3.28.1-0ubuntu3), ubuntu-desktop:amd64 (1.417.5), gdm3:amd64 (3.28.3-0ubuntu18.04.6), gnome-shell:amd64 (3.28.4-0ubuntu18.04.3), gnome-shell-pomodoro:amd64 (0.13.4-2)
End-Date: 2021-01-04  20:24:12

Start-Date: 2021-01-04  20:31:14
Commandline: apt-get install gnome-shell
Requested-By: caio (1000)
Install: ubuntu-session:amd64 (3.28.1-0ubuntu3, automatic), gnome-user-guide:amd64 (3.28.2+git20180715-0ubuntu0.1, automatic), gnome-shell:amd64 (3.28.4-0ubuntu18.04.3)
End-Date: 2021-01-04  20:31:38

Start-Date: 2021-01-04  21:27:23
Commandline: /usr/bin/apt install mint-meta-xfce
Requested-By: caio (1000)
Install: xfce4-systemload-plugin:amd64 (1:1.2.1-0ubuntu1, automatic), xfce4-appfinder:amd64 (4.12.0-2ubuntu2, automatic), xubuntu-icon-theme:amd64 (18.04.5, automatic), libthunarx-2-0:amd64 (1.6.15-0ubuntu1.18.04.1, automatic), thunar-media-tags-plugin:amd64 (0.2.1-1, automatic), exo-utils:amd64 (0.12.2-0ubuntu0.18.04.1, automatic), thunar-data:amd64 (1.6.15-0ubuntu1.18.04.1, automatic), libgnomecanvas2-common:amd64 (2.30.3-3, automatic), libgnomeui-0:amd64 (2.24.5-3.2, automatic), xfce4-timer-plugin:amd64 (1.6.0-1build1, automatic), gtk2-engines-xfce:amd64 (3.2.0-3, automatic), libxfce4ui-common:amd64 (4.13.4-1ubuntu1, automatic), xfce4-screenshooter:amd64 (1.8.2-2, automatic), xfce4-mailwatch-plugin:amd64 (1.2.0-2ubuntu2, automatic), gir1.2-clutter-1.0:amd64 (1.26.2+dfsg-4, automatic), libtumbler-1-0:amd64 (0.2.1-0ubuntu1, automatic), libxfce4panel-2.0-4:amd64 (4.12.2-1ubuntu1mint2, automatic), xfce4-whiskermenu-plugin:amd64 (2.3.0-0ppa1~bionic, automatic), libxfce4util7:amd64 (4.12.1-3, automatic), gir1.2-cheese-3.0:amd64 (3.28.0-1ubuntu1, automatic), xfce4-time-out-plugin:amd64 (1.0.2-0ubuntu1, automatic), xfce4-settings:amd64 (4.12.4-0ubuntu0.18.04.1, automatic), mint-meta-xfce:amd64 (2018.11.28), libxfce4ui-1-0:amd64 (4.13.4-1ubuntu1, automatic), libexo-1-0:amd64 (0.12.2-0ubuntu0.18.04.1, automatic), libxfce4ui-2-0:amd64 (4.13.4-1ubuntu1, automatic), libbonobo2-common:amd64 (2.32.1-3, automatic), libexo-2-0:amd64 (0.12.2-0ubuntu0.18.04.1, automatic), xfce4-panel:amd64 (4.12.2-1ubuntu1mint2, automatic), thunar-volman:amd64 (0.8.1-2, automatic), xfwm4:amd64 (4.13.0-2~downgrade-4.12.5-1ubuntu0.18.04.1+tara, automatic), libbonoboui2-common:amd64 (2.24.5-4, automatic), thunar-archive-plugin:amd64 (0.3.1-4, automatic), gir1.2-cogl-1.0:amd64 (1.22.2-3ubuntu1, automatic), libgnomeui-common:amd64 (2.24.5-3.2, automatic), xfce4-eyes-plugin:amd64 (4.5.0-1, automatic), tumbler:amd64 (0.2.1-0ubuntu1, automatic), mugshot:amd64 (0.4.0-1, automatic), xfconf:amd64 (4.12.1-1, automatic), libexo-common:amd64 (0.12.2-0ubuntu0.18.04.1, automatic), libgnome-2-0:amd64 (2.32.1-6, automatic), thunar:amd64 (1.6.15-0ubuntu1.18.04.1, automatic), tumbler-common:amd64 (0.2.1-0ubuntu1, automatic), xfdesktop4:amd64 (4.12.3-4ubuntu2, automatic), libbonoboui2-0:amd64 (2.24.5-4, automatic), libxfce4util-bin:amd64 (4.12.1-3, automatic), gir1.2-coglpango-1.0:amd64 (1.22.2-3ubuntu1, automatic), xfce4-quicklauncher-plugin:amd64 (1.9.4-11build1, automatic), xfce4-verve-plugin:amd64 (1.1.0-1, automatic), libgnomevfs2-common:amd64 (1:2.24.4-6.1ubuntu2, automatic), xfce4-cpufreq-plugin:amd64 (1.1.3-1, automatic), xscreensaver:amd64 (5.36-1ubuntu1, automatic), libgarcon-common:amd64 (0.6.1-2linuxmint1, automatic), xfce4-screenshooter-plugin:amd64 (1.8.2-2, automatic), libtagc0:amd64 (1.11.1+dfsg.1-0.2build2, automatic), libgnomevfs2-0:amd64 (1:2.24.4-6.1ubuntu2, automatic), xfce4-session:amd64 (4.12.1-3ubuntu3, automatic), libxfce4util-common:amd64 (4.12.1-3, automatic), liborbit-2-0:amd64 (1:2.14.19-4, automatic), libgnomecanvas2-0:amd64 (2.30.3-3, automatic), libxfconf-0-2:amd64 (4.12.1-1, automatic), libbonobo2-0:amd64 (2.32.1-3, automatic), libxfcegui4-4:amd64 (4.10.0-4, automatic), xfce4-places-plugin:amd64 (1.7.0-3, automatic), xfdesktop4-data:amd64 (4.12.3-4ubuntu2, automatic), gir1.2-gtkclutter-1.0:amd64 (1.8.4-3, automatic), libgarcon-1-0:amd64 (0.6.1-2linuxmint1, automatic), libgnome2-common:amd64 (2.32.1-6, automatic), greybird-gtk-theme:amd64 (3.22.8-1, automatic), libexo-helpers:amd64 (0.12.2-0ubuntu0.18.04.1, automatic)
End-Date: 2021-01-04  21:31:09

Start-Date: 2021-01-04  21:38:39
Commandline: /usr/bin/apt autoremove
Requested-By: caio (1000)
Remove: libmono-system-numerics4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), linux-headers-4.15.0-126-generic:amd64 (4.15.0-126.129), linux-modules-4.15.0-126-generic:amd64 (4.15.0-126.129), libmono-system-runtime-serialization-formatters-soap4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), linux-image-4.15.0-126-generic:amd64 (4.15.0-126.129), bamfdaemon:amd64 (0.5.3+18.04.20180207.2-0ubuntu1), libmono-system-componentmodel-dataannotations4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-ldap4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-web-applicationservices4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libplank1:amd64 (0.11.4-2), libmono-system-enterpriseservices4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-data4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libgnome-keyring1.0-cil:amd64 (1.0.0-5), libmono-ldap4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), linux-modules-extra-4.15.0-126-generic:amd64 (4.15.0-126.129), libnotify0.4-cil:amd64 (0.4.0~r3032-7build1), libmono-data-tds4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libbamf3-2:amd64 (0.5.3+18.04.20180207.2-0ubuntu1), libmono-system-servicemodel-internals0.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-web4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-design4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-runtime-serialization4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-xml-linq4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-web-services4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), gnome-shell-pomodoro-data:amd64 (0.13.4-2), libmono-system-transactions4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), linux-headers-4.15.0-126:amd64 (4.15.0-126.129), libplank-common:amd64 (0.11.4-2), libmono-webbrowser4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-system-windows-forms4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-sqlite4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libmono-accessibility4.0-cil:amd64 (4.6.2.7+dfsg-1ubuntu1), libgkeyfile1.0-cil:amd64 (0.1-5)
End-Date: 2021-01-04  21:40:58

Start-Date: 2021-01-04  21:42:22
Commandline: apt-get install ubuntu-desktop --no-install-recommends
Requested-By: caio (1000)
Install: ubuntu-desktop:amd64 (1.417.5), gdm3:amd64 (3.28.3-0ubuntu18.04.6, automatic)
End-Date: 2021-01-04  21:42:42

Devo então apagar um por um os pacotes e rodar esse comando do lightdm, certo? Pior que quando apaguei de uma vez a DE, acho que cheguei a usar algo com lightdm e não acontecia nada.
Após deletar um por um os softwares do ubuntu, o que devo fazer?

De acordo com o Log, no dia 4 de Janeiro você fez isto:

  1. Às 20:23, você removeu alguns pacotes relacionados ao gnome-shell (inclusive o gdm).

  2. Às 20:31, você instalou de novo gnome-shell, o que trouxe mais alguns pacotes (mas não o gdm).

  3. Às 21:27, você instalou mint-meta-xfce, que é um meta-pacote, provocando a instalação de todo o ambiente Xfce. ─ Nenhum sinal de que tenha instalado nenhum “display manager” (dm). Portanto você ainda tinha algum dm.

  4. Às 21:38, você executou uma remoção automática de tudo que não tinha mais motivo de manter instalado. ─ Uma bela limpeza.

  5. Às 21:42, você instalou ubuntu-desktop, que é outro caminho para instalar o gnome, mas frisou que não queria instalar pacotes “recomendados”. ─ Mas, você já tinha instalado o gnome-shell, antes disso, então não tinha quase nada faltando. ─ Nessa hora, reinstalou o gdm, e é provável que ele esteja no comando da sua “tela de Login”, desde então.

Não existe nenhuma indicação de que você tenha instalado ou removido o LightDM, então é possível que ele esteja instalado.

Claro, não sei o que mais você fez nesses 2 meses, do início de Janeiro, até agora. ─ No mínimo, houve várias atualizações.

O que posso sugerir, é apenas um “procedimento lógico”, pois não conheço Gnome, nem o MATE, e há tempos não uso Xfce.

Pela lógica:

a) Primeiro, fazer um backup (snapshot) do sistema pelo Timeshift ─ caso você tenha o Timeshift instalado ─ e se certificar de fazer isso de novo, a cada passo descrito aqui.

Caso tenha pouco espaço na /home, primeiro elimine os snapshots anteriores ─ e em seguida crie o “primeiro” snapshot, citado acima.

b) Atualize o sistema! ─ É importante fazer isso, antes de instalar coisas novas. ─ Faça outro snapshot, caso o Timeshift não tenha feito isso de novo após atualizar o sistema.

c) Execute aquele comando sudo dpkg-reconfigure lightdm para ter certeza de que o LightDM será seu “display-manager” daqui por diante. ─ Reinicie o computador e, na tela de Login, escolha a sessão MATE.

Se conseguir entrar na sessão MATE, pode deixar para fazer o resto outro dia, com calma, pois o mais urgente você já conseguiu. ─ Se não conseguir entrar na sessão MATE, instale o meta-pacote MATE, para ver se falta alguma coisa.

Se mesmo assim não conseguir entrar na sessão MATE, não execute o próximo passo.

d) Remova os pacotes instalados nas etapas (2) Gnome-shell; (3) Meta-Xfce; e (5) Ubuntu-desktop.

Eu faria isso pelo Synaptic, pois ele sempre dirá se a remoção de um pacote também vai eliminar outros. ─ Aí, você verifica se esses outros estão na sua lista de eliminações, e concorda. ─ Se ele falar que vai eliminar alguma coisa que não estava na sua lista de eliminações, procure ver do que se trata, antes de concordar. O Synaptic tem um campo de busca, basta copiar o nome e pesquisar, para ver do que se trata.

Se quiser salvar uma lista de todos os pacotes atualmente instalados no seu Mint, execute esse comando, que vai gerar um arquivo na sua pasta pessoal:

$ dpkg --get-selections | grep -v deinstall > Todos-os-pacotes-instalados.txt

@cnemo, pelas suas dúvidas anteriores, tenho a impressão de que você não está muito familiarizado com esses processos todos, e talvez esse roteiro possa assustá-lo.

Antes de fazer tudo isso, esqueça os nomes desses inúmeros pacotes, e procure entender apenas a “lógica” desses passos que eu sugeri. ─ Se fizer sentido para você, siga em frente. ─ Se você se sentir “no escuro”, deixe para outro dia, ou considere outra solução (por exemplo, reinstalar o Mint MATE).

Tenho pouca experiência nessa remoção de uma interface gráfica. ─ Minha experiência mais recente foi instalar o KDE no Mint 20 ─ mas depois removi apenas uma parte da DE original.

Caso ajude a se familiarizar com esses procedimentos:

1 curtida

Massa, @frc_kde.
Antes de você responder, eu já tinha ido fuçar o sistema de acordo com o que o pessoal falou.
Antes de tudo eu executei o dpkg-reconfigure lightdm, e depois segui a dica de ir deletando um por uns os pacotes pelo synaptic.

Ainda bem que fiz pelo synaptic, porque não realizei o procedimento sugerido de criar o snapshot, apesar de estar ciente de que poderia quebrar meu sistema.

No entanto, observando as aplicações que tinham no meu pc, que eu não havia baixado ou sequer utilizado, eu ia buscando no synaptic e excluindo-as. Depois pesquisei por gnome-shell e ubuntu-desktop e vi que o Synaptic apontava que se tratava justamente da DE que eu buscava excluir.

Feito isso, e meu computador se mantendo, supus que deu certo, algo que tive certeza quando reiniciei o computador e vi o display-manager que eu usava antes. De fato o gdm tava sobrepondo o lightdm.
(Era estranho ligar meu pc com tela de login do ubuntu e o sistema mint kkkkkk)

Até tenho certa familiaridade devido cursos técnicos do linux @frc_kde, mas evitando fazer besteira, achei mais prudente pedir ajuda, já que nunca tinha removido uma DE.

Enfim. Deu tudo certo e eu agradeço demais a você e todos que me ajudaram.

1 curtida