Como mudar o layout do teclado

Recentemente eu instalei varias vezes o ubuntu e tinha o layout perfeito para o meu teclado (que è bem esquisito)
porem na ultima instalacao escolhi o layout errado e ele nao aparece nas “fontes de entrada” do sistema
Alguèm sabe onde eu posso configurar esse layout?

2 Curtidas

O layout em especifico è
Espanhol (America Latina) dead tilde

1 Curtida

Olá @MATEUS_WITECK :wave:t2:

Conseguiria ir no caminho onde esta o locale gen? etc/locale.gen
Se sim abre ele com o bloco de notas e apaga o # no idioma específico. Acredito que seja es_ES.UTF-8 UTF-8
Salva e no terminal digita locale-gen

Edited: não precisa do sudo e é UTF por isso editei.
:pray:t2:

Qual é o layout do teclado? :thinking:

1 Curtida

Não aparece nada nas configurações do Ubuntu/Gnome? Muito estranho! Acho que devia de aparecer lá alguma coisa…

2 Curtidas

Já tentou pesquisar nessa opção? :thinking:

1 Curtida

Sim, mas n]ao tem a opcao do

1 Curtida

Aparece isso para mim:
Qual eu escolho?

1 Curtida

Então esta opção pode estar “oculta” no locale gen… Você conseguiria chegar lá?
Se for isso, nem com mágia o teclado espanhol irá aparecer lá em “fontes de entrada” por isso de descomentar a linha # es_ES.UTF-8 UTF-8 apagando o # e depois subir o novo locale gen…

Isso, vai descendo até encontrar o # es_ES.UTF-8 UTF-8 e apaga o #

Um exemplo eu deixo tudo comentado com #, para ficar menos bagunçado esta parte do “fontes de entrada” só aparecem 2 idiomas, que eu estudo :smile:

1 Curtida

Aparecem as mesmas fontes, nada mudou aqui
Captura de tela de 2021-02-02 21-10-37

1 Curtida

Você executou o locale-gen no terminal depois de desmarcar e salvar no nano né? Só para checar…
Ah esqueci de dizer, tem vezes que precisa reiniciar o computador para o locale gen ter efeito.

1 Curtida

reiniciei, continua igual

Então teriamos de descobrir qual é o formato certo… lá em locale gen, descomenta tudo que é espanhol, salva e execute o comando locale-gen dai reinicia denovo mas antes disso roda um:

sudo apt-get update e sudo apt-get upgrade para garantir.

Tava pesquisando aqui, parece que é o es_AR.UTF8 UTF8 da Argentina… Ele sim é latino americano, então foi falha minha… tenta descomentar este para ver se vai e perdão a bobeira o es_ES é espanhol europeu.

descomentei todas em es, mas nao mudou nada nas configuracoes do ubuntu
mesmo reiniciando

Então complicou :sweat_smile: :joy:

Estou realizando umas pesquisas aqui para solucionarmos mas está parecendo um problema que tivemos no Manjaro @chimpa_theist conseguiu resolver… Se bem que lá na verdade era “apenas” reconfigurar o ç
Se alguém mais tiver outras idéias :innocent:

Edited: Eu usei mau o “apenas” peço perdão ao chimpa_theist pois foi uma luta brava para resolver aquele problema e ele conseguiu! Por isso re editei este comentário.

Tenta executar somente este comando:

sudo locale-gen es_AR.UTF-8

e reinicia o computador para ver.

3 Curtidas

aeeeeeeeeeee
DEU

1 Curtida

Muito obrigado @RuKsu !

1 Curtida

Aeee, :v:t2: Eu que agradeço e fico muito feliz em poder ter ajudado!

:pray:t2: