Como instalar zsnes no lubuntu

Galera quando vou tentar instalar o emulador zsnes no lubuntu LXQT 14.1 via terminal da o seguinte erro:
O pacote ‘zsnes’ não tem candidato para instalação.
Já tentei com pacote .deb mas também da erro.
Alguém sabe como resolver?
Obrigado.

1 Curtida

já tentou o retroarch?

Você está usando o lubuntu na versão 14.1? (não sei se entendi direito o que escreveu)
Se não, qual versão está usando?

De esse comando no terminal e poste o retorno dele:

apt search zsnes

E o LXQT que ta na versão 0.14.1 kkkkkkkkkkkkkkk ele deve ter ido no about do Desktop environment, e o 19.04 ou 19.10

O zsnes foi descontinuado ja a bastante tempo, o melhor e vc usar o snes9x disponível no flatpak

Tente:
sudo apt install zsnes-dbg

Se n der certo, só adicionando algum repositório que contém o pacote zsnes.
Os que meu SO usa e que têm o pacote zsnes-dbg e bibliotecas necessárias são:

1 Curtida

Ahhh pow kkkk é que ninguém passa a versão da interface que está usando e sim a do SO e como não to acompanhando o lxqt eu nem imaginei que seria isso kkkkkkkkk xD

Então eu nunca usei ele e nem sei se foi descontinuado mas se foi ele ainda está no repositório do ubuntu 18.04, por isso que pedi pra ele usa o apt search pra vê se não tava no repositório dele e se ele não tinha digitado nada errado na hora de usa o apt install
image

1 Curtida

Cara, zsnes é mais antigo que casar com primo no Alabama, usa o snes9x que é o mais recomendado. Ou o core bsnes dentro do retroarch.

O zsnes é 32-bit. Se você quiser instalá-lo precisa adicionar a arquitetura i386, assim terá a disposição os pacotes e bibliotecas 32 bits.

Eu uso o snes9x, é muito bom mesmo! Mas se quiser usar o zsnes, faça o seguinte:

sudo dpkg --add-architecture i386
sudo apt update
sudo apt install zsnes

Resolvido!
Mas e depois se eu quiser remover a arquitetura? Simples, remova todos os pacotes instalados que são 32 bits e depois remova a arquitetura:

sudo apt-get purge “.*:i386”
sudo dpkg --remove-architecture i386

Obs: testado no ubuntu 18.04

3 Curtidas

Também prefiro usar o ZSNES, é antigo mas gosto da interface única dele.


Habilite o suporte a 32bit com o comando abaixo:

sudo dpkg --add-architecture i386

Abra o gerenciador de pacotes ou central de aplicativos e procure por “zsnes”. Muito provavelmente você achará o pacote zsnes-dbg:i386, selecione para instalá-lom que ele automaticamente instalará o pacote zsnes:i386

2 Curtidas

Deu certo amigo. Valeu,muito obrigado!