Como fazer o Firefox iniciar com aceleração de Hardware

Como iniciar o firefox com MOZ_X11_EGL=1 automaticamente sem precisar colocar MOZ_X11_EGL=1 firefox no terminal ?

1 Curtida

• Abra o firefox normalmente;
• Na barra de pesquisa, digite: about:config;
• Dentro de “about:config” procure por: layers.acceleration.force-enabled e marque como true;
•Reinicie o navegador.

Source: How to enable hardware acceleration on Mozilla Firefox | Our Code World

5 Curtidas

então, já coloquei essa como true mas só funciona quando executo MOZ_X11_EGL=1 firefox no terminal, com isso consigo assistir vídeos até em 4k, sem isso não passa de 720p travando
já instalei o VA-API driver correto pra gpu, flags:
media.ffmpeg.vaapi.enabled true
media.ffvpx.enabled false
media.rdd-vpx.enabled false
media.navigator.mediadatadecoder_vpx_enabled true
layers.acceleration.force-enabled true
https://wiki.archlinux.org/index.php/Firefox#Hardware_video_acceleration
tentei fazer parecido com chromium, mas não deu muito certo
Exec=/usr/lib/firefox/firefox MOZ_X11_EGL=1 %u

Muda o comando de inicialização do firefox:

Bem estou no KDE, se for no gnome aí eu já não lembro como muda isso.

5 Curtidas

Valeu! está funcionando, deixei assim :smiley:


agora não precisa mais abrir pelo terminal :slightly_smiling_face:

3 Curtidas

@Joey, como você fez para confirmar que a aceleração por hardware foi habilitada?

3 Curtidas

Atualmente não precisa mais fazer isso no Firefox 87 ou superior. Basta ativar as seguintes flags: gfx.webrender.all (apenas se o webrend r já não estiver ativo em about:support), gfx.prefer-x11-egl (deixa em true) e deixar em true as duas flags ffmpeg vaapi. Resumindo: não precisa mais iniciar o Firefox com a variável: MOZ_X11_EGL=1

Sobre as flags citadas anteriormente:

media.ffvpx.enabled false (somente se sua gpu n suportar vp9)
media.rdd-vpx.enabled false (Não precisa mexer aki, não altera nada)
media.navigator.mediadatadecoder_vpx_enabled true (não precisa mexer aqui, não altera nada)
layers.acceleration.force-enabled (não precisa mexer aki, não altera nada e é uma flags antiga que não influencia em nda no webrender)

1 Curtida

Essa informação está incorreta. Se o seu hardware não estiver na whitelist ou vc estiver usando uma tela de 4K, o webrender vai continuar não-habilitado por padrão… Então você deve habilitar manualmente a opção layers.acceleration.force-enabled e correr os riscos de encontrar falhas gráficas… No meu caso, compensa…

https://wiki.mozilla.org/Platform/GFX/WebRender_Where#Linux